Reply

Kernel panic WNAP320

Lumenare
Aspirant

Kernel panic WNAP320

Hi All, Netgear Community!

I need some help !

 

I have few WNAP320 and Controller, and one of this AP's have some problems with DHCP.

I tried update firmware via Web-GUI, but in process get BlueScreen on PC.

Now AP not working, but I connect via COM-port and see this message:

 "kernel panic-not syncing: VFS: unable to mount root fs"

 

How can I restore this device?

 

Best Regards!

Model: WNAP320|ProSafe Wireless-N Access Point
Message 1 of 5
schumaku
Guru

Re: Kernel panic WNAP320

The WNAP320 can be recovered from failed firmware updates using the tftp method - How to upload firmware to a NETGEAR router using TFTP.

 

 

Message 2 of 5
Lumenare
Aspirant

Re: Kernel panic WNAP320

Dear shumaku , thank you for Your answer.

 

I tried this way, but, unfortunally, it not work.

Here log of boot, when i connected via Com port:

Spoiler
U-Boot 1.1.4 dni-1.09 (Jul  1 2010 - 11:39:24)

AP94 (ar7100) U-boot 0.0.12
DRAM:  b8050000: 0xc0140180
128 MB
Top of RAM usable for U-Boot at: 88000000
Reserving 228k for U-Boot at: 87fc4000
Reserving 192k for malloc() at: 87f94000
Reserving 56 Bytes for Board Info at: 87f93fc8
Reserving 36 Bytes for Global Data at: 87f93fa4
Reserving 128k for boot params() at: 87f73fa4
Stack Pointer at: 87f73f88
Now running in RAM - U-Boot at: 87fc4000
id read 0x100000ff
flash size 8MB, sector count = 128
Flash:  8 MB
In:    serial
Out:   serial
Err:   serial
Net:   ag7100_enet_initialize...
No valid address in Flash. Using fixed address
: cfg1 0xf cfg2 0x7014
 VSCXXX Found 0  unit 0:0  phy_addr: 1  id: 004dd04e
PHY:   Atheros AR8021
eth0: 00:03:7f:09:0b:ad
eth0 up
eth0
Manu data is valid!
### main_loop entered: bootdelay=4

### main_loop: bootcmd="bootm 0xbf050000"
Enter SPACE to drop into boot loader:  0
## Booting image at bf050000 ...
   Image Name:   Linux Kernel
   Created:      2017-10-09  11:29:27 UTC
   Image Type:   MIPS Linux Kernel Image (gzip compressed)
   Data Size:    983040 Bytes = 960 kB
   Load Address: 80020000
   Entry Point:  8020e000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 8020e000) ...
## Giving linux memsize in bytes, 134217728

Starting kernel ...
▒Linux version 2.6.23-WNAP320_V3.7.9.0-gaecb3146-dirty (root@cbuap-build2.netgear.com) (gcc version 4.2.4) #1 Mon Oct 9 04:16:31 PDT 2017
flash_size passed from bootloader = 8
arg 1: console=ttyS0,9600
arg 2: rootfstype=squashfs
arg 3: root=31:03
arg 4: init=/sbin/init
arg 5: mtdparts=ar7100-nor0:256k(u-boot),64k(u-boot-env),1024k(vmlinux.gz.uImage),6208k(rootfs),512k(var),64k(manufacturing-data),64k(ART)
CPU revision is: 00019374
Determined physical RAM map:
 memory: 08000000 @ 00000000 (usable)
Built 1 zonelists in Zone order.  Total pages: 32512
Kernel command line: console=ttyS0,9600 rootfstype=squashfs root=31:03 init=/sbin/init mtdparts=ar7100-nor0:256k(u-boot),64k(u-boot-env),1024k(vmlinux.gz.uImage),6208k(rootfs),512k(var),64k(manufacturing-data),64k(ART)
Primary instruction cache 64kB, physically tagged, 4-way, linesize 32 bytes.
Primary data cache 32kB, 4-way, linesize 32 bytes.
Synthesized TLB refill handler (20 instructions).
Synthesized TLB load handler fastpath (32 instructions).
Synthesized TLB store handler fastpath (32 instructions).
Synthesized TLB modify handler fastpath (31 instructions).
Cache parity protection disabled
PID hash table entries: 512 (order: 9, 2048 bytes)
Using 340.000 MHz high precision timer.
console [ttyS0] enabled
Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
Memory: 127616k/131072k available (1619k kernel code, 3396k reserved, 352k data, 100k init, 0k highmem)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
registering PCI controller with io_map_base unset
NET: Registered protocol family 2
Time: MIPS clocksource has been installed.
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 4096 (order: 3, 32768 bytes)
TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
TCP: Hash tables configured (established 4096 bind 4096)
TCP reno registered
AR7100 GPIOC major 0
squashfs: version 3.3 (2007/10/31) Phillip Lougher
squashfs: LZMA suppport for slax.org by jro
JFFS2 version 2.2. (NAND) © 2001-2006 Red Hat, Inc.
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver $Revision: 1.90 $ 1 ports, IRQ sharing enabled
serial8250: ttyS0 at MMIO 0x0 (irq = 19) is a 16550A
serial8250.0: ttyS0 at MMIO 0x0 (irq = 19) is a 16550A
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
7 cmdlinepart partitions found on MTD device ar7100-nor0
Creating 7 MTD partitions on "ar7100-nor0":
0x00000000-0x00040000 : "u-boot"
0x00040000-0x00050000 : "u-boot-env"
0x00050000-0x00150000 : "vmlinux.gz.uImage"
0x00150000-0x00760000 : "rootfs"
0x00760000-0x007e0000 : "var"
0x007e0000-0x007f0000 : "manufacturing-data"
0x007f0000-0x00800000 : "ART"
u32 classifier
    Actions configured
Netfilter messages via NETLINK v0.30.
TCP cubic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
List of all partitions:
1f00        256 mtdblock0 (driver?)
1f01         64 mtdblock1 (driver?)
1f02       1024 mtdblock2 (driver?)
1f03       6208 mtdblock3 (driver?)
1f04        512 mtdblock4 (driver?)
1f05         64 mtdblock5 (driver?)
1f06         64 mtdblock6 (driver?)
No filesystem could mount root, tried:  squashfs
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,3)
Rebooting in 3 seconds..

There is some console with few commands, can they help me ?

Spoiler
ar7100> help
?       - alias for 'help'
autoscr - run script from memory
base    - print or set address offset
bdinfo  - print Board Info structure
boot    - boot default, i.e., run 'bootcmd'
bootd   - boot default, i.e., run 'bootcmd'
bootelf - Boot from an ELF image in memory
bootm   - boot application image from memory
bootp   - boot image via network using BootP/TFTP protocol
bootvx  - Boot vxWorks from an ELF image
burn  - burn data into flash
cmp     - memory compare
coninfo - print console devices and information
cp      - memory copy
crc32   - checksum calculation
delay  - delay
echo    - echo args to console
erase   - erase FLASH memory
exit    - exit script
flinfo  - print FLASH memory information
gigamode  - switch the giga port in different mode
go      - start application at address 'addr'
gpio  - gpio testing command
help    - print online help
iminfo  - print header information for application image
imls    - list all images found in flash
itest   - return true/false on integer compare
loadb   - load binary file over serial line (kermit mode)
loads   - load S-Record file over serial line
loady   - load binary file over serial line (ymodem mode)
loop    - infinite loop on address range
macset - set netinterface macaddress
macshow - display mac address of eth0,eth1,wlana
md      - memory display
memtest  - memory testing command
mii     - MII utility commands
mm      - memory modify (auto-incrementing)
mtest   - simple RAM test
mw      - memory write (fill)
nfs     - boot image via network using NFS protocol
nm      - memory modify (constant address)
pci     - list and access PCI Configuration Space
ping    - send ICMP ECHO_REQUEST to network host
porttest  - port testing command
printenv- print environment variables
progmac - Set ethernet MAC addresses
protect - enable or disable FLASH write protection
rarpboot- boot image via network using RARP/TFTP protocol
reset   - Perform RESET of the CPU
run     - run commands in an environment variable
saveenv - save environment variables to persistent storage
savemd  - save manufacturing data info flash
setenv  - set environment variables
setmd  - set manufacturing data
showmd  - Display manufacturing data
sleep   - delay execution for some time
test    - minimal test like /bin/sh
tftpboot- boot image via network using TFTP protocol
version - print monitor version
wpspinset - set wpspin number
ar7100>
─────────

I tried few of this like 'tftpboot' , 'bootp'

Without results, help me please

Message 3 of 5
schumaku
Guru

Re: Kernel panic WNAP320

Have some ideas, but don't want to bring your device into risk. @RaghuHR please jump in here.

Message 4 of 5
Retired_Member
Not applicable

Re: Kernel panic WNAP320

Hi @Lumenare

 

I sent you a PM. It may be possible to recover AP, if not we can check the hardware warranty.

 

Thanks

DavidGo

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 2106 views
  • 1 kudo
  • 3 in conversation
Announcements