Reply

Re: WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

TLGinc
Aspirant

WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

I have three WAC510 AP's that I use at our business, and I have upgraded them multiple times. recently I saw there was a firmware upgrade from my v5.xx version to v8.0.1.3. I ran the update and after it finished and restarted, I coudl no longer get to the login screen. I restarted the unit, I tried factory resetting it, and I got to the first time setup and it restarted and again, I could not access the login page however it was working based on the lights and client access signal strength.

 

I then found that if I used the IP address to access the device, the configuration page loaded correctly and I noticed it redirects from http://xxx.xxx.xxx.xxx to http://xxx.xxx.xxx.xxx/AP_login. So I entered in the dns name for the device and added AP_Login after it and it loaded the login page. There appears to be a bug in this v8.x firmware update that prevents redirect to the login page when using the dns name rather than ip address.

Message 1 of 13
RaghuHR
NETGEAR Expert

Re: WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

@TLGinc  Thanks for reaching Netgear Community. Your observation is correct and is because of security fixes went in 8.0.1.3 release.

 

Please refer release notes for the fixes went in 8.0.1.3 release https://kb.netgear.com/000060753/WAC505-WAC510-Firmware-Version-8-0-1-3

 

In our next maintainanace release we will take care of accessing AP UI using DNS name. Please stay tuned.

 

Raghu

Message 2 of 13
TLGinc
Aspirant

Re: WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

I have tried firmware v8.0.5.5 on the previous WAC510 that I upgraded to v8.0.1.3 and it now is accessible via FQDN. However, the second WAC510 that I upgraded from v5.0.10.2 to 8.0.5.5 will not work via FQDN (tried clearing cache, different browsers).

 

Also, my third WAC510 which is running v5.0.10.2 will not upgrade to v8.0.1.3 or v8.0.5.5. It says that an unknown error has occurred (tried different browsers, clearing cache, resetting to factory default).

 

I have linked a file below with the error logs for the unknown error during update.

 

Log Files

Message 3 of 13
RaghuHR
NETGEAR Expert

Re: WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

Hi @TLGinc 

 

We need a detailed log for the issue "FQDN"  is not working on your second AP.

For the upgrade error we need to know what is exact error that you are seeing on the UI?May be you can share the screen shot.

 

Are you using Insight App to manage your WAC510s?

 

Thanks,

Raghu

Message 4 of 13
TLGinc
Aspirant

Re: WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

I am using browser to to manage, not Insight app. I tried Microsoft Edge, Chromium, Internet Explorer and all of them behave the same for both issues.

 

WAC510 Three Logs - v8.0.5.5 FQDN issue

 

 

Message 5 of 13
schumaku
Guru

Re: WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

Ref. the FQDN problem: There is a mostly non-documented FQDN configuration option in the WAC IP settings - suspect the idea might be that we have to "white-list" the FQDN to be used here .... complete strange, anyway - @RaghuHR can you shed some light?

 

WAC5xx FQDN config.PNG

Message 6 of 13
RaghuHR
NETGEAR Expert

Re: WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

@TLGinc  from the config we saw that you have not configured the domain to be white-listed. Please configure and confirm if it is working or not.

Message 7 of 13
schumaku
Guru

Re: WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

@RaghuHR, so the undocumented feature above is a mandatory domain (or FQDN?) white list like we guessed - required to be configured exactly to the FQDN we intend to use for the WAC Web UI access?

Message 8 of 13
TLGinc
Aspirant

Re: WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

This used to work fine before the v8 upgrades. So I went in now and added the FQDN, saved it, logged out, closed and reopened my browser and tried to access via the FQDN and I am getting an error now about the IP address not being reachable.

 

EDIT: Ok, it stopped giving me that error finally. but now after entering the FQDN it still only displays a blank white screen. To log in I have to use the IP address.

 

Message 9 of 13
TLGinc
Aspirant

Re: WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

Any word on this? This one WAC510 will not upgrade to any firmware. I tried downloading the same 5.x version, the two new 8.x versions and none of them work. It says please select a valid firmware file, and I am selecting the extracted firmware .tar file.

 

Tried resetting to factory defaults and it still won't update, I really want to get it updated for the security fixes.

Message 10 of 13
schumaku
Guru

Re: WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

@RaghuHR this FQDN whitelist is just ridiculous - get rid of this nonsense ASAP please.

Message 11 of 13
schumaku
Guru

Re: WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

@RaghuHR this FQDN whitelist is just insane - get rid of this nonsense ASAP please.

Message 12 of 13
RaghuHR
NETGEAR Expert

Re: WAC510 firmware update 8.0.1.3 breaks access to configuration website via dns name

Hi @TLGinc  Can we take a look at your setup why you are facing firmware upgrade issue? I sent you PM. Please check and respond.

 

Thanks,

Raghu

Message 13 of 13
Top Contributors
Discussion stats
  • 12 replies
  • 3184 views
  • 2 kudos
  • 3 in conversation
Announcements