Posts: 9
Registered: ‎2011-04-28

WNDAP350 incompatible with Android devices

[ Edited ]

OK. I have had it. I run 4 WNDAP350 APs at home for their dual-band and enterprise features. But I am having more and more Android devices at home, both tablets and phones.

The WNDAP350s are connected to gigabit ethernet backbones. For computers, the WNDAP350s are flawless. I have wireless security set at WPA2/AES for them.

Now if I add android devices, the android devices will connect to the WNDAP350s but after several minutes, the wifi connection will hang. The devices still show that they are connected, but there will be no communication between the devices and the AP. I have further discovered that if I reduce the network security on the WNDAP350s to WPA/TKIP, the android devices will be able to maintain the wireless connection. But the wireless speed of the whole network drops to 54M!!!!!

My WNDAP350s are on firmware 2.1.2 (current as of May 3, 2012). And I tried with multiple Android devices with the same result:
HTC Incredible S (2.3.5 2.4G)
Sony Xperia S (2.3.6 2.4G)
Samsung Galaxy S2 (4.0.3, 5G and 2.4G)
Samsung Galaxy Tab 8.9 (3.02, 5G and 2.4G)
Samsung Galaxy Note (2.3.5, 5G and 2.4G).

These devices work flawlessly (WPA2/AES) with other APs as follows:
Draytek V2920n
Buffalo AGH-300
Netgear(!!!) WNDR4500

Please help! This has been bugging me for over a year! I had to move to a cluster of WNDR4500 as a temporary solution but I am looking for something more business grade......

Discussion Stats
  • 0 replies
  • 0 kudos
  • 1 in conversation
Top Contributors