Orbi WiFi 7 RBE973

AC1900 Nighthawk cant get to admin page


AC1900 Nighthawk cant get to admin page

My Nighthawk AC1900 is functioning fine but I cannot access the admin page to check data usage.  When I go to routerlogin.net I get a loop where Netgear offers to reset the password, but when I do I just get the same reset page even with the new password.  How do I get to my admin page?

Message 1 of 3

Re: AC1900 Nighthawk cant get to admin page

What model NG product do you have? AX1900 is a wifi speed. 


Try after a factory reset.

Be sure to clear out all browser caches and any saved password profiles.

Try a different web browser to access the web page.

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode  | Wifi Router RAXE500 and RBKE963; Router mode | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX30/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, RAXE500, RAX120v2, RAX50v2, XR450/500/700/1000, EX7500/EX7700

Message 2 of 3

Re: AC1900 Nighthawk cant get to admin page

I have a Nighthawk AC1900 modem/router. I could not log in to the admin page so I did a factory reset, cleared browser cache in Microsoft Edge and Chrome ( the only browsers I use).  I tried going to and also but got a message of timeout before it connected.  I went to routerlogin.net and was able to enter a new password.  I then tried to login with 
Admin and the new password.  I was taken back to the Netgear Genie page that allows for a password reset.  I have done that twice and each time, after using Admin and the latest password I am sent back to the Netgear Genie page offering me the option to reset my password.  Fortunately, the network and wifi work fine and my devices are all connected.

How do I get to to the router admin page?

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 0 kudos
  • 2 in conversation

Orbi WiFi 7