× We are aware of an issue affecting Nighthawk CAX30 Cable Modem Routers that may have resulted in an interruption of internet service. For instructions to restore Internet connectivity click here.

C6300 Readyshare USB not detected


C6300 Readyshare USB not detected

I can't get readyshare to work. I specifically got the approved PNY 2GB Attache USB. Readyshare will show up in my network list. However if I try to add my USB it doesn't show up as detected. USB light on the front of the router does not come on.
I've also had it working in the past (about a year ago) with an external hdd, same hdd doesn't work anymore.
I've tried cycling all of the router settings individually (including ones that have nothing to do with readyshare).


On routerlogin.net (and in netgear genie):

advanced/USB Setup/basic settings: "basic" is checked, \\readyshare is the name, and no "available network folders" are displayed.


advanced/USB Setup/advanced settings: my custom workgroup name is entered, networkneighborhood and HTTP are checked and passworded, (I've tried the other options and they don't work either), no "available network folders" are displayed, if I click "create network folder it says "no disk".



advanced/advanced setup/media server: Enanble Media Server is checked


advanced/advanced setup/USB storage: USB is enabled

The only thing a little different about my home network is I am using my own DHCP and DNS server behind the router.

Model: C6300BD-1TLAUS|DOCSIS 3.0 Cable Gateway Wi-Fi AC
Message 1 of 1
Top Contributors
Discussion stats
  • 0 replies
  • 0 kudos
  • 1 in conversation

Orbi WiFi 6E