× We are aware of an issue affecting Nighthawk CAX30 Cable Modem Routers that may have resulted in an interruption of internet service. For instructions to restore Internet connectivity click here.

Can't write to HDD over Readyshare


Can't write to HDD over Readyshare

I can't write to harddrives over Readyshare on my N450 modem/router. I've tried this with two different drives. When I try to write to it, it asks me to login and then says "The operation cannot be completed because you don't have the necessary permission." I'm on Mac OS X. I've tried my username/pass for both my computer and my router.


The drive permissions in the Netgear Genie Software are set to all can read and write. The drive format is Mac OS X Extended. I've tried exFat and FAT as well, and I could only write to a FAT-formatted HDD. But that isn't useful for me because I want to the use Readyshare for TimeMachine, which requires OS X Extended.


I've tried freshly formatted drives and freshly formatted partitions. I've tried setting the partitions as Shared drives and enabling anyone to read and write. I've tried disabling the firewall on my computer. Nothing has worked.


I appreciate any suggestions, thank you.

Model: CG3000D-2CXNAS|COX N450 Cable Gateway Docsis 3.0
Message 1 of 3
Sr. NETGEAR Moderator

Re: Can't write to HDD over Readyshare

Hello drink_schlitz


Here is a article covering how to setup time machine may want to look over this to see if you may of missed a step in the process.





Message 2 of 3

Re: Can't write to HDD over Readyshare

Hi did this get resolved? I am having the exact same problem?

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 0 kudos
  • 3 in conversation

Orbi WiFi 6E