Orbi WiFi 7 RBE973

Netgear CAX30-Unable to edit port forwarding service


Netgear CAX30-Unable to edit port forwarding service


If you are unable to edit or delete a port forwarding service with a Netgear CAX30 modem router, you might consider trying this strategy that worked for me using a Firefox Browser. The problem is caused by entering a space in the Service Name when initially setting up a service in the Port Forwarding Portmap Table.  The space prevents future editing or deleting that service.  For example, if you typed Remote Desktop with a space between “Remote” and “Desktop” as the Service Name, you’ll find can no longer edit or delete that service in the future.

  1. Log into your Netgear router modem
  2. Click on the Advanced tab
  3. Click on Advanced Setup
  4. Click on Port Forwarding/Port Triggering
  5. Press F12 on your keyboard to open a Developer window to the right of you screen
  6. Go to the Port Forwarding Portmap Table at the bottom of the page
  7. Place the mouse cursor over the service name you are attempting to edit or delete (i.e., Remote Desktop)
  8. Right click on the service name (i.e., Remote Desktop) and select Inspect Element
  9. You should then see a line of text/code highlighted in the Developer window to the right that may appear as: <td>Remote&nbspDesktop</td>.
  10. In this case, you will want to remove “&nbsp” from the line and replace it with a conventional space between Remote and Desktop.  In this case you should then end up with <td>Remote Desktop</td>.
  11. Return to the LEFT Window, select the Service to be edited or deleted and click on Edit Service or Delete Service to perform the desire function.
  12. Caveat:  If this fails the first time, try again.  This initial failure is likely due to timeout of the login to the router modem. Login again and complete the process more quickly before it times out.
  13. In the future, do NOT add spaces when entering a Service Name since this will not allow you to edit or delete that service without going through the above editing process.  

I hope you found this useful.


Message 1 of 2

Re: Netgear CAX30-Unable to edit port forwarding service

* Summary: (jan 2023 - Firefox) I did not see the space written as '&nbsp' in the code, so I deleted the visual space (DEL key) and re-added a space manually with keyboard space bar and it let me delete the key


This worked for me with a slight change in procedures

- using Firefox (109 - 2023 Jan), CAX30, Service Name "My - Router"CAX30.png

Step 8: highlight service name text, right click and select  'Inspect'. (Inspect Element was not a choice for me)

Step 9/10: remove the spaces manually and then re-add them with the keyboard space.(I did not see &nbsp in the text so I removed the spaces with DEL and then added them back with the keyboard)

Step 11: now delete the service, and it deleted for me


thank you!



Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 2 kudos
  • 2 in conversation

Orbi 770 Series