Reply

Re: NightHawk CAX 30 slows until Factory Reset or config restore

akeele
Aspirant

NightHawk CAX 30 slows until Factory Reset or config restore

I have experienced this issue with this router since buying it at Costco in July 2021. My firmware is up-to-date with version 1.4.10.8. I do not have any special port forwarding or access control configured. This router does not support QoS configuration.

 

After initial setup, I get 350 - 500Mbps directly from the router over Xfinity that is provisioned for 400 Mbps. Within hours, the rate drops to 120 - 150 Mbps. This is consistent and repeatable.

 

I enabled Airtime Fairness. Nothing improved.

 

If I do a reboot, nothing is improved. This is consistent and repeatable.

 

If I do a hard factory reset, speed is temporarily restored in full. This is consistent and repeatable.

 

If I restore a backed-up configuration and then restore/overwrite + reboot, speed is temporarily restored in full. This is consistent and repeatable.

 

This router needs better firmware is all I can figure. I am not the only customer with this issue in this forum. I hope Netgear reads this post and will respond.

Message 1 of 20
plemans
Guru

Re: NightHawk CAX 30 slows until Factory Reset or config restore

How are you testing speeds? 
Wired? 

Wireless? 

Are you testing over the 2.4ghz or the 5ghz?

What device are you testing on? 

Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 2 of 20
akeele
Aspirant

Re: NightHawk CAX 30 slows until Factory Reset or config restore

Per my original post, "After initial setup, I get 350 - 500Mbps directly from the router  over Xfinity that is provisioned for 400 Mbps. Within hours, the rate drops to 120 - 150 Mbps."

 

I want to test the router's ability to handle what is provisioned. This means I logged into the router's Netgear administrative console to test internally from the router itself to avoid any potential network or wireless issues in getting to the router. I used the speed test tool on the router itself. As such, this test is neither wired nor wireless, and wireless frequency is not relevent.

 

The device I'm testing on: directly from the router 

 

Here is a link on how to check the speed between your ISP and your router: https://kb.netgear.com/000038894/How-do-I-check-my-Internet-speed. This speed test should be fairly constant, and should not be influenced by resetting the router to factory defaults, or simply reloading the current config.

Message 3 of 20
plemans
Guru

Re: NightHawk CAX 30 slows until Factory Reset or config restore

"directly from the router" isn't always the best choice as it doesn't let you choose which server it tests off. 

And if it chooses a slower server, you get slower speeds showing even if they aren't accurate. 
its why if you look on here, you see us recommending people wire a pc/laptop into their router and test that route. 

Because then you can try different speedtest sites and even servers on those sites. 

Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 4 of 20
akeele
Aspirant

Re: NightHawk CAX 30 slows until Factory Reset or config restore

Thanks for the advice.

 

Unfortunately, I do not have an Ethernet adpater for my laptops. However, I can say that testing from 2 Dell laptops (1 is band newand a Galazy 21 phone (Wifi 6 conection) through the CAX30 using Speedtest consistently mirrors what I get on the router's console within +/- 20 - 30 Mbps  from multiple testing and multple target servers. My laptop and phone are connecting through 5G from a distance of about 8 - 10 feet.

 

Again, I am able to reliably fix the slow speed within about 3 - 4 minutes by simply re-loading the saved config file and rebooting. We're talking about improving from 120Mbps pre-fix to a post-fix 400 - 500 Mbps speed in only about 4 minutes' time. The reliability of the fix proves out over across the 4 testing devices (including the router console).

 

I am not the only person to report this issue and the same fix. https://community.netgear.com/t5/Nighthawk-WiFi-Routers/CAX30-Slow-Internet-Speeds/td-p/2132543

 

Anthing you can recommend?

 

 

Message 5 of 20
akeele
Aspirant

Re: NightHawk CAX 30 slows until Factory Reset or config restore

I screen captured some tests for you to see I am not crazy. Each test is time-stamped.

 

1. I performed two "Pre-reset" tests. In the first test, I used Speedtest on the console and Speedtest running on my 5Ghz connected laptop simultaneously, wiht the laptop connected to my ISP as the test server. In the second test, I tested the console and my laptop connection simultaneously using a local university as the test server for my laptop.

 

2. I then re-loaded my saved backup config of the very configuration running on the router at the time of the tests. The screencaps are timestamped.

 

3 I then repeated the speedtests from the console and my laptop, with the laptop testing against the same test servers as before.

 

Result: I doubled my download speed within a few minutes by re-loading a backup config and rebooting. Again.

 

I get the same result if I perform a hard reset and reconfigure the router manually. It's just a lot more work.

 

See attached.Pre-Reset-1.pngPre-Reset-2.pngReset-1.pngReset-2.pngPost-Reset-1.pngPost-Reset-2.png

Message 6 of 20
akeele
Aspirant

Re: NightHawk CAX 30 slows until Factory Reset or config restore

The screen captures from the previous post went bad when I edited the post. Here it is again properly:

--------------------------------------------------

 

I screen captured some tests for you to see I am not crazy. Each test is time-stamped.

 

1. I performed two "Pre-reset" tests. In the first test, I used Speedtest on the console and Speedtest running on my 5Ghz connected laptop simultaneously, wiht the laptop connected to my ISP as the test server. In the second test, I tested the console and my laptop connection simultaneously using a local university as the test server for my laptop.

 

2. I then re-loaded my saved backup config of the very configuration running on the router at the time of the tests. The screencaps are timestamped.

 

3. I then repeated the speedtests from the console and my laptop, with the laptop testing against the same test servers as before.

 

Result: I doubled my download speed within a few minutes by re-loading a backup config and rebooting. Again.

 

I get the same result if I perform a hard reset and reconfigure the router manually. It's just a lot more work.

 

Pre-Reset-2.pngPre-Reset-1.pngReset-2.pngReset-1.pngPost-Reset-2.pngPost-Reset-1.png

 

Message 7 of 20
akeele
Aspirant

Re: NightHawk CAX 30 slows until Factory Reset or config restore

Bump. Help?

Message 8 of 20
akeele
Aspirant

Re: NightHawk CAX 30 slows until Factory Reset or config restore

Hello? Is anybody out there?

Message 9 of 20
plemans
Guru

Re: NightHawk CAX 30 slows until Factory Reset or config restore

Maybe try a wired speed test like we suggested? 

I understand you don't have a hardwired device. 

try borrowing a laptop or picking up a usb/ethernet adapter. 

Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 10 of 20
akeele
Aspirant

Re: NightHawk CAX 30 slows until Factory Reset or config restore

Did you look at the screen captures? Did you see I am testing from the modem and from a laptop through the modem at the same time? Did you see both test results shown on the same screen capture?

 

The speed test is not the problem.

Message 11 of 20
plemans
Guru

Re: NightHawk CAX 30 slows until Factory Reset or config restore


@akeele wrote:

Did you look at the screen captures? Did you see I am testing from the modem and from a laptop through the modem at the same time? Did you see both test results shown on the same screen capture?

 

The speed test is not the problem.


Yep. I did see that you're using the built in speedtest. Which isn't always accurate. which is why we ask to test a hardwired in device. 

I'm happy to sign off this thread though. 

good luck. 

Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 12 of 20
Brettmcm
Apprentice

Re: NightHawk CAX 30 slows until Factory Reset or config restore

This is crazy but I also purchased the same device through Costco ... and let me tell you it's been no picnic.... first I had the same exact problem, My speed would be less than what I had with the Xfinty modem around 700, I used to get 950. I tired every conciveable possible solution but I could never reliably find a fix that would correct the problem it would magically work sometimes and then it would drop to like 200...  then i turned back on the Armor protection and whalla .... back to 950 and all my wireless speeds went back to normal as well. I shut it off back to 200, turn back on 950 where is has remained ever since, with armor off always 200 with armor on 950. Netgear states that Armor should not have anything to do with it but all I know is with it off 200, with it on 950, reproducible every single time. There is ZERO question with my connection (could be Comast wouldn't suprise me, they are scantless). Try, if you experience the same thing maybe they'll stop calling me crazy. 

 

Let me know when you get to constant dropped and poor signal reception I've got the fix for that as well. Thanks to a Super User.. he nailed it. 

Message 13 of 20
akeele
Aspirant

Re: NightHawk CAX 30 slows until Factory Reset or config restore

Hi,

 

Yes, this was explained previously that the console speedtest is not necessarily reliable since we cannot control the destination speedtest server.

 

I also explained that I am simultaneously testing from a laptop through the modem hitting a controlled desitnation. The speedtests are conducted in pairs. The points of the test show:

 

1. That results are comparable, regardless of console testing versus testing from a laptop to a controlled speedtest destination.

2. The strange behavior is reproducable, regardless of the test origin - console versus laptop over wireless.

3. The srange behavioir I am testing for, is not simply that I end up with slow data rate, it is that 1, the rate drops over time from a reset, and 2.) the rate can be immediately temporarily fixed with a factory reset or reload of the backup configuration.

 

Any observations on these three points to share?

Message 14 of 20
akeele
Aspirant

Re: NightHawk CAX 30 slows until Factory Reset or config restore


@Brettmcm wrote:

This is crazy but I also purchased the same device through Costco ... and let me tell you it's been no picnic.... first I had the same exact problem, My speed would be less than what I had with the Xfinty modem around 700, I used to get 950. I tired every conciveable possible solution but I could never reliably find a fix that would correct the problem it would magically work sometimes and then it would drop to like 200...  then i turned back on the Armor protection and whalla .... back to 950 and all my wireless speeds went back to normal as well. I shut it off back to 200, turn back on 950 where is has remained ever since, with armor off always 200 with armor on 950. Netgear states that Armor should not have anything to do with it but all I know is with it off 200, with it on 950, reproducible every single time. There is ZERO question with my connection (could be Comast wouldn't suprise me, they are scantless). Try, if you experience the same thing maybe they'll stop calling me crazy. 

 

Let me know when you get to constant dropped and poor signal reception I've got the fix for that as well. Thanks to a Super User.. he nailed it. 


I enabled Armor after paying for a subscription, but it made no difference. Just FYI.

Message 15 of 20
FURRYe38
Guru

Re: NightHawk CAX 30 slows until Factory Reset or config restore

I recommend you contact NG support and let them know what your having problems with. You may have a faulty unit. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CBR750 Modem | Wifi Router CBR750(v.7) | Switches NG GS105/8 and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 16 of 20
Brettmcm
Apprentice

Re: NightHawk CAX 30 slows until Factory Reset or config restore

To my computer, mine runs through the CAX30 through a switch and then to my computer. With Armor off I got 200 with it on 950, like tunring on or off a light switch, as reliable as the sun coming up. Armor comes with a 30 day trial, I was suggesting using that. I don't know if the switch is what caused it or not, actually trying to replace the switch, but good luck searching the Netgear website for a switch that supports LACP, why is this so hard NETGEAR?!?!?! Their products are good, but after that it's a STRUGGLE to do anything, even find a simple swtich, but keep at it, when I finally got most of my stuff working like it's supposed to. It's been a significant upgrade to the Xfinity X7 

Message 17 of 20
akeele
Aspirant

Re: NightHawk CAX 30 slows until Factory Reset or config restore

I had already used my trial up, but was willing to spend the $50 to see if it worked ;-). I fugure that in worst-case scenario, I have more security (maybe).

 

I'm glad it worked for you. I just ordered a 1Gb Ethernet usb c adapter for my computer along with a Cat8 cable to test through an ethernet port like the Guru says I should. I am highly doubtful it will make a difference in the test results, but I am wlling to give it a shot.

 

I also suspect that this might be an Xfinity/comcast compatibility issue. Comcast had to re-provision my router after a factory reset. MyXfinity app did not recognize the router was even connected for another day, even though I was getting Internet through it. Xfinity tech support said that its possible to have internet even though their systems do not recognize that an un-provisioned router is connected, but that service would be unpredicatable. Then MyXfinity app reported my router needed to be updated to newer equipment, which is a laugh. After another day MyXfinity app simply says I have a non-supported personal router connected. With this kind of weird stuff going on, it would not surprise me that all of this "unpredictable behavior" is really due to Xfinity. Xfinity has been unreliable in every way for me here in Atlanta.

 

The only thing that is predictable is that I can temproarily fix the situation be simply reloading the backup config and rebooting. 

Message 18 of 20
Brettmcm
Apprentice

Re: NightHawk CAX 30 slows until Factory Reset or config restore

     Oh it's 100% Xfinity all the way. I literally hate them with a passion. You've tapped into my Xifintiy is a giant corrupt coporate liar conspiracy part of my SOUL.

 

     What they did to me is they provisioned my speed and I cannot get an IVp6 address to my computer and my speed is limited to the 950 on my computer, however, my Xbox Series X is directly connected to the CAX30 through a Cat6 cable and it gets speeds almost to 1100. I thought well that's got to be a mistake, but NOW I think it could be my switches? Maybe that's why it works on my Xbox but not my computer. 

 

     My tier speed is 1.2 Gbps and even though the CAX30 is capable of 2.5gbs they say it's only "Comcast Rated" for 800, which is nowhere to be found on your shiny CAX30 packaging but they do quickly mention it on their website if you check everything (kind of a crummy move on Netgears part if you ask me) funny how the same exact same hardware is rated for 1Gbs on both Cox and Spectrum. Because my tier speed is faster than the "Comcast Rated" speed of 800, they provision the CAX30 to I believe DOCIS 3.0 and isn't allowing you/me to use the DOCIS 3.1.

 

     I never asked to be on the 1.2 tier I was automatically "upgraded for free" by them. LOL Xfinity for free? Please what's the catch? By putting me at the higher tier, if I go online and "check my euipment" it'll say not supported because 1.2Gb speed to high for your equipment and you'll need XYZ euipment to be supported. If you notice those options are even more expensive. I believe this is on purpose for 2 reasons. 1) to purchase that much more expensive equipment, will pretty much negate the "save rental fees" as it will take forver to recoup your money so people will skip it and continue to rent. 2)  "upgraded" which caused my service to be downgraded to DOCIS 3.0 from 3.1. Why would they do that? I can only guess it's so they can save on bandwith for business customers even though its a service your paying for. I hate them. 

 

     I'm going to replace my switches with LACP capable switches and see if like the Xbox it will change my status of HDD managed Ivp6 provisioning. But its a stretch, but whatver I'd rather link the ports and use 2.5gbs instread of the seperate 1gb each. Plus I would do anything to subvert Comcast cause I can't stand them. 

 

Oh and my Xbox does get an IVp6 address where my comptuer does not 

 

 

Message 19 of 20
akeele
Aspirant

Re: NightHawk CAX 30 slows until Factory Reset or config restore

Comcast/Xfinity sucks, no doubt. My problem is so intermittant and unpredictable, it's nearly impossible to troubleshoot. Router or Xfinity? Who knows. At least we have both in-common. Neither knows the true source.

 

I'm thinking about applying a gummi bear fix to smooth things out. Just don't know how to get the router to eat it. Ideas?

Message 20 of 20
Top Contributors
Discussion stats
  • 19 replies
  • 1536 views
  • 1 kudo
  • 4 in conversation
Announcements

Orbi WiFi 6E