Reply
Highlighted
Aspirant

Circle "Something Went Wrong" on new RBR50 install

Got my new RBR50 Router and Satellite set up and running with no issue.

 

Got to the part about installing Circle and hit a snag:

  • Installed the Cirlce App (1st Gen) on iPhone
  • Got the "Your router is compatible!" msg on the app
  • Hit Enable Circle on the app
  • Netgear router login screen appears
  • Router login seems to work as it kicks you back to the Circle app.
  • Cirlce app = Something Went Wrong. Please try again to enable Circle.

I've deleted and reinstalled the Circle app.

Router firmware is up to date: V2.7.0.70

Drank lots of coffee.

Read all the threads—again.

Repeated the above process.

Cried a little.

Posted here.

 

Any help is appreciated!

Robot Happy

 

 

 

 

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 10
Highlighted
Guru

Re: Circle "Something Went Wrong" on new RBR50 install

Please post about this in the Circle app forum:
https://community.netgear.com/t5/Circle-Smart-Parental-Controls/bd-p/en-home-circle
Good Luck


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 2 of 10
Highlighted
NETGEAR Moderator

Re: Circle "Something Went Wrong" on new RBR50 install

Hi @6ftoompa

 

Welcome to NETGEAR Community!

 

Firmware version 2.7.0.70 introduces NETEGAR Smart Parental Controls (SPC). This allows you to monitor your kids' online activity across their connected devices. 

 

Here's a reference of how to set it up: 

How do I set up and install NETGEAR Smart Parental Controls?

 

If you want to use Circlev1, you may need to downgrade the firmware to a lower version. If you have Circlev1 enabled, you can continue to use it even if the router upgrades to firmware v2.7.0.70 or higher. 

 

Regards,
Blanca
Community Team

Message 3 of 10
Highlighted
Aspirant

Re: Circle "Something Went Wrong" on new RBR50 install

Thanks @Blanca_O!

 

So are you saying that SPC replaces Circle in Firmware version 2.7.0.70?

 

I don't have a subscription to Circle, so I can roll with SPC instead.

 

Thanks again!

Message 4 of 10
Highlighted
NETGEAR Moderator

Re: Circle "Something Went Wrong" on new RBR50 install

Hi @6ftoompa

 

Thank you for your interest. You can still use Circlev1 provided that you have enabled it prior to firmware v2.7.0.70. 

 

Should you need help setting up NETGEAR Smart Parental Controls, please let us know. 

 

For more information: 

Regards,
Blanca
Community Team

Message 5 of 10
Highlighted
Master

Re: Circle "Something Went Wrong" on new RBR50 install

@Blanca_O 

Will this also be available for the RBK53 V1 systems (RBR50 and RBS50)?

Orbi RBK53 System/RBR50/RBS50/RBS50. + Orbi Voice RBS40V
RBK753 system/RBR750/RBS750/RBS750 + RBK853 System/RBR850/RBS850/RBS850
There's always a logical answer, if you have all the facts!
Message 6 of 10
Highlighted
Guide

Re: Circle "Something Went Wrong" on new RBR50 install

@Blanca_O 

 

so basically the NEW Smart Parental control have much LESS than what Circle v1 was offering?!? 

 

In summary

- you pay a lot for RBK53 (this is the first mistake we made in the first instance)

- NG keep trying to sell you Armour to have security features (i.e. you have to pay to have a decent protection)

- NG provided free Circle v1 Parental Control functionalities... BUT with firmware 2.7.0.70 if you haven't subscribed before you don't even get them anymore and only the even more limited ones provided https://kb.netgear.com/000062103/What-are-the-features-of-NETGEAR-Smart-Parental-Controls-and-Smart-...

 ==> to have decent Parent Control you have to pay extra :-(

Message 7 of 10
Highlighted
Tutor

Re: Circle "Something Went Wrong" on new RBR50 install

As Circle kept disabling without me doing it, the firmware was complete with it not enabled.  How do I downgrade and enable it so that the circle filtering and monitoring that was available for free before is available again? 

Message 8 of 10
Highlighted
Aspirant

Re: Circle "Something Went Wrong" on new RBR50 install

I have the exact same issue.

RBR50 updated firmware with inability to reconnect Circle.

Were you able to get it fixed?
Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 9 of 10
Highlighted
Aspirant

Re: Circle "Something Went Wrong" on new RBR50 install

I am joining the complaining bandwagon. I had to reset my router, and had paid for 1 year Circle membership. Now, when I try to connect Circle to Orbi, I get the "something went wrong" message.

 

I have several profiles set up in Circle -- and its already paid till next year. I dont want to sign up for NG's new software. Do I have NO options?

 

This was before I updgraded the firmware as well. I thought upgrading the firmware would fix it -- I am reading it wont. Please help !!

 

I prefer to keep the Circle 1st gen.

 

THanks

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 1364 views
  • 2 kudos
  • 8 in conversation
Announcements