Reply
Highlighted
Aspirant

OpenVPN not working with Circles enabled in Orbi RBR50

Hi,

 

As the subject suggests, I cannot reach my Internal Network when connecting to my Orbi Router via my iPhone OpenVPN. It used to work before enabling Circles but now it doesn't work as expected. When i troubleshooted the issue, i found that the mac address of the iPhone VPN Tunel is set to 0000.0000.0000 which prevent me from unblocking it. Furthermore, I have the same issue on OpenVPN on my Mac laptop which always changes the mac address that gets it blocked by the access control settings in Orbi and must be manually allowed which defets the purpose of being able to connect from anywhere via VPN. I attached my settings snapshots for those who can help.

Thank you

 

 

Message 1 of 4
Highlighted
Guru

Re: OpenVPN not working with Circles enabled in Orbi RBR50

Please post about this in the Circle app forum:
https://community.netgear.com/t5/Circle-Smart-Parental-Controls/bd-p/en-home-circle
Good Luck


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 2 of 4
Highlighted
Sensei

Re: OpenVPN not working with Circles enabled in Orbi RBR50


@Digital2000 wrote:

As the subject suggests, I cannot reach my Internal Network when connecting to my Orbi Router via my iPhone OpenVPN. It used to work before enabling Circles but now it doesn't work as expected. When i troubleshooted the issue, i found that the mac address of the iPhone VPN Tunel is set to 0000.0000.0000 which prevent me from unblocking it. Furthermore, I have the same issue on OpenVPN on my Mac laptop which always changes the mac address that gets it blocked by the access control settings in Orbi and must be manually allowed which defets the purpose of being able to connect from anywhere via VPN. I attached my settings snapshots for those who can help.

Thank you


While this issue may be related to Disney Circle, there have been numerous posts recently about a new feature in iOS which "randomizes" MAC addresses as a security feature.  Not having "i-things", I have not studied the issue.  But, I had a similar problem when I activated a similar feature on a Raspberry Pi.  I believe there is a control setting to say something along the lines of "use the real MAC address instead of inventing new ones all the time."

I love my Orbi.
Message 3 of 4
Highlighted
Aspirant

Re: OpenVPN not working with Circles enabled in Orbi RBR50

Thank you for the reply. I’m aware of the private mac feature that has been introduced in iOS14. My issue is with the OpenVPN client that gets a “tunnel” mac address of all zeros which makes it useless in the Orbi access control feature. Also, it makes it not seen in Circles App! If i toggle the Orbi VPN settings to make the clients use Internet and home network (i.e. no split-tunnel vpn), then it works fine “for a while” even though it shows as being blocked in access control section! Quite weird and i want to find a solution to this by either fixing the mac address of the vpn tunnel to something else other than zeros or make the access control allow the zeros mac address! Now if i try to allow it, Orbi complains that it’s an invalid mac address! Okay, we understood its invalid but why Netgear assign it when setting up the tunnel for the client??? so frustrating Smiley Happy
Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 134 views
  • 0 kudos
  • 3 in conversation
Announcements