Orbi WiFi 7 RBE973

D7000 V2 cannot update firmware


D7000 V2 cannot update firmware

I have read through the discussions and have not seen this problem though I seem to have various similar problems to other. 


I am currently running V1.0.0.44_1.0.1 and have been trying to update to the next version of firmware V1.0.0.45 as I am having problems with frequent dropping out of the wi-fi signal. Some other fixes have suggested this. This router has been dubious from the get go, with a few goes at resetting and trying to update firmware which initially seemed to help. Purchased in September and has always had patchy wi-fi signal. Tried checking channels etc., the only thing that helps this issue is rebooting the modem, yet again. So in an effort to fix this I am trying to install the new firmware. 


When I try to update firmware now - connected by LAN cable - initially when it goes to reboot it loses connection with the computer, and at times won't reconnect to ADSL at all. Waiting up to 5min. to see if it can pick up the ADSL signal, then having to manually reboot the router again. Some times it does pick up the signal but then again takes around 5 min to pick up internet. 

When you finally get back to router log in the same version is still there. I have tried this multiple times without success. 


Is there another way to upgrade the firmware?

Do I just have a dud router?

Model: D7000|Nighthawk AC1900 VDSL/ADSL Modem Router
Message 1 of 3

Re: D7000 V2 cannot update firmware

I forgot to add, that I have also tried updating the firmware by downloading to a laptop. Still the same issues with dodgy reconnection and still I have the old version of the firmware there. 

Message 2 of 3

Re: D7000 V2 cannot update firmware

Message 3 of 3
Discussion stats
  • 2 replies
  • 0 kudos
  • 2 in conversation

Orbi 770 Series