× We are aware of an issue affecting Nighthawk CAX30 Cable Modem Routers that may have resulted in an interruption of internet service. For instructions to restore Internet connectivity click here.

Netgear D6220 NBN FTTN doesn't connect to internet


Netgear D6220 NBN FTTN doesn't connect to internet

I've been without internet for 5 days. 


I'm using a Netgear D6220 to connect to NBN FTTB with iinet. 

My service had been connected for over a month before it dropped out for no apparent reason. 

After days of talking to iinet support they sent a technician out. Just before they arrived my internet connected, again for no apparent reason. 

The technician checked everything out, said it was all working fine. We even went down and checked the MDF room (I live in an apartment) and confirmed that everything was fine. 

After he left, I disconnected the modem/router to tidy up the cables and when I plugged it back in the internet connection was lost. 

I called iinet and again and they confirmed that everything was good on their end. 


Basically I'm 90% sure it's the Modem/router. I can get a connection but it can take 24/48hr for a green light. 


I've tried factory resets, reconfiguring settings, literally everything. 


Has anyone else experienced this with this model?


I don't want to go out to buy a new router just to test it. 


When I do manage to get a connection, the speeds are great. But Ican't go on like this for much longer!

Model: D6200v2|AC1200 WiFi DSL Modem Router
Message 1 of 5

Re: Netgear D6220 NBN FTTN doesn't connect to internet

I have the exact same problem. My D6220 randomly stopped working yesterday. My nbn is fine - i called iinet and they confirmed my connection - but theres something wrong with the router. I tried updating the firmware, and the netgear router website said that i needed to. I had to manually download it from netgears website and upload it myself. Nothing changed: theres still no internet.

Its kinda bullsh*t that netgear dont have an easily accessible number to call, because i dont know whats wrong with it and iinet cant fix it.
Message 2 of 5

Re: Netgear D6220 NBN FTTN doesn't connect to internet

Yep! I did the manual firmware update as well! No change.
As much as it sucks I’m glad I’m not the only one.

I think I’ve looked at every single D6220 forum.

Do you have the ISP configured to ‘other’ or ‘iinet’ in the Netgear genie?
Message 3 of 5

Re: Netgear D6220 NBN FTTN doesn't connect to internet

See if any of these help:


Search - NETGEAR Communities – D6220 NBN


NBN seems to be a rat's nest. Some ISPs go for exotic settings that confuse everyone.


This seems to be a good source of local wisdom:


“NBN” - Whirlpool Forums


Just another user with a set of boilerplate macros.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 4 of 5

Re: Netgear D6220 NBN FTTN doesn't connect to internet

I have this exact problem.  D6220 Router worked for several months on FTTN (VDSL). Now shows No Internet.  NBN technician came out and proved service works with iinet ISP Provided router.  He said he has now had multiple customers with D6220 that no longer work.

On the ISP side they can see the mac-address of my router, and see that i am successfully authenticating with the Radius server but my router is not obtaining a DHCP lease from the ISP.  Factory reset router, no luck. Tried another D6220, still did not work. Upgrded to latest firmware but didnt fix it.  The ISP advised NBN upgraded their equipment and it looks like D6220 no longer works. Contacted Netgear and they said they would send me a new router but would call me back next day to confirm as they were out of stock. 5 days later, still waiting for that call. As I am woking from home, I ran out and bought TPLink VR400. Worked instantly.

Model: D6200v2|AC1200 WiFi DSL Modem Router
Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 0 kudos
  • 4 in conversation

Orbi WiFi 6E