Reply

Corrupted Firmware for Router (impacting operation of the router)

dlallnsn
Aspirant

Corrupted Firmware for Router (impacting operation of the router)

Sony Vaio i5 laptop, Windows 8.1, D7800 - AC2600 Nighthawk X4S VDSL/ADSL Modem Router (this is the version I have, not the one listed in the model field above)

 

I was upgrading my D7800 Routers Firmware from Version 1.0.0.48 to 1.0.1.10 and upon updating the firmware immediatly my Netgear Genie application stopped working. 

 

When I clicked on the Router Settings option it said that my router wasn't supported???

 

I restarted my computer to see if that would make a difference to the Genie application, however this did nothing.  I thought that maybe the Router needed to be turned off / turned back on to finalise the installation.  Upon doing that step, the router has stopped working and no longer any devices can connect to the internet.

 

The power button was flashing white with the ethernet port 1 with a steady red colour.  My home computer is connected through a wired connection to port 1.

 

I did some searching on the internet and it stated if the power button was flashing white it was a corrupted firmware version that's causing the issue and to login to the router through www.routerlogin.net or 192.168.1.1 or 192.168.0.1 and all these fail. It was saying in the support pages that you could reinstall the firmware and this would fix the issue, however I've tried and had no luck. https://kb.netgear.com/app/answers/detail/a_id/27199?cid=wmt_netgear_organic

 

I've done a reset on my router by holding in the reset button with a paper clip, however this did nothing and no factory defaults were restored.  I read in a blog that if you held in the reset button for about 30 seconds and then powered off the router whilst holding in the reset button and then turning it back on would force it to be restarted, however this has done nothing except change the flashing white power light to a steady red colour with no other lights on the router.

 

Please help, I've only had this router 2 months and I was told that it's the easiest and most effective router on the market that's very easy to support, however, I've had nothing but trouble with it.

Model: R7800|Nighthawk X4S AC2600 Wifi Router
Message 1 of 6
VE6CGX
Master

Re: Corrupted Firmware for Router (impacting operation of the router)

Your f/w update did not finish properly. Tried to reflash? Know how to do it with tftp method?  As is the router is in unknown state.

Did you reset it? Did it do anything? Power light blinking  means usually it is waiting for the f/w file. Can you ping the router?

Message 2 of 6
dlallnsn
Aspirant

Re: Corrupted Firmware for Router (impacting operation of the router)

Hi VE6CGX,

 

I downloaded both the old and new firmware versions to see if I could get at least 1 to work also I downloaded the tftp method described in the support blogs, however the file starts to update, and get's to about 3 quarters of the way and fails, the second attempt doesn't even look to start updating and the third attempt again get's to the 3 quarter stage and fails.

 

I've tried to reset it and the white blinking powerlight has become a steady red light, which I think means it's in the process of starting?  It's been like that for hours (even overnight).

 

I've tried to ping the router on 192.168.0.1 and 192.168.1.1 and both are unsuccessful.  I followed some instructions for a command line prompt and run ipconfig, however the IPv4 Address is blank.  I've also tried to assign a static IP address and that doesn't seem to work either.

 

Thanks for getting back to me.

Message 3 of 6
Igorchiasso
Aspirant

Re: Corrupted Firmware for Router (impacting operation of the router)

Hi dlallnsn
nighthawk X4S
I just had the same issue as you right now. It was worse when the cable connection with my laptop said unidentified network, but that was just the firewall. Anyway, I was updating firmware from 1.0.2.20 to 1.0.2.28 and Genie stopped receiving internet and couldn't connect to the router( same message saying router not compatible). Later I realized the firmware was corrupted.
I tried to factory reset(which nothing happens) and I have the power led blinking white. I assigned static IP to my pc and I can ping the router and receive an answer. But when I go to the TFTP application I have the same problem where the upgrading flash bar goes until 2/3 on the first try and stops, the second try doesn't fill anything and the third goes 2/3 again and stops saying "unable to get response from the server" Which does not make much sense since I can ping. Maybe the router's password got corrupted and The TFTP program can't access him anymore? IDK.
Did you have any success with you router? Does anyone have other ideas? I am out of them.
Message 4 of 6
Igorchiasso
Aspirant

Re: Corrupted Firmware for Router (impacting operation of the router)

Hi dlallnsn
https://community.netgear.com/t5/Nighthawk-WiFi-Routers/SOLVED-Steps-for-debrick-unresponsive-R7000-...
I just made it work. The problem here it's because we are using that TFTP2.exe which doesn't work. Refer to this link here where the guy explains how to put the file using TFTP inside the Windows, which you have to enable first. Beware that you must have ping from the router for this to work. Hope it works out for you to.
Message 5 of 6

Re: Corrupted Firmware for Router (impacting operation of the router)

There is also this on using TFTP:

 

How to upload firmware to a NETGEAR router using TFTP | Answer | NETGEAR Support

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 6 of 6
Discussion stats
  • 5 replies
  • 2850 views
  • 0 kudos
  • 4 in conversation
Announcements