Reply
Highlighted
Aspirant

D6400 FIRMWARE (1.0.0.94) UPDATE FAILS

D6400 Router tells me there's a firmware update available (1.0.0.94).

Chose to download and update automatically  - package downloads - router "updates" but no change to firmware and error message saying "router sent no data"

Tried doing it manually. Exactly the same happened. The .chk file is just 34.9 MB

 

Done this plenty of times before and usually pretty straightforward.

 

Anyone else having the same problem? Any ideas gratefully received - thank you!

Message 1 of 9

Accepted Solutions
Highlighted
Aspirant

Re: D6400 FIRMWARE (1.0.0.94) UPDATE FAILS

4th time round..for some reason it worked fine this time.

No idea what the problem was but at least it's fixed now.

 

Thanks to those folks who replied

View solution in original post

Message 8 of 9

All Replies
Highlighted

Re: D6400 FIRMWARE (1.0.0.94) UPDATE FAILS


@Joffo wrote:

D6400 Router tells me there's a firmware update available (1.0.0.94).

What is your current firmware?

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 2 of 9
Highlighted
Aspirant

Re: D6400 FIRMWARE (1.0.0.94) UPDATE FAILS

What is your current firmware?

 

1.0.0.88

I believe this is the one immediately preceding 1.0.0.94 and therefore should be straightforward to update?

Message 3 of 9
Highlighted

Re: D6400 FIRMWARE (1.0.0.94) UPDATE FAILS


@Joffo wrote:

I believe this is the one immediately preceding 1.0.0.94 and therefore should be straightforward to update?


Correct.

 

I asked because there was an earlier problem that needed some jiggery pokery to update the firmware.

 

The filesize you report isn't what I see. Have you tried a second download of the file?

 

I assume that this is what you are doing:

 

How do I manually upgrade firmware to my NETGEAR router? | Answer | NETGEAR Support

 

 

 

 

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 4 of 9
Highlighted
Aspirant

Re: D6400 FIRMWARE (1.0.0.94) UPDATE FAILS

Hmm...thanks for your response.

 

Yes, I have tried several downloads and have tried both manual and "auto" (direct from router's update prompt) routes

I see 32MB on Netgear site, 31.9 for previous version (1.0.0.88), 33.4 for version before that - so I assumed file size OK. What file size are you seeing?

Message 5 of 9
Highlighted
Aspirant

Re: D6400 FIRMWARE (1.0.0.94) UPDATE FAILS

Message 6 of 9
Highlighted
Sage

Re: D6400 FIRMWARE (1.0.0.94) UPDATE FAILS

> [...] The .chk file is just 34.9 MB

 

   "just"?  What were you expecting?  Generally speaking, if you
extracted a file from a zip archive, and the extraction program did not
complain, then you got the whole thing, intact.

proa$ unzip -l D6400-V1.0.0.94_1.0.94.zip
Archive:  D6400-V1.0.0.94_1.0.94.zip
  Length      Date    Time    Name
---------  ---------- -----   ----
 34865232  07-28-2020 04:09   D6400-V1.0.0.94_1.0.94.chk
      894  07-28-2020 04:16   D6400-V1.0.0.94_1.0.94_Release_Notes.html
---------                     -------
 34866126                     2 files

   "34865232" bytes looks to me like about "just 34.9 MB".

proa$ ls -l D6400-V1.0.0.94_1.0.94.zip
-rw-rw-rw-@ 1 sms  staff  33604891 Sep 18 17:10 D6400-V1.0.0.94_1.0.94.zip

   The size of the archive itself should be 33604891 bytes.  (You get
some, but not much, compression from zip on these files.)

 


> The filesize you report isn't what I see. Have you tried a second
> download of the file?

 

   "what I see" might depend on "what I look at", which remains a secret
from the non-psychics here.  As I might have mentioned before, generally
speaking, if you extracted a file from a zip archive, and the extraction
program did not complain, then you got the whole thing, intact.
Repeated downloads would be a waste of time and effort.

 


> [...] What file size are you seeing?

 

   That might depend on which file anyone is discussing.

 


Back in the real world, I don't know why the manual firmware load is
not working for you.  I don't have a D6400 in hand to test.

Message 7 of 9
Highlighted
Aspirant

Re: D6400 FIRMWARE (1.0.0.94) UPDATE FAILS

4th time round..for some reason it worked fine this time.

No idea what the problem was but at least it's fixed now.

 

Thanks to those folks who replied

View solution in original post

Message 8 of 9
Highlighted

Re: D6400 FIRMWARE (1.0.0.94) UPDATE FAILS


@Joffo wrote:

4th time round..for some reason it worked fine this time.

 


Glad it worked out.

 

I unearthed my D6400 to see if there was a problem with the firmware. (I wanted to check to conform that I wasn't talking out of my rear end.) It installed seamlessly. But I probably jumped a few versions. I also did the manual update as a standalone move, with the D6400 wired to a laptop that was itself isolated from the Internet and the local network.

 


@Joffo wrote:

 

No idea what the problem was but at least it's fixed now.

 


In the past Netgear has advised that you should restart the beast before attacking it with new firmware. But that is usually flagged up in the release notes.

 

Sometimes a factory reset has "unblocked" something and allowed the firmware to install.

 

Sadly, there is often no seeming logic to what goes on.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 9 of 9
Discussion stats
  • 8 replies
  • 85 views
  • 0 kudos
  • 3 in conversation
Announcements