Reply

Re: D8500 died, was working fine. Now not so much.

YF-IT-Manager
Aspirant

D8500 died, was working fine. Now not so much.

This thing is a piece of garbage. We spent a ridiculous amount on it. Only to have it completely die after 5 months? (hopefully not). We bought it in October.

It's for our business, I wasn't in when it died but i have the following details;

It didn't do anything strange supposedly before it died, was running as normal.
Red power light comes on, then it appears to try and reboot constantly. 
Cannot login via Genie, IP address or any other means. 
HAve tested net on other routers, works perfectly. 
Have rebooted, unplugged, reset. 

Any Ideas? 

Model: R8500|Nighthawk X8 Tri-Band AC5300 WiFi Router
Message 1 of 9
William10a
Master

Re: D8500 died, was working fine. Now not so much.

 Could be the firmware has problem not sure if you could use a serial cable to reflash the firmware.

Message 2 of 9
YF-IT-Manager
Aspirant

Re: D8500 died, was working fine. Now not so much.

Sorry, I'm a little new to these routers, how might one reflash the firmware?

Message 3 of 9

Re: D8500 died, was working fine. Now not so much.

There is a manual for the D8500 somewhere at the end of this link:

 

>>>> D8500 | Product | Support | NETGEAR <<<<

 

The Release Notes explain what to do:

 

D8500 Firmware Version 1.0.3.39 | Answer | NETGEAR Support

 

Then there is this:

 

How do I manually upgrade firmware to my NETGEAR router? | Answer | NETGEAR Support

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 4 of 9
Mcv
Aspirant
Aspirant

Re: D8500 died, was working fine. Now not so much.

These Nighthawk X8's are garbage. Do a search and you'll find a bunch of threads about them bootlooping and constantly restart. Let me guess, orange/amber light and the router continuously restarts? Yep. We purchased about 20 of these for our consumer sites and we had roughly 50% that went bad. All had firmware updates to the most current. Only thing to do is call in for a warranty repair or exchange.

Stick with the Nighthawk X6's those are built like a tank.
Message 5 of 9
YF-IT-Manager
Aspirant

Re: D8500 died, was working fine. Now not so much.

Yes, sadly we are realising this after 5 months of ownership. Hunk of s h i t.
When it works, it's great....

Also, Netgear support is probably one of the worst support systems I've ever encountered for electronic goods in my life, the guy tried to tell me because my tech support of 90 days expired he couldn't help me, I nearly lost it at him, it's got a 12 month warranty. You cannot expect me to pay for further tech support just to use my 12 month warranty. Thankfully he finally twigged and started the RMA process.

Message 6 of 9
YF-IT-Manager
Aspirant

Re: D8500 died, was working fine. Now not so much.

Thanks for the options, sadly it keeps rebooting before I can complete any of the steps.

Message 7 of 9
DarrenM
Sr. NETGEAR Moderator

Re: D8500 died, was working fine. Now not so much.

Hello YF-IT-Manager 

 

I have sent you a PM.

 

DarrenM

Message 8 of 9
YF-IT-Manager
Aspirant

Re: D8500 died, was working fine. Now not so much.

In the end it was replaced under RMA. At last. 

At least I can switch Mu-mimo on with this new one....

Message 9 of 9
Top Contributors
Discussion stats
  • 8 replies
  • 1178 views
  • 0 kudos
  • 5 in conversation
Announcements

Orbi WiFi 6E