Reply

Freshly saved backup is worthless N600

jaraco
Aspirant

Freshly saved backup is worthless N600

Today, AT&T convinced my father that his router config needed to be reset to factory defaults. Before he did that, he made a backup, using the settings from Advanced > Administration > Backup. He actually backed up three times before realizing that it was saving the backup to his Downloads. After restoring to factory defaults, we attempt to restore from backup (any of them), but the modem reports "config check failed".

 

The file's not corrupt.

 

There's a bug in NetGear's backup/restore process. Now we're forced to reprogram the router from scratch.

 

I'm just writing here to gripe. There's nothing you can do to help. Please NetGear, if you're listening, write better software.

Model: DGND3700v2|N600 WIRELESS DUAL BAND GIGABIT ADSL2+ MODEM ROUTER
Message 1 of 3
antinode
Guru

Re: Freshly saved backup is worthless N600

> There's a bug in NetGear's backup/restore process. [...]

   Or, there was at one time.

> [...] There's nothing you can do to help. [...]

   Revealing the firmware version involved might make that less true.
If you want to report a problem, then you ought to provide a problem
report with actual information.  If you want only to rant, then
something meatier than "write better software" might be more effective.

Message 2 of 3
jaraco
Aspirant

Re: Freshly saved backup is worthless N600

Good point. Yes, I did not provide more detail because at the time, I did not have better detail. I was working on the router by talking my 70-year-old father through it over a land line, because that was the only link I had.

 

Since then, I've managed to talk him through getting the remote access restored and access to the systems where he had the backups saved. I can see now what the firmware version was on the router from the backup header:

 

# Netgear DGND3700v2 Text Format Configure File v0.2
#
# FW Version V1.1.00.21_1.00.21NA

 

I know that firmware version is older, because I'd previously attempted to upgrade the firmware from a remote session, but the update did not complete.

 

But can you honestly say that "config check failed" is a reasonable error message? Other reports of that error in this forum suggested the config was corrupt, but I know it wasn't. So there must be a bug.

 

If you can say that it was a known bug with that firmware and that it was fixed, I'd feel a little better. But honestly, I'd expect the backup/restore process to be tested in every firmware release such that a user can rely on it.

 

Instead, I go through the work of backing up and restoring (through a person on the phone interface), then painstakenly restore the settings by hand, then report the issue... all work I don't have time for and which could have been avoided if the backup/restore feature weren't there at all.

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 606 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 6E