Antworten

ActiveDirectory Zugriff

Serviceman
Aspirant

ActiveDirectory Zugriff

Hallo, ich beschreibe kurz das Vorhaben und das Problem. Wir wollen auf dem RN eine für bestimmte Benutzer eine Internetseite betreiben  was auch soweit funktioniert. Damit wir nicht alle Benutzer von Hand anlegen müssen, haben wir den RN an ActiveDirectory angemeldet. Das hat wie es aussieht auch funktioniert, die Benutzer sind aus AD alle kopiert bzw. importiert worden. So jetzt kommt das Problem, wenn ich aus dem Internet den RN aufrufe  server.meinedomain.de/testordner  kommt die Anmeldemaske was auch ok ist, Benutzername und Passwort rein, dan kommt Fehler 500. Im Admin-bereich auf dem RN habe ich auch den Benutzer aus AD dem HTTP  Testordner hinzugefügt. Was mache ich falsch ?

 

Model: RN21200|ReadyNAS 212 Series 2- Bay (Diskless)
Nachricht 1 von 6
Slas
NETGEAR Employee Retired

Re: ActiveDirectory Zugriff

Hallo @Serviceman

 

und willkommen in der NETGEAR Community.

 

Kannst Du im lokalen Netzwerk normal auf die Webseite ohne Fehler zugreifen?

Versuche HTTP für die Verwaltung von Readynas auszuschalten und versuche die Webseite erneut zu erreichen.

Gehe unter System -- Settings -- HTTP Settings - nehme das Häkchen bei "Enable HTTP Admin" raus.

Dann sollte die NAS lokal und vom Remote nur über HTTPS (Port 443) antworten und mit dem HTTP Service nicht mehr kollidieren.

 

 

Grüße
Slas
NETGEAR Community Team


____
Klicke auf KUDOS, wenn du diesen Beitrag hilfreich findest, und markiere ihn ggf. als AKZEPTIERTE LÖSUNG.

Nachricht 2 von 6
Serviceman
Aspirant

Re: ActiveDirectory Zugriff

Also die Webseite ist aus dem lokalen Netz sowie aus dem Internet auch erreichbar. Der HTTP-Admin war schon abgestellt.

Es geht nur um die Anmeldung dass nicht jeder auf die Seiten zugreifen soll, sondern nur angelegte Benutzer. Wenn die Benutzer direkt auf dem RN angelegt werden klappt es auch sauber, sowohl lokal auch aus dem Internet. Fehler kommt nur wenn ich die Benutzer aus ActiveDirectory importiere. Ich wollte einfach keine 40 benutzer neuanlegen wenn diese in AD schon vorhanden sind.

Nachricht 3 von 6
Slas
NETGEAR Employee Retired

Re: ActiveDirectory Zugriff

Hallo @Serviceman,

 

könntest Du noch beschreiben wie die User Berechtigungen konfiguriert wurden?
Also, ob User Berechtigungen nur über den Domain Controller und/oder Readynas WebGUI verwaltet werden?

Können die Domain User lokal auf eine andere "Test Share" per HTTP oder SMB zugreifen?

Könntest Du eine Test Share anlegen und einem Domain User über das WebGUI der Readynas unter Share Einstellungen  -- Netzwerkzugriff für SMB und HTTP einen Zugriff erlauben und die Verbindung überprüfen?

 

Grüße
Slas
NETGEAR Community Team


____
Klicke auf KUDOS, wenn du diesen Beitrag hilfreich findest, und markiere ihn ggf. als AKZEPTIERTE LÖSUNG.

Nachricht 4 von 6
Serviceman
Aspirant

Re: ActiveDirectory Zugriff

Die Berechtigungen habe ich wie folgt gesetzt. Die Benutzer aus ActiveDirectory sind alle da. Berechtigungen habe ich nur bei RN gesetzt.

SMB lesen/schreiben für Benutzer aus AD, anonym hab eich den hacken rausgenommen, HTTP Benutzer aus AD auf zugriff.

 

Die berechtigungen habe ich nur im Webgui von ReadyNas gesetzt.

 

ich habe bereits mehrere test-ordner angelegt mit dem gleichen Effekt.

 

Ich habe es auf 2 readyNAS ausprobiert, bei beiden passiert das Gleiche.

Was aber sehr komisch ist, nach Neustart des SBS-2011 Server wo AD läuft funktioniert es. Ich werde noch weitersuchen warum es so ist, es funktioniert jedenfalls. Im protokoll von readyNAS stehen auch keine Fehler. Ich werde heute noch die Ereinissanzeige durchforsten und berichte.

 

Vorerst vielen Dank

Nachricht 5 von 6
Slas
NETGEAR Employee Retired

Re: ActiveDirectory Zugriff

Hallo @Serviceman,

 

vielen Dank für Deine Rückinfo.

Schaue in den AD Logs nach, werden die Anmeldezeiten, Anmeldefehler von den bestimmten Benutzer oder sonstige interne Serverfehler gemeldet?

Du könntest auch versuchen den Fehler zu reproduzieren und gleichzeitig den Datenverkehr am Server mit einem Netzwerk Scanner z. B. Wireshark untersuchen.

 

Grüße
Slas
NETGEAR Community Team


____
Klicke auf KUDOS, wenn du diesen Beitrag hilfreich findest, und markiere ihn ggf. als AKZEPTIERTE LÖSUNG.

Nachricht 6 von 6
Diskussionsstatistiken
  • 5 Antworten
  • 856 Aufrufe
  • 0 Kudos
  • 2 in Unterhaltung