Reply
Highlighted
Follower
Follower

Alexa Echo Dot won't connect to my wireless router

So frustrated and need HELP!!!  I received an Amazon Echo Dot for Christmas and I am trying to connect my WI-Fi to it.  I am not a computer geek, so please use words I will understand.  Here's what I have.  I have internet service thru my phone company and have a modem thru them.  My wireless router is a Netgear WNR1000v3.  I can't get past the connect to wi-fi manually screen.   My Echo Dot keeps saying I need to connect to my WI-Fi, so it prompts me to manually connect to Wi-Fi. So, on my phone (Samsung S7) I go to my wi-fi and connect to Amazon wi-fi and then go back to my Amazon Alexa app to try and finish my set up. It won't let me go any further to finish the set up of my Echo Dot. When I called my phone company they said that I need to get in touch with Netgear in order to get my Echo Dot connected to my wireless router?  I have no idea what I need to do to accomplish that.  Can somebody please help me, as there is no phone number or anyone to talk to on this website for support.  Poor, poor customer service!!!

Thanks!  SC7  

Model: WNR1000v3|N150 Wireless Router
Message 1 of 13
Highlighted
Aspirant

Re: Alexa Echo Dot won't connect to my wireless router

I am a computer nerd and work in the industry and am having a similar problem.  I have an echo Show, echo dot, and first generation echo.  I also have two amazon cloud cams and a fire TV. I say all that because I'm having a wide range of wifi issues with my R7000 and Amazon products.

 

The echo devices will stay connected for sometimes days at a time, but will randomly not be able to connect to my wifi network for several hours, if they reconnect at all.  Rebooting the echo devices or cameras does not solve the issue, however, if I reboot the router everything reconnects.  Sometimes one echo device will stay online while the others remain disconnected.  So far haven't been able to narrow down the issue.

 

The fireTV does not have this issue, currently watching a movie on it while the echo devices won't connect.  I had issue with one of the amazon cloud cams not wanting to connect to my ASUS-ARCH13 router either.  So I'm trying to see if there is a user side setting I can change that resolves this or if it's some compatibility, DHCP renewal or what.  I may static map these devices and see if it's an issue there.

 

I have a Netgear R7000 running firmware V1.0.9.18_1.2.27.  I have disabled implicit beamforming hoping that would be the culprit of the disconnects.  Unfortunately it seems like that is not the case.

 

I'm actively searching for a solution as well, I'll update here if I find one.

 

EDIT:

I've tried downgrading firmware and the issue persists with all those I tested.  I've also tried the newest stable dd-wrt firmware on my R7000, but the wifi disconnects still happened.

 

EDIT2:

Started thinking about why some Amazon devices remain connected while others disconnect.  Turns out, the disconnected devices are all on the 2.4GHz band, the ones on the 5GHz band remain connected and work just fine.

 

Tried to connect to the 2.4GHz band from my phone and it's failed to obtain an IP address.  I have a guest network enabled on the 2.4GHz band but not the 5GHz, not sure if that matters or not.

Message 2 of 13
Highlighted
Aspirant

Re: Alexa Echo Dot won't connect to my wireless router

I have the same issue. Same router. I did a firmware upgrade (to V1.0.9.18_1.2.27)  a while back & around that time my Alexa stopepd working. My NVidia shield  (new small model) stopped working too. (Ipads and Iphones all work fine). All conected @ 2.4 GHZ

 

I was on the phone to Amazon support for an hour they could not fix it. I get error 10:2:17:51 during setup. 

 

Amazon are were very helpful they are going to send me a new Dot. But I think the new firmware is the problem.

Message 3 of 13
Highlighted
Initiate

Re: Alexa Echo Dot won't connect to my wireless router

Struggled with this problem on my Echo Dot (Gen2). Could not get it to connect to my Netgear R6220 for 2 hours on the 2.4GHz (WPA2-PSK) channel. Later tried on the 5GHz(WPA2-PSK) and got connected in 15 secs. Love my Netgear router,

Message 4 of 13
Highlighted
Aspirant

Re: Alexa Echo Dot won't connect to my wireless router

I had the same problem with my R6700 router. Thanks for the info about using the 5Ghz connection; I was able to connect my echo second generation and echo dot second generation right away! 

Message 5 of 13
Highlighted

Re: Alexa Echo Dot won't connect to my wireless router

If Alexa device won't connect to wireless router, you should have information about some important things like echo device connect to dual-band Wi-Fi (2.4 GHz / 5GHz) networks that use the 802.11a / b / g / n standard. Because devices don't support peer to peer networks. You can check network Wi-Fi network you're connected by going to Settings and Selecting Wi-Fi. So, to troubleshoot wi-fi internet issue, understand and identify internet issues.

Message 6 of 13
Highlighted
Aspirant

Re: Alexa Echo Dot won't connect to my wireless router

I've spent hours trying to get 4x Amazon Echo Dot 3rd Gen connected.  Through lots of repetition and a couple of hours, I was able to get two connected.  I gave up on the other two and circled back to this today, a couple of more hours before taking a different approach which resolved my connection issues instantly.

 

Turns out these past few years I have not been running my modem and Orbi router properly.  Here is how it was setup previously:

-  cable coming out of 'internet' port on Orbi router was connected to Port 2 on my Spectrum Cable Modem

-  cable connected to PC was in Port 1

 

Solution:

-  remove internet cable connecting PC from Port 1 on cable modem, and connect it to one of the 'ethernet' ports on the back of wireless router (you will not require this step if all of your devices, in my case PC, are connected wirelessly)

-  change 'internet' cable on Orbi router to Port 1 on cable modem

    -  it is important on my particular cable modem that any router be hard-wired to Port 1 (I dont know if this is exclusive to Spectrum modems, but may be worth a try - the manufacturer of mine is ARRIS)

    -  it is also important that you determine if your modem has wi-fi capability

        -  if said modem does have wi-fi capability, it is important that you disable that as your Orbi is your wi-fi and you do not want the two competing.  I think this more than anything was at the core of my woes.  You'll need to login to your modem from a web browser using something like 192.168.0.1 or 192.168.1.1 to determine and change wifi settings.  Look up the process for your modem if you are not familiar.

 

I did all of this and voila, both remaning Echo Dots connected within seconds.  I should say that I crashed my modem while changing the settings myself.  Ended up calling Spectrum to get them to reboot it, while I had the guy on the phone I told him I had the Orbi router and he pointed out the proper cable connection mechanics, how mine was flawed (even though it's been working for years), and he was able to login and configure the modem for proper use with an Orbi (a bridge I believe).  Hope it helps.

 

-HB

Message 7 of 13
Highlighted
Initiate

Re: Alexa Echo Dot won't connect to my wireless router

Here is what worked for me. I’m no computer geek. But I can get around if you walk me through it. I called netgear and they had me open a new tab in my web browser. Your computer will need to be connected to your router. I typed 192.168.1.1 and then pressed enter. This will bring you to a login page. The default username is admin, and the default password is password unless you’ve changed it. Now you’ll be in your netgear router info page.

Select the Attached Devices section. When I got in here I noticed my Echo Dot was blocked. To the right just above your list of attached devices you should see in blue letters, Access Control. Click on this. Then find your Echo Dot again. It should say blocked in red letters. Check the box to the left and click the blue Allow tab just above all your devices. Then click the green box in the middle just a little bit higher that says Apply.

Hopefully this was able to help some of you. I still don’t know why my echo was blocked, but at least I was able to fix it.
Message 8 of 13
Highlighted
Aspirant

Re: Alexa Echo Dot won't connect to my wireless router

Hi iam trying to connect my echo dot to my netgear wireless router. I have updated my firmware, and it was sucessfull. I have also checked to make sure it was not blocked. MY WIFI ROUTER MODEL # IS WNR2000v5. N300. I am stumped dont know what else to do at this point. my son bought this a gift to me, 

Message 9 of 13
Highlighted
Initiate

Re: Alexa Echo Dot won't connect to my wireless router

I had same issues with all Amazon devices, turned off "smart connect" i wifi setting s on the Nighthalk app and works fine, you just then always need to select a 2.4Hz or 5.0Hz network. 5.0Hz better if router travels through walls. 

 

If you switch back to smart connect they will drop out again so have to leave this feature off. 

 

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 10 of 13
Highlighted
Aspirant

Re: Alexa Echo Dot won't connect to my wireless router

I had the same issue. In my wireless setup, I changed WPA2-PSK - AES to the WPA2-PSK -TKIP + WPA2-PSK - AES  combo and it worked.  

Model: RAX80|Nighthawk AX8 8-Stream WiFi Router
Message 11 of 13
Highlighted
Aspirant

Re: Alexa Echo Dot won't connect to my wireless router

I have tried everything that is mentioned here.. and I still can't get the echo or the amazon microwave to work.

Message 12 of 13
Highlighted
Tutor

Re: Alexa Echo Dot won't connect to my wireless router

When I have smart connect enabled, it seems to allow different echoes to go on different bans, when I take it off they all go to the 2.4 g. I’m guessing that it can’t stream if it’s not on the same band. Is there a way to do smart connect, but force devices to stay on 2.4g?
Model: R7800|Nighthawk X4S AC2600 Wifi Router
Message 13 of 13
Discussion stats
  • 12 replies
  • 16619 views
  • 4 kudos
  • 13 in conversation
Announcements