Reply
Highlighted
Follower

Attempted to update firmware on R6350, won't connect now

Just this morning I tried to update my firmware through the Nighthawk app and everything seemed to go fine, giving me the "Update complete" message and all. After waiting about 10 minutes for the router to restart, as the app said it would, I came over to check the lights on the router and they were flashing green back and forth from the power light to the USB light with no internet connection. I decided to restart the router and see if it could work, but to no avail. 

 

After that failed I immediately started looking into fixes and attempted to do the TFTP fix as mentioned in this post. I have followed those steps a couple of times now, and am wondering if I'm doing something wrong. Is there any kind of specific timing needed for when you run the TFTP program, or can it be any time after you've turned the router back on after 10 seconds, and wait for the flashing? I have followed the guide step by step multiple times. I have tried both the newest firmware files and the last version as well, but with no results. I also attempted to do this fix with the modem still connected to the router as well as to my computer, though I have since disconnected the modem from the router. As of right now my modem is getting an internet connection but my router isn't, and the green light is still flashing back and forth on power and USB. I could really use some help, been trying to go at this with this method for a few hours now.

Model: R6300|Dual Band 11ac WiFi Router R6300
Message 1 of 2
Highlighted
Aspirant

Re: Attempted to update firmware on R6350, won't connect now

I had this same issue previously. See:
https://community.netgear.com/t5/General-WiFi-Routers-Non/Warning-R6350-latest-firmware-update-brick...

 

Netgear support was not helpful at all. I asked repeatedly (both by phone and online) if they could confirm that the manual update would not do the same thing. They responded with answers totally unrelated to the issue and when they did act as if finally responding to the issue they did not respond to the ticket as my free support period expired. Phone support was hideous with person who could barely speak or understand English reading from a screen of prompts.

 

No help on forum either as many have reported this same problem.

 

I finally just left the .52 version of the firmware in place.

 

On a related note, I've had a Netgear Wifi Extender that had worked great since we installed it. Recently used the Automatic Firmware update function on it (after using it successfully several times previously) and it bricked the device.

 

I've used and recommended Netgear products for years, but I seriously doubt I will be purchasing any in the future.

 

 

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 449 views
  • 0 kudos
  • 2 in conversation
Announcements