Reply

Can't download files with apostrophe

Jazzper
Aspirant

Can't download files with apostrophe

I attached a USB drive to my R6400 and setup a ReadyCloud share to various folders.  Everything is working fine EXCEPT I cannot download an individual file if its name has an apostrophe in it.  If I try downloading a whole folder and that folder has a file in it with a name that has an apostrophe, it just hangs also.  There is no problem downloading files w/o an apostrophe.

The filenames are obviously in a legal format as I copied them up to the folder from my local drive for sharing with others.  Short of renaming all these files, any other ideas?

Model: R6400|AC1750 Smart WiFi Router
Message 1 of 7
antinode
Guru

Re: Can't download files with apostrophe

> [...] I cannot download an individual file if its name has an
> apostrophe in it. [...]

   "download" how, exactly, to what, exactly?  Computer/device?  OS
(version)?  Program (web browser, File Explorer, Finder, ...)?

> [...] The filenames are obviously in a legal format as I copied them
> up to the folder from my local drive for sharing with others.

   "copied" how, exactly, from what, exactly?  Computer/device?  OS
(version)?  Program (web browser, File Explorer, Finder, ...)?  That's
with the USB drive still on the R6400, not connected directly to the
(unspecified) computer/device with the "my local drive"?

   What's the file system on the USB drive (FAT, NTFS, Mac OS X
Extended, ...)?

> [...] Short of renaming all these files, any other ideas?

   Complain to Netgear, and hope for better firmware some day?

Message 2 of 7
Jazzper
Aspirant

Re: Can't download files with apostrophe

I initially copied a bunch of mp3's to my WD MyBook 1TB drive (formatted as FAT) from a MacBook while it was attached via USB.  I then connected the MyBook drive to the R6400 and configured the MyCloud shares and links.  I also ftp'd a couple of files to the drive just to test that functionality.  But I don't think those files had apostrophes in them so that'sa moot point.

 

A friend then went to that link I setup, tried downloading them to his Windows 10 PC and mentioned that he could not DL any file with an apostrophe.  Thinking it might be a Windows/Mac compatibility issue or a difference in browsers, I tried going to that same link and downloading files using the same Macbook that I used to put them on there.  I tried Safari, Chrome and Firefox and got the same results as my Windows-using friend.  So it's definitely a Netgear issue.  Just wondered if anyone else ran into the same thing and if they are aware of it. 

 

This is my first posting here so I'm not sure if they monitor this forum of if it's just for users to trade info.  I'm thinking best solution is to use my Synology NAS-Smiley Happy

Message 3 of 7
antinode
Guru

Re: Can't download files with apostrophe

> I initially copied a bunch of mp3's to my WD MyBook 1TB drive
> (formatted as FAT) from a MacBook while it was attached via USB.

   Again, "copied" how, exactly?  Finder, drag+drop?  "cp" command?

> [...] I then connected the MyBook drive to the R6400 [...]

   Ok.  So, these files were "copied" (somehow) to a Mac disk.  Have you
tried "copying" (somehow) a funny-name file to the shared file system
from a locally-connected computer?

> [...] configured the MyCloud shares and links.

   Eh?  My Cloud is a WD thing, isn't it?  ReadyCLOUD?  Again, actual
details may matter.

> A friend then went to that link I setup, tried downloading them to his
> Windows 10 PC and mentioned that he could not DL any file with an
> apostrophe. [...]

   What, approximately, was "that link I setup"?  Again, "downloading"
how, exactly?  "cannot" and "could not" are not useful problem
descriptions.  They do not say what you did.  They do not say what
happened when you did them.  As usual, showing actual actions with their
actual results (error messages, LED indicators, ...) can be more helpful
than vague descriptions or interpretations.

> [...] So it's definitely a Netgear issue.

   I don't doubt it, but without a clear guide showing how to reproduce
the problem, getting anyone to investigate it may be difficult.

> [...] I'm not sure if they monitor this forum of if it's just for
> users to trade info.

   Primarily the former, with just enough of the latter to raise your
hopes.


>  I'm thinking best solution is to use my Synology NAS [...]

   I'd expect that to be less buggy than any (dancing-bear) feature
you'll find in a Netgear router.

Message 4 of 7
Jazzper
Aspirant

Re: Can't download files with apostrophe

>> [...] What, approximately, was "that link I setup"?  Again, "downloading"
how, exactly?  "cannot" and "could not" are not useful problem
descriptions.  They do not say what you did.  They do not say what
happened when you did them.  As usual, showing actual actions with their
actual results (error messages, LED indicators, ...) can be more helpful
than vague descriptions or interpretations.

 

"that link I setup" relates back to my original post.  When you connecta USB drive to an R6400 and configure ReadyCloud (my bad with the "MyCloud" typo), one of the ReadyCloud menu options is to "create a weblink" that can then be emailed for users to access that share folder of files.  Have you previously attached a USB drive to your Netgear router?

 

>> [...] Again, actual details may matter.

At this point I don't think they really do.  Sounds like no one on here has run into a similar problem when attaching a USB drive to their router.  Also haven't heard any response from NetGear tech support, and I'm certainly not going to shell out $50 to call them! 

 

So it's off to Synology-land....like you mentioned, it a much more robust platform.

Thanks anyway.

Message 5 of 7

Re: Can't download files with apostrophe


@Jazzper wrote:

Everything is working fine EXCEPT I cannot download an individual file if its name has an apostrophe in it. 

 

Interesting question.  It sent me into test mode. I went to the USB drive I leave connected to ReadyShare and looked for a *'* filename. It was an mp3 file. I dragged it to the desktop with no difficulty.

 

It was an mp3 file, if that makes any difference.

 

I even managed to copy a file with some strange "French" characters.

 

I assume that these are standard ' characters and not typographical variants.

 

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 6 of 7
antinode
Guru

Re: Can't download files with apostrophe

> [...] I went to the USB drive I leave connected to ReadyShare [...]

   What's the file sysyem on that volume?

> [...] my WD MyBook 1TB drive (formatted as FAT) [...]


> [...] looked for a *'* filename. It was an mp3 file. I dragged it to
> the desktop with no difficulty.

   Accessing the shared volume how, exactly, from what, exactly? 
"dragged" means using File Explorer?

> A friend then went to that link I setup, tried downloading them to his
> Windows 10 PC and mentioned that he could not DL any file with an
> apostrophe. [...]

   One of us seems to be going through ReadyCLOUD.

 


> [...] It sent me into test mode. [...]

   Are you testing anything like the activity which led to the
complaint?

Message 7 of 7
Top Contributors
Discussion stats
  • 6 replies
  • 609 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E