Reply
Highlighted
Aspirant

Can't get VOIP to work through WNDR3700

Hi Folks,

I purchased a Netgear WNDR3700 on Friday 1/15 to replace my current router (a Linksys WRT54G).

I can't get my VOIP to work through the WNDR3700, even though it worked fine through the Linksys router. My VOIP provider is BroadVoice and my ATA device is a Grandstream HT-502. I've tried setting up Port Forwarding for ports 69, 5060-5063 and 10,000-20,000 (the same ports that were forwarded by the Linksys). I've tried with Disable SIP ALG checked and unchecked. I've tried disabling the SPI Firewell. I've tried settiing NAT to Open. I've tried making the HT-502 the DMZ host... All to no avail...

Does anyone know how to get Broadvoice/HT-502 to work through the WNDR3700?

Thanks

Gudge
Message 1 of 14
Highlighted
Aspirant

Re: Can't get VOIP to work through WNDR3700

I had a very similar problem. Actually my exact problem is that my calls were getting dropped a few seconds into them. I have the same Grandstream HT-502 behind the router.

I did the following:

0) Make sure that you reserve IP address of Grandstream so it doesn't change on you
1) Disabled both SPI and SIP ALG
2) Port forwarded 5004 to 5061 UDP to Grandstream IP address
3) Port forwarded 4200 TCP to Grandstream IP address

The above did the trick and it works great now. Also, I tried putting Grandstream IP address in DMZ instead of step (2) & (3). That worked for me too. So, I went with the safer solution above.

I hope this helps.

Regards
Message 2 of 14
Highlighted
Novice
Novice

Re: Can't get VOIP to work through WNDR3700

I found that simply disabling the SIP ALG fixed a similar problem for me. This is not un-common, before disabling SPI and forwarding ports, I'd try disabling just the SIP ALG.
Message 3 of 14
Highlighted
Aspirant

Re: Can't get VOIP to work through WNDR3700

Thanks for the replies, folks. I've tried various combinations of disabling SIP ALG, disabling SPI firewall, DMZ, port forwarding etc. but I still can't get it to work. Some guys at work have VOIP working through the WNDR3700 but they have a different VOIP provider (Vonage) to mine (BroadVoice).

I'll try again at the weekend...

Gudge
Message 4 of 14
Highlighted
Aspirant

Re: Can't get VOIP to work through WNDR3700

hbroamer wrote:

3) Port forwarded 4200 TCP to Grandstream IP address


Why do you forward this port? It's not a port used by the SIP or RTP protocols that Voip uses. Is it specific to Grandstream devices?
Message 5 of 14
Highlighted
Aspirant

Re: Can't get VOIP to work through WNDR3700

paspro wrote:
Why do you forward this port? It's not a port used by the SIP or RTP protocols that Voip uses. Is it specific to Grandstream devices?


It is probably because of my VOIP service provider, PhonePower. I got my list of ports to forward from their technical support. I wonder if it is used for voice mail notification...not really sure.

Regards
Message 6 of 14
Highlighted
Novice

Re: Can't get VOIP to work through WNDR3700

I had problems to, outgoing calls dropped after 21 secs.

Besides forwarding the correct ports and IP Address Reservation based I also switched on RIP version in the LAN settings to RIP_M2. The text in the WNDR 3700 says its on by default but actually it is switched off. RIP direction is set both ways, RIP switched on did the trick for me. VOIP adapter in use:Linksys SPA2100 (Sipura SPA-2100).
Message 7 of 14
Highlighted
Aspirant

Re: Can't get VOIP to work through WNDR3700

I have just tried all of the fixes discussed here and still can't get my VOIP to work. I have both callcentric and Broadvoice which both worked with my old routers (one of which was a Netgear DGND3300) but I just can't get them to work with the WNDR3700. The problem is that neither service will register with this router in place. I am running VOIP on the Liksys WRP400. Any further ideas?
Message 8 of 14
Highlighted
Aspirant

Re: Can't get VOIP to work through WNDR3700

I would check that the router is resolving all network names you are putting into your devices to the proper location. I have noticed that DNS problems are cropping up with this router.
Joseph
Message 9 of 14
Highlighted
Aspirant

Re: Can't get VOIP to work through WNDR3700

Thanks for your insight. It was a DNS problem. I had to put in the DNS addresses on my VOIP box that my VOIP provider gave to me. All of the other fixes were unnecessary for my configuration. Hope this helps some other poor souls not have to spend over a day trying to figure this one out. Technology -- its great when it works, but otherwise...
Message 10 of 14
Highlighted
Aspirant

Re: Can't get VOIP to work through WNDR3700

I've been able to get my BroadVoice VOIP working with the latest firmware update (V1.0.4.55NA).

I checked the 'Disable SIP ALG' checkbox on the WNDR3700.

I forwarded ports 69, 5060-5063, 10,000-20,000 to the HT-502.

I configured the HT-502 to have a static IP address and static DNS settings.

Thanks to everyone for their suggestions, it turned out to be a combination of DNS issues and the SIP ALG.

Cheers

Gudge
Message 11 of 14
Highlighted
Aspirant

Re: Can't get VOIP to work through WNDR3700

msb wrote:
I found that simply disabling the SIP ALG fixed a similar problem for me. This is not un-common, before disabling SPI and forwarding ports, I'd try disabling just the SIP ALG.


This worked for me as well. With Broadvoice and a Linksys SPA-2100.
Message 12 of 14
Highlighted
Novice

Re: Can't get VOIP to work through WNDR3700

I just wanted to add my experience. I just bought a WNDR3700 to update my WNDR3300. I moved to all gigabit connections so the new 3700 looked appealing.

I have Packet8 VOIP. I setup all my port forwarding like I had on the old 3300.

TCP 8880 starting port, 8880 Ending port
UDP 8000 starting port, 65534 Ending port

I could get my phone to dial out, but I could not get any audio back in. Everyone on the other end could hear me, but I could not hear them. Calls coming in would not ring either.

I eventually found it was the NAT filtering that I had to set to open in the WAN setup.

Just wanted to add in my problem and how I got it cured.
Message 13 of 14
Highlighted
Aspirant

Re: Can't get VOIP to work through WNDR3700

Although my router is a wndr4700 and this forum post is 4 years old, it helped me figure out what was causing Skype to get that choppy robotic sound on voice calls. Disabling the SIP ALG feature in the WAN setup solved the problem. Thanks for the help!
Message 14 of 14
Top Contributors
Discussion stats
  • 13 replies
  • 18956 views
  • 0 kudos
  • 10 in conversation
Announcements