Reply
Highlighted
Novice

Cannot access complete UI on routerlogin.net



Hopefully you can see that pic. Netgear is no help. I'm trying to access my router settings so I can update my firmware and edit port forwarding. I can't see the correct UI as shown above. There's no buttons to upload a firmware file, or press yes to update. Also, I can't even get to port forwarding. I've tried every sort of reset that I could think of.

Any ideas guys?
Message 1 of 2
Highlighted
NETGEAR Employee Retired

Re: Cannot access complete UI on routerlogin.net

Hi @lilcrumb033,

 

Welcome to the community!

 

I apologize but is it possible for you to upload the image once again? Regarding your concern, how did you reset the router? Have you tried the reset instruction from our knowledge base? If yes, I suggest for you make sure that you are really reaching that reset button by using a paper clip then try to follow the hard reset instructions below.


1. Push the reset button (power light will be blinking as an indication).
2. Count for 30 seconds.
3. Unplug the power cord from the router while still holding the reset.
4. Count for another 30 seconds.
5. Power on the router and wait for another 30 seconds.
6. Let go of the reset button.


After doing the steps above, you should be able to access your router once again and be able to configure your desired settings.

Let us know if this helps.

ElaineM
NETGEAR Community Team
Message 2 of 2
Discussion stats
  • 1 reply
  • 7804 views
  • 0 kudos
  • 2 in conversation
Announcements