Reply
Tutor

Device not grabbing the address I set as reservation

I have an WNDR4500 running firmware 1.0.1.36_01.0.63
I have an Amped Wireless range extender (SR10000) which, in the Lan Setup menu has an address reservation of 10.0.1.233:
http://imageshack.com/a/img661/1094/0IXuwA.jpg
The extender is working and any device connected to its network can see the internet. However,

1) ping is showing nothing on .233, and when I go to the "Attached Devices" page, I see the Extender's hardware address assigned to .28 instead, and nothing to .233.

2) when I do a LAN scan, I see a bunch of other addresses assigned to the Amped Wireless for the devices connected to it (DHCP relay): http://imageshack.com/a/img540/852/csB9lb.jpg, but these don't show up on the Attached Devices page of the Netgear router's admin pages: http://imageshack.com/a/img538/118/6sl9fC.jpg

What am I missing?
Message 1 of 6
NETGEAR Employee Retired

Re: Device not grabbing the address I set as reservation

In the Amped DHCP options can you set it to ‘disabled’ so that clients will go directly to the WNDR4500?
____________________________
Working on behalf of Netgear
My name is Andy
Message 2 of 6
Mentor

Re: Device not grabbing the address I set as reservation

I can't tell you why the Amped range extender is not getting the reserved address, but I may be able to provide some insight that could explain that as well as the other quirks you are seeing.

Let's talk about DHCP relay first - DHCP relay is used when the DHCP server is on a different network to the clients it is responding to - you seem to be using a single network range of 10.0.1.0/24, with the DHCP server at 10.0.1.1, which would mean that DHCP relay is not or can not be used.

The next thing I want to address is wireless range extension and more specifically wireless repeating, because most range extenders are configured as repeaters, but before I do this, I need to explain the interaction between ip addresses and MAC addresses as it relates to communications on the local network.

I know this will sound strange, but ip addresses are not actually used for local network communications - the MAC address is what is important - ethernet was around long before tcp/ip, and for tcp/ip to be used on an ethernet LAN, tcp/ip had to conform to the ethernet standards. WiFi as we know it, was once known as "wireless ethernet", and the same standards apply there - data packets are sent across the local network using MAC addresses to determine which device the data will be sent to or received by.

A range extender creates an unusual situation because the data intended for a device connected to the range extender must first be sent to the range extender, and then retransmitted by the range extender either to the router, or to the connected device - I hope you can see where this is going - if you have a laptop connected to the range extender, the router has to send the data for the laptop to the range extender, and to do so, it must use the range extender's MAC address instead of the laptop's MAC address, and the same holds true for every other device connected to the range extender - the reverse of this is also true, when the router receives data from that laptop, that data will be shown as originating from the range extender's MAC address.

Because of how range extension works there will be data packets crossing your network addressed to the range extender's MAC address when they are actually intended for a different device - which is why you are seeing the range extender's MAC address associated with several different ip addresses in a scan. I suspect that scan is being performed from a "wired system" - if you can, try performing it from a wireless system, see if the results change.

Let's go back now to that DHCP reservation - how DHCP works is that a DHCP client sends out a DHCP discover broadcast, and that broadcast will include the client's MAC address (at this time it has no ip address), and the DHCP server in the router will use this MAC address to send a DHCP offer to the client - the problem is, that when the DHCP server receives a DHCP discover request from any client system connected to the range extender, it's going to have the range extender's MAC address embedded in it - this may relate to why the range extender is not being given the reserved address.

Moving now to the router's "attached device" page - there are a couple of different ways to derive this information, and one of them is to pull it from what is known as the "arp cache" - which is an area in the router memory where ip address/MAC address pairings are temporarily stored - since the router never sees the MAC address of devices connected to the range extender, you would/should not see them shown here.

Hopefully you understand now, that what are perhaps normal conditions on a local network can change significantly when devices like range extenders are introduced, and can make for puzzling situations - what I would suggest you do, if you want the range extender at a particular address (which is a very good idea) is to set it at a static address (not a DHCP reservation), personally I consider it "best practice" to use static addressing on all my network infrastructure devices.

Give a man a fish, feed him for a day
Teach a man to fish, feed him for life.
Message 3 of 6
Tutor

Re: Device not grabbing the address I set as reservation

Babylon5 wrote:
In the Amped DHCP options can you set it to ‘disabled’ so that clients will go directly to the WNDR4500?


yeah, it was set as Disabled, but was getting a random (.52) address which was NOT the one assigned to that MAC address in the reservation list on the Netgear. Weird!! Then, the Amped Wireless support tech told me to set it to "Client", which I tried, and now the repeater isn't making a wifi network at all that I can detect, even though I've reset it. Assuming I ever get it back to working at all, is there any way to figure out why the Netgear isn't giving that device the reserved IP I want it to give?
Message 4 of 6
Tutor

Re: Device not grabbing the address I set as reservation

Babylon5 wrote:
In the Amped DHCP options can you set it to ‘disabled’ so that clients will go directly to the WNDR4500?


Yeah, it had been set to Disabled, but still getting a random (.52) address - not the one I had listed for that MAC address in the reservation table. Then the Amped Wireless support tech had me try setting it to "Client" instead, which for some reason made the repeater's network disappear completely - I can't detect its wifi network now with any of my devices even though I've reset it twice. Assuming I can ever get it back to making a wifi network and connecting to the router, any way on the WNDR4500 to see why it's giving it an address that's not the one in the reservation table?
Message 5 of 6
Tutor

Re: Device not grabbing the address I set as reservation

fordem wrote:
to the client - the problem is, that when the DHCP server receives a DHCP discover request from any client system connected to the range extender, it's going to have the range extender's MAC address embedded in it - this may relate to why the range extender is not being given the reserved address.

Moving now to the router's "attached device" page - there are a couple of different ways to derive this information, and one of them is to pull it from what is known as the "arp cache" - which is an area in the router memory where ip address/MAC address pairings are temporarily stored - since the router never sees the MAC address of devices connected to the range extender, you would/should not see them shown here.

Hopefully you understand now, that what are perhaps normal conditions on a local network can change significantly when devices like range extenders are introduced, and can make for puzzling situations - what I would suggest you do, if you want the range extender at a particular address (which is a very good idea) is to set it at a static address (not a DHCP reservation), personally I consider it "best practice" to use static addressing on all my network infrastructure devices.


thank you for this most informative reply. Remaining,
1) how do I make sure to give my repeater a static address? I don't see this option on the Amped Wireless' menu and the tech support hasn't been able to tell me... Anyone here know?
2) given that "router never sees the MAC address of devices connected to the range extender, you would/should not see them shown here.", what's the best way to know which device is getting which IP address on my whole network - is there a way short of piecing together info from both router and repeater manually?
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 9485 views
  • 0 kudos
  • 3 in conversation
Announcements