Reply

Messed up registration (on company end)=no support

timberbeard
Aspirant

Messed up registration (on company end)=no support

802.11ac Dual Band Gigabit     450+1300 Mbps           sole user at home  what is "firmware, OS, environment"?

I used to get the correct updates to firmware and sailed along seamlessly for some time.  Now the web site says both "no products registered" and "serial no. already registered".  Really? Is this a scheme to cut off all support?

  I stopped using my router for a time while moving across country.  During that time I missed an update.  Just got another but when I click on the link it takes me to a smartphone app for Nighthawk, but does nothing??!!  I've never had a Nighthawk.

  I hope someone can help me straighten this out pretty quickly. I really don't want to just abandon Netgear but I will if the nightmare continues for very much longer. 

Model: R6400|AC1750 Smart WiFi Router
Message 1 of 3

Accepted Solutions

Re: Messed up registration (on company end)=no support

 

There is support for the R6400, including a manual, somewhere at the end of this link:

 

>>> R6400 | Product | Support | NETGEAR <<<

 

You can download firmware from there.

 

The release notes tell you how to apply the firmware.

 

See also Update the Router Firmware in the manual.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V

View solution in original post

Message 2 of 3

All Replies

Re: Messed up registration (on company end)=no support

 

There is support for the R6400, including a manual, somewhere at the end of this link:

 

>>> R6400 | Product | Support | NETGEAR <<<

 

You can download firmware from there.

 

The release notes tell you how to apply the firmware.

 

See also Update the Router Firmware in the manual.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V

View solution in original post

Message 2 of 3
timberbeard
Aspirant

Re: Messed up registration (on company end)=no support

Thanks very much Michael Kenward.  Got 'er done.  Sorry I was being a big baby.  I can never take months off from anything technical, then when I come back, get it right on the first try.

(needed to update firmware from 1.0.23.34 to 1.0.1.46 via Mac  support login rejected)

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 548 views
  • 1 kudo
  • 2 in conversation
Announcements