Reply

Orbi RBR750/AX4200 - Getting slow speeds on mobile devices but not laptop

Raskolnikov
Follower

Orbi RBR750/AX4200 - Getting slow speeds on mobile devices but not laptop

I currently have 500 Mbps download from ISP and have a DOCSIS 3.1 cable modem hardwired to an ORBI RBR750 with 2 satellites. There was a recent ISP issue that disrupted internet service in my area and after the internet was restored, I noticed that my wifi speeds are about half as fast on my mobile devices including phones, amazon fire tv sticks and amazon fire tablets.

 

The strange part is that my wifi speeds on my connected laptop and desktop have come back to pre-outage levels but now only my mobile devices seem to still be slow. 


Things I have tried so far:

Rebooted Modem numerous times

Rebooted and factory-reset the Orbi router and satellites at least 3 times.

Upgraded lastest firmware for Orbi router

Spoke with ISP who state connection is fine on their end

 

In terms of diagnosing the issue, I typically used speedtest's app to test the speeds on all my devices where possible both before and after the outage. I have noticed that the ORBI's built-in speedtest often shows what I can only assume are erroneous results as it reports, for example 3.6 Mbps download and 4.1 Mbps upload, but if I test it on my wifi connect laptop or desktop, the speedtest app shows speeds for download of well over 300 Mbps and upload speeds of 37 Mbps so these don't seem to align. I verified that the speeds show consistent between speedtest.net and fast.com on my mobile devices so I don't think it is a measurement issue.

 

I also notice that when running the speedtests on my phone, it starts relatively high (150 Mbps for download) but then quickly dwindles down to about 70 Mbps on a good day. Upload also starts higher and then trends quickly downward over the course of the speedtests. 

 

I have tried utilizing the ISP's custom speedtest site and it reports consistent speeds of 500 Mbps/42 Mbps so I don't understand why there is such a discrepancy between speedtest, orbi's speedtest results and my ISP's custom speed test site.Any thoughts what might be causing issues only on my mobile devices when my computers which are also on wifi, don't seem to have any issues?

 

 

Message 1 of 1
Top Contributors
Discussion stats
  • 0 replies
  • 405 views
  • 0 kudos
  • 1 in conversation
Announcements

Orbi WiFi 6E