Reply
Aspirant

R6400 login page issue - it always redirect to the "Router Password Recovery" page

Hello,

I need a little help - intially I could login www.routerlogin.net with Chrome, but I not long later when logging in after entered the username and password I always rediret me to http://www.routerlogin.net/MNU_access_setRecovery_index.htm.

 

So I tried Internet Explorer, and it worked. But I don't know since when, but at least today  I could no longer login, it does the same - again it redirects me to to http://www.routerlogin.net/MNU_access_setRecovery_index.htm

 

So I resorted to FireFox, it worked but I'm very worried, I don't know if and when the router login page will block me from logging in.

 

Any hints and helps would be appreciated.

 

PS - it's my first time buying a netgear router and I kinda regret it. I didn't expect I couldn't contact the official support for free - I needed help, and during the registration on netgear.com, they asked me to input the purchase date of my R6400, I forgot and didn't bother to find the exact date. So after the registration the webpage showed to me that I couldn't get help for free after 90 days, I my actual purchase date is within 90 days but the webpage has no place for my to modify it. What a bad experiece.

Model: R6400|AC1750 Smart WiFi Router
Message 1 of 8

Re: R6400 login page issue - it always redirect to the "Router Password Recovery" page

Greetings,

It sounds like you are using the Auto-Complete or Remember Password feature in Chrome, but have inadvertenly saved the wrong username or password combination.  This is why you would be re-directed to the PW recovery page.  This is also confirmed since you are able to use another browser where you didn't save the credentials successfully.  This is not the routers fault.  Sorry that you entered inaccurate information during the registration process.  Sounds like you know what happend there.  I agree they could make it a little easier to contact support, but that's not the case.

 

The issue you are experiencing has to do with Chrome and the credentials you have saved for routerlogin.net

 

Password management is located under the Settings menu, Advanced options.  Here you can review or edit saved credentials.   

 

 

 

   

~Comcast 1 Gbps/50 Mbps SB8200 > R8000P
~R8000P FW:1.4.1.64 ~R7000 FW:1.0.9.42
~R6400 FW:1.0.1.52 ~Orbi-AC3000 FW:2.5.1.8
~EX3700 FW:1.0.0.84

Message 2 of 8
Aspirant

Re: R6400 login page issue - it always redirect to the "Router Password Recovery" page

@shadowsports Thanks for your reply, I somehow overlooked the notification email thus wasn't aware your reply unitl today.

 

No, my Chrome doesn't save any password, I double checked it, actually I use KeePass with the chromeIPass extension.

 

But just one minute ago I tried again - I don't know what happend, but it works now. The only thing I know is that my Chrome's updated to the latest version recently.

 

Also, IE works now. I'm really puzzeled although I've been a programer for over a decade...

 

Re "Sounds like you know what happend there. ", I'm not sure what you mean, I've no idea what such strange issues existed and I'm not sure if the issues will happen again, sadly.

Message 3 of 8

Re: R6400 login page issue - it always redirect to the "Router Password Recovery" page

I believe what happened is explainable.  There might have been cached information somewhere which was causing the browser to redirect to to the PW recovery page.  Very familar with KeePass, several of my clients use it.  But am happy to hear the problem is now resolved and that you didn't need to reset to recover.  Lets hope it doesn't happen again.  I have PW recovery disabled on my devices.   

~Comcast 1 Gbps/50 Mbps SB8200 > R8000P
~R8000P FW:1.4.1.64 ~R7000 FW:1.0.9.42
~R6400 FW:1.0.1.52 ~Orbi-AC3000 FW:2.5.1.8
~EX3700 FW:1.0.0.84

Message 4 of 8

Re: R6400 login page issue - it always redirect to the "Router Password Recovery" page

You seem to have fixed the problem, but you might like to know a bit more about that dreaded "password recovery" feature.

 

There is a bug in some devices in Netgear's implementation of password recovery. You can get locked into a close loop.

 

If password recovery is enabled, but you have not set the answers to the questions, it keeps sending you back to the beginning of the process because you can't answer the questions.

 

If the standard factory password (password) does not work, then you will have to factory reset the thing to get back to that. Then either disable password recovery (check the manual for your device) or provide some answers to those questions.

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 5 of 8
Aspirant

Re: R6400 login page issue - it always redirect to the "Router Password Recovery" page

Thanks for hte help Michael!

Just one quesiton - if I disable the 'password recovery' option, I assume the hardware factory reset button will still work, right?

Message 6 of 8
Aspirant

Re: R6400 login page issue - it always redirect to the "Router Password Recovery" page

Well, I just checked, I have answers set for the two security questions...

Message 7 of 8

Re: R6400 login page issue - it always redirect to the "Router Password Recovery" page


@regretngrouter wrote:

 

Just one quesiton - if I disable the 'password recovery' option, I assume the hardware factory reset button will still work, right?


Yes.

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 1432 views
  • 0 kudos
  • 3 in conversation
Announcements