R6400v2 Stopped loading certain webpages and Sling TV


R6400v2 Stopped loading certain webpages and Sling TV

Two days ago all my connected devices with Sling TV app and the Sling website no longer worked. Then I had wireless printer issues where it would fail to print sporatically.  Then certain webpages for my work stopped loading.  I did a factory reset of the router, and power cycled my modem.  My work tech support connected to my network and the lag was so bad they could barely help out (I have 333mbps internet).  Wireless and ethernet connection all the same.  


Everything worked when I connected directly to modem or used an old D-link wifi router.


Any ideas?

Model: R6400|AC1750 Smart WiFi Router
Message 1 of 2

Re: R6400v2 Stopped loading certain webpages and Sling TV

Electronics do go bad. How old is the R6400? it has a 1 year warranty.

here's some things you can try though.

You've tried a reset.

What firmware are you running? Try updating firmware, then doing a reset.  make sure to do it over a hard wired connection.

Another option is power supplies. these can occassionally go out or not give the router enough power under load. If you have a spare 12v off another device (look at R6400 power output specs and make sure its same voltage and at least enough amperage), you can try a new power supply.

You state that everything works fine if directly connected or if using an old router. Not a good sign for the R6400 but worth checking into if its a firmware issue, power supply issue, or just straight bad router issue. 


Current Setup: CM2000-> SXK30-> GS716v2-> Arris W31 x2-> Pi-hole->
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 0 kudos
  • 2 in conversation