Reply
Aspirant

USB Stopped working

I have an old WNDR3700 (rev0)  with an attached USB hard drive acting as my sound system music NAS.

 

It was working fine until today - my sound system reported it couldn't find any music.  

 

I've "Tried Rebooting" the router, unplugged the USB and ran CHKDSK on it and found no issues.  

 

Other places to look before I throw it out and buy something else?

 

 

Message 1 of 6
NETGEAR Employee Retired

Re: USB Stopped working

Hello @mj000001,

 

Welcome to the community!

 

Is there a USB light on the router?

Access the admin page of the router and see if it will be recognize  by showing its self under USB storage.

Can you try to access it using "\\readyshare_USB name".

Also, try to disable by unchecking ReadyDLNA under Media Server then hit Apply. Once done, re-enable it and saved the settings.

 

Let us know what happens.

 

Regards,

ElaineM
NETGEAR Community Team
Message 2 of 6
Aspirant

Re: USB Stopped working

Hi Elanie,

 

Yes - the USB light is on.  The HD itself - the light blinks indicating power-saving mode.  When I access the Admin UI and select Advance under USB settings - the drive powers up (light becomes steady) plus I can hear the drive spinning.

 

However, in the admin web UI the choice to select a USB drive remains disabled.

 

I have plugged the drive into my PC, run Chkdsk, and even reformatted it - still it won't work.

 

I'm looking for a place to view a log that indicates why the Router no longer likes this HD.  LIke I said - it's been working fine for years.

Message 3 of 6
NETGEAR Employee Retired

Re: USB Stopped working

@mj000001 Have you tried using a different USB drive to see if it will still be recognized by the router?

Do you have the latest firmware installed on the router?

How about reset and reconfigure?

I cannot give a direct answer as to why it will no longer recognize but possibilities would be hardware is starting to degrade or firmware problem.

ElaineM
NETGEAR Community Team
Message 4 of 6
Aspirant

Re: USB Stopped working

thanks - I tried all of the obvious.  I was hoping there was an undocumented tool that could provide some insite.

 

Thank you.

Message 5 of 6
NETGEAR Employee Retired

Re: USB Stopped working

@mj000001 Can you confirm if a different USB drive is detected by the router? Perhaps, just try a thumb drive to check.

By the way, what's the brand and model of the HDD that you have? Also, post a screenshot where it shows that the USB drive is disabled.

 

Looking forward to your response.

ElaineM
NETGEAR Community Team
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 2070 views
  • 0 kudos
  • 2 in conversation
Announcements