Reply
Aspirant

WGR614v10 drops wireless connection from Ubuntu 11.04

Router: Netgear WGR614v10

Internet Connection: DSL (static IP)

Test PC: Dell Inspiron 6000
Operating System: Ubuntu 11.04
Network Controller: Intel Corporation PRO/Wireless 2200BG [Calexico2]

---------------

Description:

Wired connections work flawlessly.

Prior to OS upgrade, wireless connections made from pc's running Windows NT, Windows XP and Ubuntu 10.10 showed NO problems whatsoever.

Since our Linux pc's were upgraded to Ubuntu 11.04, we have experienced an ever frustrating series of dropped wireless connections.

In general, wireless connectivity lasts from 1- 3 minutes before disconnecting. On the rare occasion (1 in 20), the connection will perform normally, but resume the dropping of connections the very next time the machine is rebooted.

Strangely, these same laptops have been able to establish AND maintain connections with other wireless networks in various locations WITHOUT difficulty.

We have reset the modem to factory defaults, but continue to experience this very confusing behavior.

This is seriously impacting our ability to work!

Any insight into the source or solution would be deeply appreciated.

Thanks...
Message 1 of 6
Aspirant

Re: WGR614v10 drops wireless connection from Ubuntu 11.04

Additional information regarding the test pc:

lspci output:

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root Port (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
03:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
03:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
03:01.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 17)
03:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)

----------

uname -r

2.6.38-8-generic-pae

----------

cat /etc/issue

Ubuntu 11.04 \n \l

----------

Please Note: This configuration tests without a problem against other networks, and ran flawlessly under Ubuntu 10.10.
Message 2 of 6
Aspirant

Re: WGR614v10 drops wireless connection from Ubuntu 11.04

Update:

The problem continues - as does our frustration. The Ubuntu laptops connect without problem to other wireless networks (both public and private), but drop connections in-house.

The router has been reset to factory defaults, with no change in behavior.

Sadly, we will have to replace the WGR614v10, if a solution can not be found.

Does anyone in the community, or at Netgear, have a clue as to what is going on here? Your HELP is most sincerely appreciated.
Message 3 of 6
Aspirant

Re: WGR614v10 drops wireless connection from Ubuntu 11.04

ADDITIONAL INFORMATION:

If Ubuntu 11.04 is booted with a wired connection and left to run for approximately 1 hour (the wireless connection auto starts at the same time), the wireless connection will remain stable after the wired connection is disconnected.

The problem returns, however, as soon as the machine is rebooted.

Something in this equation makes absolutely NO sense to us....

Any suggestion would be greatly appreciated!
Message 4 of 6
Aspirant

Re: WGR614v10 drops wireless connection from Ubuntu 11.04

It now appears that the source of the problem was a conflict between the WICD Network Manager and the Ubuntu Connection Manager.

Once the option "Automatically Connect to this Network" was deselected within WICD, and the machine rebooted - the connection appears stable.
Message 5 of 6
Virtuoso

Re: WGR614v10 drops wireless connection from Ubuntu 11.04

Jut to save you time, have you hang out at unbuntu forum? This site has very small Linux user so may want to change your strategies Smiley Happy
VPN Case Study

VPNCASESTUDY.COM

"Our Second To None VPN Related Setup Case Study[/COLOR][/URL]

"One Stop Solution To Your Netgear VPN Connectivity"

*Visit the site for Non-VPN related Doc & Links* [Windows & Mac user/support]





June Mizoguchi-
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 5789 views
  • 0 kudos
  • 2 in conversation
Announcements