Reply

Re: WNDR3700v3 Unable to downgrade firmware

kapeens
Aspirant

WNDR3700v3 Unable to downgrade firmware

Hello,

 

I'm trying to downgrade my Netgear WNDR3700v3, but can't get the router into recovery mode.

 

Running Stock firmware V1.0.0.38_1.0.31 with some multicast issues. I want to downgrade to V1.0.0.27 and do more testing. I must say i have tried DD-wrt and TomatoUSB as well, before returning to the stock firmware. I'm now looking for support on the official Netgear firmware only.

 

When in the Netgear Genie interface, advanced, router-update, no firmware is accepted. I have tried WNDR3700v3-V1.0.0.18_1.0.14.chk and WNDR3700v3-V1.0.0.30_1.0.27.chk (from the Netgear support site) and both jump directly to failed, check file. 

 

I tried everything, 30-30-30 reset. Holding the reset button for 90secs, non of it worked.

 

Does anyone have a solution?

 

Thanks. 

Message 1 of 3
jlewter
Guide

Re: WNDR3700v3 Unable to downgrade firmware

Here is what google returns for me... Personally speaking I have used recovery mode a few times but some of the guides out there have the sequence slightly wrong.  I cant remember if this is how my products went into recovery mode or not... I know that there is/was a guide on these forums a long time ago that was slightly wrong.  Step 2 of the following guide is where it was normally wrong in the past... And in fact, I wonder if this one is wrong... My memory fails me sometimes on things, but I thought you held it until everything started flashing, and KEPT holding it until you ended up with a amber flashing light.  First set of flashing was reset, Second set of flashing was recovery mode.  But try the guide first and if you get no joy post back.  The other option is to go back to ddwrt/tomato and then re-flash with a old version of stock firmware.  Be aware that some devices (I doubt the 3700v3 will be one) have upgrade paths that sometimes CAN NOT be reversed...  But I doubt this is the case here, and even if it is then recovering to a new-ish firmware should still be possible.

Source Stolen From DD-Wrt Forum

 

[Quote=DDWrt Forum]

So you've bought a shiny new wireless router for your home network and loaded it with DD-WRT. Like myself, you've decided it's just not for you and you'd rather return to the factory firmware. I've read through the forums and still found the guides a little confusing. So here's how to restore the stock or factory firmware on your Netgear WNDR3700 router in five simple and easy to understand steps.

Before you begin you will need to gather these resources:

      1. A push pin, safety pin or needle.

 

      2. A copy of the latest WNDR3700 firmware which you can download

[HERE]


Note that this guide was written for the Netgear WNDR3700-100NAS Revision: 02R1 using Windows 7 64-bit. This will work for any WNDR3700 router currently running DD-WRT.


Step 1: Setting Your Static IP Address

It is important that you setup a static IP address on your computer. Navigate to: "Start" -> "Control Panel" -> "Network and Internet" -> "Network and Sharing Center" -> "Change adapter settings" (left side). Now right click on your local area connection and open up the properties window. Select "Internet Protocol Version 4 (TCP/IPv4)" and click on properties. Enter the following information then click "OK".

Quote:

IP address: 192.168.1.2
Subnet mask: 255.255.255.0
Default gateway: <leave blank>
Preferred DNS server: <leave blank>
Alternate DNS server: <leave blank>




Step 2: Placing the Router Into Recovery Mode

Start by turning off the router using the power button on the back of the device. Now, using the small object of your choice, press and hold the "Restore Factory Settings", also known as the Reset button located on the bottom of the router (there is a red ring around it). While holding the rest button, turn the router back on. Continue to hold the reset button for approximately 45 seconds then release it.

** NOTE: Before you release the reset button, just be sure the power LED light on the router is flashing. If it isn't, continue to hold it for about another 15 seconds until it is flashing.


Step 3: Enable the TFTP Client in Windows

If you are using Windows Vista or Windows 7, you will need to enable the TFTP client. To do this, navigate to: "Start" -> "Control Panel" -> "Programs" -> "Programs and Features" -> "Turn Windows features on or off" (left side). From there, scroll down until you spot "TFTP Client". Check the box if it isnt already and click "OK". Exit the control panel.


Step 4: Flash the Firmware

Start by opening up a command prompt. From there you will want to type "cd desktop" in order to change your working directory to your desktop. Assuming of course that is where you saved the firmware download. Now for the fun bit. In the command window type:

Quote:
tftp -i 192.168.1.1 put WNDR3700-V1.0.4.68NA.img



** NOTE: Be sure to use the appropriate name of the file you are trying to flash. It may be a later version then the one I used as an example.


Step 5: The Waiting Game

This would be the perfect time to go grab a drink or hit the washroom. You need to be patient. Do not turn off, restart, unplug cables or otherwise interact with your router. It may take a little while; this is normal! Watch the power LED light on the front of the router. It should remain orange throughout the process. Once it is complete, it will turn green. At this point you may proceed to point your browser to "192.168.1.1" and continue to setup your router.

Good luck!

[/Quote]

Message 2 of 3
kapeens
Aspirant

Re: WNDR3700v3 Unable to downgrade firmware

Thank you for the impressive answer.

  

After a few days off trying I ended-up doing the following...

 

First of all. I would like to warn everybody, read up at the websites of DD-wrt and OpenWRT before you delete any partitions. There might be other, easier solutions, but if everything fails give it a try at your own risk.

 

1. Enable telnet on the Netgear (http://wiki.openwrt.org/toh/netgear/telnet.console#telnetenable_on_unixlinuxos_x)

2. Login with the same user as the web-interface

$ ./telnetenable
Version: 0.4, 2009/10/18
Usage: ./telnetenable <host ip> <host mac> <user name> [password]
$ ./telnetenable 192.168.1.1 001E3A04E2EB Gearguy Geardog
$ telnet 192.168.1.1
Trying 192.168.1.1...
Connected to 192.168.1.1.
Escape character is '^]'.


BusyBox v0.60.0 (2008.05.15-10:32+0000) Built-in shell (msh)
Enter 'help' for a list of built-in commands.

# version
Release version : Netgear Wireless Router WGR614v8
                  U12H07200/V1.1.11/6.0.36NA
           Time : May 15 2008 18:35:41
# exit
Connection to 192.168.1.1 closed by foreign host.
$

 

3. Find the correct patition 

cat /proc/mtd

 

4. Delete the mtd-partition-number that is named 'Linux'. (replace <mtd?> with the correct one)

mtd erase -d <mtd?>

5. Now the that the linux partition is gone, power-cycle the router, when the power light starts flashing the router accepts a new firmware image.

6. tFTP a new firmware, stock, DD-wrt or OpenWRT... for example http://wiki.openwrt.org/doc/howto/generic.flashing.tftp

 

Good luck!

 

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 5489 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 6E