Reply
jimmyo68
Aspirant

WNDR4300 ReadyShare issue after firmware Upgrade to 1.02.80

I'm having a weird issue after upgrading my Netgear WNDR4300 to 1.02.80 from 1.01.60 firmware level.  I have a Western Digital 500GB MyBook that has worked for years without issue.  It is connected to the USB port on the WNDR4300.  I would use MS SyncToy to replicate files from a local C: drive on multiple computers to the MyBook through ReadyShare.  After the firmware upgrade all files are set to read only.  I have reconfigured ReadyShare to allow all users full access, unplugged the USB from the router, reattached, etc.  Tried deleting the readyshare config and creating a new one as well.  Everything is "read only".  I get various "access denied" errors attempting to create new subfolders, edit existing documents, etc.  

 

If I connect the WD 500GB USB drive directly to my laptop I have no issues.  

 

Has anyone else experienced this?

 

Jim

Message 1 of 6

Accepted Solutions
jimmyo68
Aspirant

Re: WNDR4300 ReadyShare issue after firmware Upgrade to 1.02.80

ElaineM,

 

    The problem is now resolved.  I performed the following steps:

 

1. Attached the WD MyBook 500GB USB drive to my laptop.

2. Ran the Windows 10 scandisk tool which indicated it repaired errors.

3. Due to results in #2, I decided to copy the USB contents to a temp directory on my laptop.

4. I was able to copy all but a few files to the temp directory.

5. Used a sync tool to confirm I had all folders/files in the temp directory from the USB drive.

6. Ran Windows 10 format against the USB drive as NTFS (did not use quick format option).  

7. Moved folders/files back to USB drive.

8. Went into Windows 10 security tab for USB drive and made sure all users had ful authority to USB drive.

9. Connected USB drive back to router USB port.

10.Went into advanced settings and added the WD MyBook USB drive to readyshare.

 

Everything is back to normal.  Not sure if I can blame this on the firmware upgrade.  I was able to add folders/files to the drive a couple of months before the firmware upgrade.  

 

Jim 

View solution in original post

Message 5 of 6

All Replies
jimmyo68
Aspirant

Re: WNDR4300 ReadyShare issue after firmware Upgrade to 1.02.80

Update - 

 

I see the following entries in the router log:

 

[WLAN access rejected: incorrect security] from MAC address xx:xx:xx:xx:xx:xx, Sunday, August xx, 2015 13:46:01

 

I see this error in the log when the USB drive is connected to ReadyShare and i am accessing directories from my Windows 10 Pro laptop.  Any ideas on the cause of this message?

 

Jim

Message 2 of 6
jimmyo68
Aspirant

Re: WNDR4300 ReadyShare issue after firmware Upgrade to 1.02.80

WLAN access reject error resolved.  Had a mac address issue with one device that was reset.  

Message 3 of 6
ElaineM
NETGEAR Employee Retired

Re: WNDR4300 ReadyShare issue after firmware Upgrade to 1.02.80

Hi @jimmyo68,

 

Welcome to the community!

 

Will you be getting the same result if you downgraded back to 1.0.1.60? Trying to isolate whether if it's a firmware issue.

 

Let us know what happens.

 

Regards,

ElaineM
NETGEAR Community Team
Message 4 of 6
jimmyo68
Aspirant

Re: WNDR4300 ReadyShare issue after firmware Upgrade to 1.02.80

ElaineM,

 

    The problem is now resolved.  I performed the following steps:

 

1. Attached the WD MyBook 500GB USB drive to my laptop.

2. Ran the Windows 10 scandisk tool which indicated it repaired errors.

3. Due to results in #2, I decided to copy the USB contents to a temp directory on my laptop.

4. I was able to copy all but a few files to the temp directory.

5. Used a sync tool to confirm I had all folders/files in the temp directory from the USB drive.

6. Ran Windows 10 format against the USB drive as NTFS (did not use quick format option).  

7. Moved folders/files back to USB drive.

8. Went into Windows 10 security tab for USB drive and made sure all users had ful authority to USB drive.

9. Connected USB drive back to router USB port.

10.Went into advanced settings and added the WD MyBook USB drive to readyshare.

 

Everything is back to normal.  Not sure if I can blame this on the firmware upgrade.  I was able to add folders/files to the drive a couple of months before the firmware upgrade.  

 

Jim 

View solution in original post

Message 5 of 6
ElaineM
NETGEAR Employee Retired

Re: WNDR4300 ReadyShare issue after firmware Upgrade to 1.02.80

@jimmyo68 Thank for that update! This will be a big help for others who would encounter the same problem after firmware upgrade.

However, firmware upgrade should not change the file to read-only unless it's stated in the release notes though it's still possible.

Again, thank you for this!

 

Regards,

ElaineM
NETGEAR Community Team
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 2713 views
  • 0 kudos
  • 2 in conversation
Announcements