Reply

Windows 10 random DNS server isn't responding error.

sharp461
Aspirant

Windows 10 random DNS server isn't responding error.

So I am not entirely sure if this is a problem with my router, PC, or something else, but I figured I would ask.

 

So for the past two weeks, I have gotten this random internet error (almost like once a week). Everything would be working fine and then just suddenly I have no internet, and having Windows troubleshoot it gives me the error "The DNS server isn't responding." The strange thing is though, my wifi was still working perfectly fine (tested on phone) and the other PC in the house that is wired had no issues, so that rules out my router/modem. Still to be on the safe side, I did my own troubleshooting and so I: 1) restarted the modem and router, 2) bought a new LAN cable just in case, 3) changed the DNS server manually to Googles' (8.8.8.8), 4) updated the LAN adapter drivers, 5) disabled and enabled the LAN adapter, 6) disabled IPv6, and 7) even flushed the DNS and renewed IP. Some info, when the problem happens, I can still ping 8.8.8.8 or even my router at192.168.1.1, but I cannot ping a website.

 

None of these solutions I read online worked, but you know what did? Restarting the PC. This led me to believe that this is a Windows issue, not any of my hardware. Considering it is only my PC which seems to be affected, and even if it lost the internet, everything else on the Network is working fine. And if the only fix seems to be to restart, then something in Windows is causing this. I just checked too when the last Windows update was, and wouldn't you believe it, 4/10/2019, update KB4493509. My issue only started happening on 4/14 ( I remember because Game of Thrones was starting soon). Never had an issue before, and that update is pretty close to cause me to wonder if it messed something up.

 

Also, the error seems to be pretty random, as it happened once, I restarted and all was good for the rest of the night. Then I left the PC on overnight to download a game and when I woke up, the game had finished and installed successfully but I lost internet again (this was on 4/14-15). After I restarted again and installed the new LAN drivers just in case, I didn't have this issue again until a week later, 4/23. Restarted and I was fine until today, 4/30. And then it happened again today, 5/3. Now I did just notice I can change the DNS manually in the router itself, so I was going to try that when it happens again, but I figured changing it in Windows would be enough? Thanks, and sorry if this is not at all related to the router.

 

 

Model: R6220|AC1200 Smart WiFi Router with External Antennas
Message 1 of 3
additude
Virtuoso

Re: Windows 10 random DNS server isn't responding error.

Yea, it sort of points to your computer as the problem source. As for the MS Update... could be, but you updated drivers so maybe more likely not the Update.

It's possible your hardware is failing.

You might consider purchasing a USB Thumbdrive WiFi if you have WiFi capable router and see if that stabalizes things. They are cheap enough.

If you get to a CMD console screen, when you have an issue use the command line and type "ipconfig /renew" and see if that refreshes your connection instead of rebooting the computer. If it does refresh then that would narrow your problems down to mostly network related issues and not software conflicts....

So those are a few things you can try to localize the problem.

 

Message 2 of 3
sharp461
Aspirant

Re: Windows 10 random DNS server isn't responding error.

An update: Computer was working fine since my last post on May 6th, but finally happened again last night on the 21st. I shut off my PC though to go to bed and the issue was still there when I turned on my PC later (possibly due to Windows Fast Startup) so I restarted normally and issue is gone. When I lost internet, I checked the lease time and it was about 4-5 hours after my ip renewed, and it wasn't supposed to expire until the next day. I also tried bypassing the router just to see what happens, and I still got nothing (and yes I renewed IP again as the PC did not pick up the new IP by itself). I also checked my Netgear Genie on my PC to see that it supposedly says I'm connected o the router, but trying to log in says it can't find it. In fact,. I can't log into my router through my browser either when this problem happens, yet I can still ping stuff and the router does say I am connected with an IP and everything. I am definitely leaning towards windows at fault, but what in Windows could actually cause this?

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 1584 views
  • 0 kudos
  • 2 in conversation
Announcements