Reply
Highlighted
Aspirant

Wndr 3700, how to change cmos battery?

I have had my Wndr 3700v2 for more than 4 years. Now it has stopped setting the clock - starts at 1/1 2000 and doesn't update via NTP (the log used to contain timesetting messages).

I have tried resetting to factory settings, even downgraded to firmware V1.0.1.10, but no good.

So I expect it's the cmos battery that is out.

But........... I can't get into the router. I can unmount the 2 screws on the back but still I can't disassemble the box.

How do I do that?

Message 1 of 4
Highlighted
Guru

Re: Wndr 3700, how to change cmos battery?

According to the teardown instructions at ifixit.com, there are 4 more screws under the feet.  Anyway, judging from the teardown photos, I don't see a CMOS battery.  Even if it did have one, it wouldn't come into play when the router is powered on.  You should keep investigating NTP.  Maybe try a factory reset for giggles.

Message 2 of 4
Highlighted
Aspirant

Re: Wndr 3700, how to change cmos battery?

Well, as I said, I have tried a factory reset without luck.

However, your explanation makes sense about the screews.

If there's no cmos, then what can be the problem? It has been going on for several months with different software versions.

Message 3 of 4
Highlighted
Master

Re: Wndr 3700, how to change cmos battery?

I highly doubt router has a CMOS. Did you try different time server? You mean you are unable to

set time initially in the router?  If you can access router via putty or ssh, clear the nvram.

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 2615 views
  • 0 kudos
  • 3 in conversation
Announcements