Reply

Re: routerlogin.net password reset portal not working

EEUT84
Initiate

routerlogin.net password reset portal not working

I am attempting to update my firmware (prompted by a security vulnerability), and I do not know what my credentials are for routerlogin.net (not admin/password).  On the password reset portal, the Continue button is grayed out in IE and Chrome.  I can get past the first screen by hitting return after I input my serial number, but I cannot get past the security questions screen.  This is a ridiculous waste of time, why is it so hard to accomplish this simple task?

Model: R6400|AC1750 Smart WiFi Router
Message 1 of 8
EEUT84
Initiate

Re: routerlogin.net password reset portal not working

I have seen a recommended solution of resetting my router...I'm not doing that.  Please fix the site.  

Message 2 of 8

Re: routerlogin.net password reset portal not working

If the default passwords do not work, then someone must have changed them in the past.

 

The only way to overcome forgotten passwords and to recover the device is to reset it so that it reverts to the defaults. Then you can get in and upgrade the firmware. If you don't do that then the security issue will remain.

 



Please fix the site.  

 


 

What site? There is no site involved. The web interface you see is within the modem/router itself. There is no website out there on the Internet. After all, you have to be able to get to that stuff when you are not on line.

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 3 of 8
ccseas
Aspirant

Re: routerlogin.net password reset portal not working

I am running into this same issue. I can not remember the admin password (I didn't think I had changed it), and using the www.routerlogin.net page to recover it is not working. The "continue" button has no effect after typing in the serial number. I'm attaching a screenshot - it looks the same when I type in my serial #. Hitting "return" does nothing. I've tried with Chrome and Firefox, same results. Safari never gets past the first "cancel" to get to this screen, just keeps asking for username/password.

 

I'll try the hard reset on the router to recover the default password, and do a better job of remembering it (or putting in lastpass).

 

Model: R7000|AC1900 Smart WIFI Router
Message 4 of 8
primaldiva
Initiate

Re: routerlogin.net password reset portal not working

This happened to me as well.  The problem is if you never went into advanced settings and enabled password recovery; this screen will just hang.  Netgear should fiux it, agreed.  Here are some articles that will help.  Basically at this point your only option is to reset your router but this time secure your password and setup password recovery. 

 

https://kb.netgear.com/24220/How-do-I-recover-my-password-on-my-Nighthawk-router

 

 

https://kb.netgear.com/20027/Configuring-router-administrative-password-recovery

Model: R7000|AC1900 Smart WIFI Router
Message 5 of 8
NealSOS
Initiate

Re: routerlogin.net password reset portal not working

I noticed your post after having the same problem connecting to routerlogin.net.  I have wasted three hours working on this problem.  Used Google search, you tube, and this comunity along with others.  After six or seven different "fixes" I have found the answer and here it is!

Took the router bact to costco and got my money back and bought a linksys!  That is the FIX!  Their is no reason to spend $150 for something you have to work on to use!  Hope that helps everyone else having the same issue!  DONT WASTE YOUR TIME!  

ps Also forwarded this information on costoco's web site along with consumer reports!

Message 6 of 8
DDC1
Initiate

Re: routerlogin.net password reset portal not working

I am also having same problem.   I have a Netgear account, but I did not change the Genie account - it says it was supposed to be admin and password but that never worked.   I am trying to use the router password recovery but it will not accept my serial number.   I have removed the netgear genie program and reinstalled but no luck.   I am trying to get to my readyshare account.   

Message 7 of 8

Re: routerlogin.net password reset portal not working

 

 



I am also having same problem.  

 


Possibly, but not from what you have said so far.

 

There are several things going on here. A Netgear account has nothing to do with logging into your router to set it up or change its settings.

 

What are you trying to do?

 

A lot of this is already describe higher up in this discussion, but let's start again. I would point you at the manual for your device, but you don't say what that is.

 



I have a Netgear account, but I did not change the Genie account - it says it was supposed to be admin and password but that never worked.  

 


 

That combination, admin and password, is to login to the hardware's local browser interface. That lets you manage your router, update the firmware and do things like that. It takes you nowhere near the world wide web and the Internet.  You can even use it when you are not connected to anything but your PC.

 

To get into this, you use the usual address

 

http://www.routerlogin.com/
 
or
 
http://www.routerlogin.net
 
If they don't work, then the IP address might be an option. Here the usual suspects are:
 
http://192.168.0.1
 
or
 
http://192.168.1.1
 

If none of this works, read this:

 

If you cannot login to your router | Answer | NETGEAR Support

 



I am trying to use the router password recovery but it will not accept my serial number.  

 



That only works if you set up password recovery ion the first place. Sounds like you never got that far. In that case there is a bug, in the firmware that means you cannot get out of that closed loop if password recovery is turned on but you haven't set it up.

 

The only way ouf of that is to do a factory reset, which means that admin and password will work.

 

 



I am trying to get to my readyshare account.   

 


I don't know what that means. One use of Rapidshare is to give you local access to USB storage attached to your router/modem, if that is what you have.

 



I have removed the netgear genie program and reinstalled but no luck.  

 


That could be one of several things. Again, it is hard to know what you are doing and where it goes wrong without more information.

 

Finally, you have joined in on an existing conversation that may or may not have anything to do with your problems.

There is a good chance that the official support team is busily monitoring new conversations and may miss your addition to this one.

If you want help with your problem, you should start your own discussion. If you do decide to ask a question, you really need to provide more details. For example, as this is a router, it helps to know what modem you are using and the various things that you have tried to fix the problem.

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 18382 views
  • 7 kudos
  • 6 in conversation
Announcements

Orbi WiFi 6E