Reply
Aspirant
Posts: 3
Registered: ‎2011-01-26

WNDR3400 Readyshare problem with WD external drive

I just connected my WD5000AAK 500GB external drive to my Netgear router, but in the router GUI, it doesn't show up. Is there a problem with this drive? It's formatted as NTFS, and the router has the most current version of the firmware.

Thanks!
Scott
Aspirant
Posts: 2
Registered: ‎2011-01-22

Re: WNDR3400 Readyshare problem with WD external drive

Yes, I have the same problem. I just upgraded to Windows 7x64 and I can not map to my external. I am able to ping successfully to the external HD and go to the HTTP link to access my files but for some reason Windows 7 doesn't recognize the Network it created for the USB device. I called NETGEAR and they claim its a Windows 7 setting issue. Does anyone know what settings I need to set inorder get this thing working?

On another note, I have an older laptop that is running XP and it mapped the external HD with no problems. So I'm leaning more to a Windows 7 compatibility issue. I also downloaded and installed the latest firmware. HELP!!!
Aspirant
Posts: 2
Registered: ‎2011-01-22

Re: WNDR3400 Readyshare problem with WD external drive

Aspirant
Posts: 3
Registered: ‎2011-01-26

Re: WNDR3400 Readyshare problem with WD external drive

Unfortunately, my problem is that the router itself can't see it. When I plug it directly into my laptop (OSX and Windows 7 Pro), it operates it fine. But when I plug it into the router, nothing.
Aspirant
Posts: 6
Registered: ‎2011-02-02

Re: WNDR3400 Readyshare problem with WD external drive

I get intermittent AAA THERE IT IS moments with both of my win 7x64 machines. It will show up in MY COMPUTER under NETWORK then I access is and upload files to it and then bang after I do that it is gone till it wants to come back.

This is the sole purpose I bought this router when looking to upgrade from a Cisco. I am a network tech and I can't figure this thing out.

If it can't get fixed I am going to sell it and get something else.
Aspirant
Posts: 248
Registered: ‎2010-07-22

Re: WNDR3400 Readyshare problem with WD external drive

Not all drives are supported. If the router cannot see the device or it doesn't work fully, that's likely because it's not supported.
http://www.TheExoticFish.com
Aspirant
Posts: 6
Registered: ‎2011-02-02

Re: WNDR3400 Readyshare problem with WD external drive

It is on the supported list.

So is the list wrong?

I also noticed that if I close the lid on my laptop it losing connection with the hard drive. If I go to the web address it is there and active but you can upload anything that way. You have to FTP it and that is a royal pain.
Aspirant
Posts: 248
Registered: ‎2010-07-22

Re: WNDR3400 Readyshare problem with WD external drive

Aspirant
Posts: 6
Registered: ‎2011-02-02

Re: WNDR3400 Readyshare problem with WD external drive

Do you have a hard time reading? Yes it is on the list. Pulled from your link. Western Digital My Book, 1000GB
Aspirant
Posts: 248
Registered: ‎2010-07-22

Re: WNDR3400 Readyshare problem with WD external drive

I can read perfectly fine thank you. Good luck as I will not continue to help you with an attitude like that.
http://www.TheExoticFish.com
Aspirant
Posts: 3
Registered: ‎2011-01-26

Re: WNDR3400 Readyshare problem with WD external drive

I guess that's why it isn't working since mine isn't in the list. I'm curious though, why would the WD MyBook 250GB and the 1000GB work and my 500GB MyBook will not?
Aspirant
Posts: 6
Registered: ‎2011-02-02

Re: WNDR3400 Readyshare problem with WD external drive

What help? All you have done is insult me. You ask a question I answer then you second guess me. I do have a CNA and a CCNA. I have tried everything I know and it doesn't work. I should have just got the wired NAS for $70 more.
Aspirant
Posts: 248
Registered: ‎2010-07-22

Re: WNDR3400 Readyshare problem with WD external drive

cpttango30 wrote:
What help? All you have done is insult me. You ask a question I answer then you second guess me.

I do have a CNA and a CCNA.

I have tried everything I know and it doesn't work. I should have just got the wired NAS for $70 more.


If you think what I said was an insult then you have bigger problems then your HD not working.
http://www.TheExoticFish.com
Aspirant
Posts: 6
Registered: ‎2011-02-02

Re: WNDR3400 Readyshare problem with WD external drive

Why would I go and buy a HDD for my wndr3400 and not make sure it worked? Then I stated it was on the list and you post up "It's on the list". No, I am just saying it is on the list to argue with you.... I came here to see if I could get some help. If you call what you do as Help you have bigger problems.
Aspirant
Posts: 248
Registered: ‎2010-07-22

Re: WNDR3400 Readyshare problem with WD external drive

You're a funny guy. Thanks, you just made my long night worth it.
http://www.TheExoticFish.com
Aspirant
Posts: 6
Registered: ‎2011-02-02

Re: WNDR3400 Readyshare problem with WD external drive

I got frustrated with the thing. I also look smoewhere else I forget what the forum was. There more then a few people said if you had Homegroup on then you wouldn't be able to see the drive on the network. So I tried that because rember setting up a homegroup (Which has yet to work on any home network I have ever set up). So I go to all my PC's remove the home group settings and reboot them. Check my network folders and still nothing. Now I am getting upset and I decide to start fresh so I reset the router to factory settings and now no matter what I do it will not even see the hdd as it did before. Oh good lord this thing is going to kill me or my wife is going to kill me because of it. I may even reset it again and start all over. Now I am off to kill squirrels eating all my bird seed.
Aspirant
Posts: 2
Registered: ‎2011-02-09

Re: WNDR3400 Readyshare problem with WD external drive

I am having difficulties to setup readyshare in my network with IMac for my external hard driver. Can anybody assist me on that? Thanks, Besim
Aspirant
Posts: 2
Registered: ‎2012-07-18

Re: WNDR3400 Readyshare problem with WD external drive

I know this forum is old, but I had the same problem and I found a solution that worked.

First of all, I am using a generic Bytec HDD enclosure. It is not on the list of "supported drives" but that does not seem to matter. What mattered was the fact that I partitioned the drive using the GUID partition scheme.

For some reason, the documentation says that GUID is supported, but the documentation appears to be wrong.

I had to reformat my drive and re-partition it with the Master Boot Record (MBR) partition scheme (which is less ideal, but I don't mind).

If you are using Mac OS X, plug your drive into the USB port and open Disk Utility. Click on the drive and click on the "Partition" tab. There you should click on "Options" and select the "Master Boot Record" partition scheme. If "Options" is grayed out, you might have to select one of the partition schemes from the menu above. This will reformat the drive and ERASE ALL OF IT'S CONTENTS, so only proceed if you have a backup or don't mind losing the data.

If you are using Windows or Linux, google "How to partition MBR" or something similar.

I hope this helps everybody who wants to use ReadyShare.

Also, if anybody finds a way to use a GUID drive, please comment here as I'd be curious how that was done.
Aspirant
Posts: 1
Registered: ‎2012-07-18

Re: WNDR3400 Readyshare problem with WD external drive

Thanks for sharing your situation and solution.
Discussion Stats
  • 18 replies
  • 7981 views
  • 0 kudos
  • 7 in conversation
Top Contributors