Posts: 0
Registered: ‎2012-02-03

can't access DLNA servers on wireless connection

I'm having a problem accessing files on a Media Server from a Playstation 3 via a wireless connection through my WNDR3700 Router. I believe it may be related to a problem with UPnP not working on the wireless link.


- My ISP is cable company, I'm using the modem they supplied.
- Ouput of the cable modem goes to the router, Netgear WNDR3700. There is no version number, so I assume it's v1. The firmware is up to date (V1.0.7.98NA)
- PC running Windows 7 is connected to the router, works just fine.
- I wirelessly connect three devices to the Netgear router: iPod Touch, laptop running Windows 7, and Playstation 3.

I seem to have a strong signal between the PS3 and the router, and speed is no issue. I can stream video from netflix just fine.


I have become interested in streaming content (mostly photos) from my PC to the PS3. It appears I should have 2 options with this setup:

- Put the files on a USB drive, and plug that into the Router, with ReadyDLNA enabled.
- Set up Windows Media Player as a DLNA server.

I can't get either one to work over the wireless connection.


When I first tried using WMP, the PC would not recognize the PS3, and the PS3 would not find the media server.

I then tried using the attached drive approach. My hardwired PC could see the ReadyServe device and also seems to recognize the media server for that drive. But the PS3 would find nothing on the network.

I then tried making a wired connection between the PC and PS3: The PS3 did see and recognize Media Servers on the PC (though there were registration or configuration errors that I never worked out.) And my PC did see "other devices" via WMP, which I verfied was the PS3 by checking the Mac Address. I didn't try using the ReadyDLNA with a hard wired connection, but I suspect it also would have worked.

Then I went back to trying to use the wireless connnection with WMP. Having been found once, the PC sees the PS3 (at least it shows "other devices" properly). But the PS3 still won't find or connect to any media servers.

Probably not coincidentally, if I try to connect to my HomeGroup network from my laptop, it works perfectly over a hard wired connection, but can't find the HomeGroup when connected wirelessly.

I have one clue as to what the problem might be:

- When I create the wireless connection to the PS3, the PS3 configuration software pauses for a very long time (45-60 seconds?) at UPnP, then comes back with 'not available'.
- When I create a wired connection, setup comes back very quickly at UPnP, and says 'enabled' (or something like that).

My understanding is that DLNA requires use of UPnP to configure the device. It appears that UPnP only works across the wired connection, but not the wireless, so that I can only see DLNA devices with the wired connecion.

Are there router settings that I can use to eliminate this issue (assuming that really is the problem)?
Posts: 0
Registered: ‎2012-02-13

Re: can't access DLNA servers on wireless connection

Apparently you have your wireless connection defined as an isolated or friend network, in this mode you can't access computers on other network, such as your wired connections
Discussion Stats
  • 1 reply
  • 0 kudos
  • 2 in conversation
Top Contributors