Re: After update won’t let me log in


Re: After update won’t let me log in

Lets be clear
Its the genie app update .72 that is the problem
PC genie works
Router firmware is up to date
And have reinstalled app several times
Rebooted several times
Netgear needs to fix app
Don’t post Michael if you cant help
Message 26 of 35

Re: After update won’t let me log in

That’s what I think , we all noticed so far!!
Michael if you are a superuser try to hear us instead of pointing fingers at us read the previous 26 posts , we are all complaining about the same issue “app got updated then app stop working’ seems like there is leak of training at Netgear’s end , someone above you should be reading your negative posts and teach you some sort of manners or how to communicate to customers who is using netgear product

It was said to you before many time
If you can’t help the please take a corner
And let the expert deal with our problem

Not trying to be rude or anything and sorry if I’m but you are very negative and very good in pointing fingers back at us , yes Netgear have a problem with the app and this is the fact so deal with it .
Message 27 of 35

Re: After update won’t let me log in

@PH69 wrote:
All messages on this feed are complaining of same problem- ie the latest genie app update does not work-

That is not obvious. The message I replied to said:


"After iphone update..."


It did not say "after Netgear Genie update". That would have been better, More detail always helps.


It may be news to you, but there are just too many variables in these things to be able say what has gone wrong from a simple statement like that.


Look at the subject of this discussion. What does it say to you? How much help does it offer to someone at tech support? The first message didn't even mention iPhone, no longer even the most widely used mobile devices.


Before anyone can diagnose problems or pass them on to anyone else, we have to pin down the issues.


You would surprised by the number of people who join on the end of a long discussion saying "me too" only to reveal on later analysis that they have caught something completely different.



Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 28 of 35

Re: After update won’t let me log in

Has anyone here tried this?


Solved: Re: Cannot login to orbi iPhone app - NETGEAR Communities



Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 29 of 35

Re: After update won’t let me log in

Sounds like you are NOT one of the Techs
So I’m surprised why you even answering us and why you “still” pointing fingers at us instead of acknowledging that yes something is going on with the app after being updated,

One of the Techs Gigi replied me in private and acknowledged that there is an (issue with the app AFTER UPDATING IT) and the Techs is working on a solution.

Michael thanks for your help and support but try to be a little more professional with you communication skills.

Hold on tight all hopefully a quick bug hot fix will follow soon
Message 30 of 35

Re: After update won’t let me log in

Dear Michael
A bit tired of the patronising excuses
If you had bothered to notice this entire feed is referring to the iohone genie app ( see messages 2& 7) hence subsequent have agreed and added rather than repeat whole story for your benefit .
A bit if common sense & basic customer service would suffice- especially when netfear insiders know there is a problem with the app - how dare you suggest its a user problem and keep suggesting things we’ve already tried
Get dexter on this pls
Message 31 of 35

Re: After update won’t let me log in

Use browser goto login to unblock the device
Message 32 of 35

Re: After update won’t let me log in

Im assuming this is not a fix for the genie app login?
I can't login from android or iPad latest genie app, is there any way to troubleshoot? Login from desktop browser and app work.
Message 33 of 35

Re: After update won’t let me log in

After months of trying to sort this out ive been dumped by customer support.

Aparently engeering considers it a customers problem if their app doesnt work with the firmware installed...

Didnt they ever hear of backwards compatability?

Since when whas it everybodys problem but theirs???

So much for customer experience.

Suggest you sack the engineering deparment and start again



2019-04-08 10:30:43
Hi Paul, I just got an update from the Engineering Department regarding the case that we escalated to them. They said, that we do not have control with the Firmware of the device provided by the ISP. We cannot modify it to work with the updated version of the App. It could be a limitation of the device or we may have to wait for ISP's update of the Firmware. Sincerely, Bella Netgear Support


2019-04-10 04:09:45
Hi Paul, I emailed you regarding the result of the Engineers after receiving the data we sent to them. They said that this is a limitation of the firmware of the device that it will not synchronized with the NH App. We need to wait for a firmware update that will be pushed by the ISP on their modem. We will be closing this case, because this is not an issue with the Nighthawk App but with the firmware of the modem provided by the Internet provider. Visit our website Sincerely, Bella Netgear Suppport
Model: C6300BD-1TLAUS|DOCSIS 3.0 Cable Gateway Wi-Fi AC
Message 34 of 35

Re: After update won’t let me log in

Not sure how this follows on from the earlier conversation, but if your device is the C6300BD, you are stuck between Netgear and the Internet service provider.


ISPs do not allow modem makers to control firmware. Quite why they do this is anyone's guess. Maybe they just want to rent you a  modem and take more of your money.


Here's the official line:


What’s the latest firmware version of my NETGEAR cable modem or modem router? | Answer | NETGEAR Sup...



If your firmware is outdated, you cannot manually upgrade your cable modem’s or modem router’s firmware. You must contact your Internet service provider (ISP) to upgrade your firmware.


But it isn't just a Netgear thing. Here are two other brands and their take:


How do I update the modem firmware? – Motorola Mentor


Drivers and Firmware: Upgrading Firmware on Cable Modems & Gateways


The only options seem to be to stick with the current firmware, shout at the ISP to get it to roll out new firmware or rent a modem from them. Or stick with the app version that used to work.


Your experience illustrates the value of adopting a strategy that I went for when my modem/router caused grief. I bought a separate modem that sits in front of a router. The things that you want to control are mostly on the router. The modem just sits there with its Internet connection.






Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 35 of 35
Top Contributors
Discussion stats