Orbi WiFi 7 RBE973
Reply

FVS318N Worth Upgrade to 4.3.3-6?

therealdgh
Aspirant

FVS318N Worth Upgrade to 4.3.3-6?

Hello,

 

I have an FVS318N firewall currently running firmware 4.3.1-22, sitting behind a DSL modem running in bridge mode and for the most part everything is running well.

 

The thing I am wondering is if it is worth it to upgrade to the 4.3.3-6 firmware for any of the updated security features.  The reason I have this conundrum is I noticed in the release notes for 4.3.3-6 that it has a known issue passing SIP REGISTER messages through NAT.  I also noticed this occurred in firmware version 4.3.2-7 and has not been addressed yet.  I have a VoIP phone behind the FVS318N and currently don't have any issues other than an occaisional clipping of the inbound voice path.  However, this is due to my ISP as we are on old copper lines with known problems.  Other than that, though, the phone works well for calls.

 

My concern is that if I upgrade to 4.3.3-6 or any other firmware from 4.3.2-7 on up that my VoIP service will suffer.  Is anyone running a VoIP phone on an FVS318N running firmware 4.3.3-6 and not having issues with the REGISTER messages getting corrupted?

 

Model: FVS318N|ProSafe Wireless N 8 port gigabit VPN firewall
Message 1 of 4
DaneA
NETGEAR Employee Retired

Re: FVS318N Worth Upgrade to 4.3.3-6?

Hi therealdgh,

 

Welcome to the community! 🙂

 

As far as I know, there has been no reported issues about "Register messages getting corrupted" using firmware v4.3.3-6.  However for me, I would rather stick with the current firmware since everything is working fine.  I suggest that you keep a backup of your current configuration file of your FVS318N.  

 

 

Regards,

 

DaneA

NETGEAR Community Team

 

Message 2 of 4
therealdgh
Aspirant

Re: FVS318N Worth Upgrade to 4.3.3-6?

DaneA,

 

Thanks for your response.

 

I assumed that since Netgear listed "No NAT translation of SIP headers during REGISTER, outbound call and SDP" in the known issues section of firmware release notes that anyone running an FVS318N with firmware from 4.3.2-7 on up that also was running VoIP phones would have encountered the issue.  One thing I am wondering is if this particular issue only applies if SIP ALG is enabled.  If so, then I won't have to worry about it as I have SIP ALG disabled.

 

Is there any repository or site where we can look up or follow the track of known issues?

 

My only reason for wanting to upgrade the firmware is to stay current on the security vulnerability fixes.

Message 3 of 4
DaneA
NETGEAR Employee Retired

Re: FVS318N Worth Upgrade to 4.3.3-6?

Hi therealdgh,

 

It is alright if you want to update the firmware of your FVS318N to the latest v4.3.3-6.  Monitor the performance of your FVS318N after updating the firmware.  Be reminded to perform a factory reset on the FVS318N after a successful firmware upgrade then reconfigure it from scratch. 

 

I'm afraid that there is no repository or site to track down known issues.  However, you may open an online case with NETGEAR Support at anytime if you need technical assistance or if you have encounter something that you think its an issue with the FVS318N.  

 

 

Regards,

 

DaneA

NETGEAR Community Team

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 3838 views
  • 0 kudos
  • 2 in conversation
Announcements