Reply
Occasional Contributor
Posts: 5
Registered: ‎2010-02-03

Torrents Downloading but NOT Uploading...

Hello,

I have a big problem with getting my NAS to work properly when it comes to torrents. When I use BitTorrent or Transmission I have no problems with downloading the torrents, but when it comes to uploading, nothing happens.

My download is usually maxed at 2,5mb/s, but uploading always stays at 0kb/s (sometimes it may go to like 5kb/s for a few seconds then back to 0 again)....What is the problem?

I am currently using a Cisco EPC2425 router which is connected to my Readynas Duo...

If additional info is required to solve it, please tell me....


Thanks!

/Lennart_Myra
Contributor
Posts: 41
Registered: ‎2010-01-22

Re: Torrents Downloading but NOT Uploading...

Have you forwarded the necessary port to your NAS on your router?
Occasional Contributor
Posts: 5
Registered: ‎2010-02-03

Re: Torrents Downloading but NOT Uploading...

I am not sure I got that part 100% right...

It looks like this when I configure the router:

Setup
Advanced Settings - Port Forwarding
This page allows you to configure port forwarding for local IP addresses.

Local IP Adr - Start Port - End Port - Protocol - Enable

X - X - X - X - X

What exactly should I put in these cells?

(In my torrent client it says: network: incoming tcp port: 51413)

Thanks again!
Contributor
Posts: 41
Registered: ‎2010-01-22

Re: Torrents Downloading but NOT Uploading...

Lennart_Myra wrote:
I am not sure I got that part 100% right...
Local IP Adr - Start Port - End Port - Protocol - Enable

X - X - X - X - X


Local IP Adr: Your NAS' IP address.
Start port: 6881 (if you're using the built-in bittorrent client) or 51413 (if you're using the Transmission add-on)
End port: Same as above.
Protocol: TCP/UDP (or if you have to choose one of the two, choose TCP)
Enable: checked

Hope this helps.
Occasional Contributor
Posts: 5
Registered: ‎2010-02-03

Re: Torrents Downloading but NOT Uploading...

Thank you for the quick answer! I have now tried it, but still nothing happens with my upload Smiley Sad

Any other ideas?
Contributor
Posts: 41
Registered: ‎2010-01-22

Re: Torrents Downloading but NOT Uploading...

What IP did you set for your nas. It should be the internal IP (probably starting with 192.168 or 10.0).

What port did you set, and what bittorrent client are you using?
Contributor
Posts: 41
Registered: ‎2010-01-22

Re: Torrents Downloading but NOT Uploading...

Oh... by the way, it should be noted that the bittorrent client on the NAS is not set to seed any of the files it downloads. It will only upload while you are downloading.
Occasional Contributor
Posts: 5
Registered: ‎2010-02-03

Re: Torrents Downloading but NOT Uploading...

My NAS received the ip 192.168.0.11 and I am using Transmission 1.83...it says something about tcp port 51413 in the preferences...

I tried forwarding that port and ip numbers, but still nothing is uploading...only downloading...
Contributor
Posts: 41
Registered: ‎2010-01-22

Re: Torrents Downloading but NOT Uploading...

Is it a problem if nothing is uploading? eg. Are you not getting fast downloads because of it?

If you've done the forwarding correctly, there shouldn't be anything else getting in the way. I would suggest trying out the 1.90 beta that you can find here (if you are using a Duo or NV+):

http://www.readynas.com/contributed/sup ... 1Light.bin
Moderator
Posts: 5,316
Registered: ‎2009-09-02

Re: Torrents Downloading but NOT Uploading...

there's no upload if there's no leecher asking for the file

1.90 will give you a tab to see tracker status and if there's leechers
If you like my add-ons - Si vous aimez mes add-ons :
EN/US: --- -------- FR: or Paypal @mail: readynas@orange.fr
Where I'm teaching
4B Perros
Discussion Stats
  • 18 replies
  • 26 views
  • 0 kudos
  • 10 in conversation
Top Contributors
User Kudos Count
1