× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
Orbi WiFi 7 RBE973
Reply

Re: After Upgrade of M4300-8x8f fans stop Working

LaurentMa
NETGEAR Expert

Re: After Upgrade of M4300-8x8f fans stop Working

Hi @jmsoren5 

 

Thank you for your message. Please find the solution here: https://community.netgear.com/t5/Managed-Switches/Feature-request-M4300-8X8F-Allow-force-fans-on-qui...

 

With latest M4300 firmware on the M4300-8X8F (XSM4316S), a new command is present for forcing fan operation, or requesting quiet (fanless) operation when ambient temperature can sustain it.

 

To enable fans for perpetual fan operation:

User:admin
Password:************
(M4300-8X8F) >en

(M4300-8X8F) #config

(M4300-8X8F) (Config)#no environment set fan quiet

(M4300-8X8F) (Config)#exit

(M4300-8X8F) #save

This operation may take a few minutes.
Management interfaces will not be available during this time.
Are you sure you want to save? (y/n) y

Config file 'startup-config' created successfully .


Configuration Saved!

(M4300-8X8F) #

 

To disable fans for fanless operation when ambient temperature is under 25C:

User:admin
Password:************
(M4300-8X8F) >en

(M4300-8X8F) #config

(M4300-8X8F) (Config)#environment set fan quiet

(M4300-8X8F) (Config)#exit

(M4300-8X8F) #save

This operation may take a few minutes.
Management interfaces will not be available during this time.
Are you sure you want to save? (y/n) y

Config file 'startup-config' created successfully .


Configuration Saved!

(M4300-8X8F) #

 

Please let us know how it goes, many thanks!

Regards,

Message 26 of 31
kgpns
Aspirant

Re: After Upgrade of M4300-8x8f fans stop Working

I am interested to see if this worked. I have been waiting for this feature update.

 

@jmsoren5

Did changing the config to "perpetual fan" work for you to allow the fans to run?

 

@LaurentMa 

Is there also a way to do this from the Web Interface?

 

 

 

 

 

Message 27 of 31
LaurentMa
NETGEAR Expert

Re: After Upgrade of M4300-8x8f fans stop Working

Hi @kgpns
I trust this works well, we QA'ed this a lot and I tested it personally too. It is only configurable through the command line, either local console or distant telnet/SSH.

I hope this helps,
Message 28 of 31
jmsoren5
Aspirant

Re: After Upgrade of M4300-8x8f fans stop Working

Just ran the commands.  Both Fan-1 and Fan-2 started immediately; the LED on the front of the switch went Green, and the Web GUI shows both fan status as OK.

 

Thank you very much.  I understand the need for the feature given that this is a small, sometimes desktop, switch.  But mine is in a noisy, very warm, computer room, so I want and need those fans to run!

Message 29 of 31
LaurentMa
NETGEAR Expert

Re: After Upgrade of M4300-8x8f fans stop Working

I'm glad, thank you for confirming! Please don't forget to save your configuration now, so that running-config is saved as new startup-config. This way, this command will be perpetual in your computer room!

Regards,
Message 30 of 31
kgpns
Aspirant

Re: After Upgrade of M4300-8x8f fans stop Working


@ jmsoren5 Thank you!
Message 31 of 31
Top Contributors
Discussion stats
  • 30 replies
  • 8736 views
  • 5 kudos
  • 9 in conversation
Announcements