× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
Orbi WiFi 7 RBE973
Reply

GSM7328FS 7.3.1.7 losing L3 vlan interfaces?

apack
Aspirant

GSM7328FS 7.3.1.7 losing L3 vlan interfaces?

Hello all, and thank you all for the help you've provided me in the past just by searching / reading your posts, especially advantagecom.
I have a star topology with a GSM7328FS at the core feeding 20 FSM7352S stacks, all running 7.3.1.7. Until recently, we had one L2 subnet, no vlans, and were using a PIX515e as our router. We have since set up 3 vlans with L3 routing interfaces on the core switch and had that switch take over as the router, then routing to the PIX. Prior to the vlans, we had no issues ever, save for the occasional line card or power supply failure. Since adding the vlans, we have been down at least once a week with symptoms including L3 interface high ping times or complete unavailability. At that point, all the L2 stuff seems okay, everything still talks to everything else, with normal ping times, but no routing is happening at all, so no internet, no vpn tunnels etc...
I have checked and verified no error packets, 590 out of 1664 MAC addys known, L3 interfaces do show as present on the switch even when routing has stopped.
What I would like to know is:
Is anyone seeing this behaviour on 7.3.1.7?
Is there something I should check that might affect only the L3 interfaces?
If anyone has experienced something similar, did installation of an 8 series firmware help or hurt the issue?

Thanks for your time.


Aaron
Message 1 of 6
mypub
Novice

Re: GSM7328FS 7.3.1.7 losing L3 vlan interfaces?

What do you show in your logs around the time of the failure?
Message 2 of 6
apack
Aspirant

Re: GSM7328FS 7.3.1.7 losing L3 vlan interfaces?

I'm sorry I haven't been back in a bit...
The switch has been stable for the last 10 days or so.
As such, I have not yet had a chance to upload logs while the L3 interfaces were unavailable.
I will reply if / when this occurs again with the output of the tech support logs.
If I should upload a different log / output, please let me know.


Thank you.
Message 3 of 6
stevenb
Aspirant

Re: GSM7328FS 7.3.1.7 losing L3 vlan interfaces?

So far I have been running fw 8.0.3.15 on that switch with no loss of vlan routing so far.... might be worth upgrading to this level of firmware. I do recall a bug in v7 with what you describe.
Message 4 of 6
apack
Aspirant

Re: GSM7328FS 7.3.1.7 losing L3 vlan interfaces?

Here's my config. I just set 5 additional ports to tagging for vlan 10 last night, and it has been up and down all day. Please let me know if anyone sees anything questionable with the config.
Thank you.


set prompt "GSM7328FS"
network protocol none
vlan database
vlan 10
vlan 252
vlan name 252 elan
vlan 253
vlan name 253 tlan
vlan routing 252
vlan routing 10
vlan routing 253
exit

configure
sntp client mode unicast
! sntp server status is active
sntp server time-d.netgear.com
stack
exit

logging buffered
slot 1/0 5
set slot power 1/0
no set slot disable 1/0
ip routing
ip route 0.0.0.0 0.0.0.0 192.10.20.21
ip route 192.168.247.0 255.255.255.0 192.10.80.63
arp cachesize 1664
lineconfig
exit

spanning-tree configuration name 00-1F-33-FD-85-71
port-channel NC_to_Core
interface 1/0/19
addport 0/1/1
exit

interface 1/0/20
addport 0/1/1
exit

snmp-server sysname "SFP_Switch1"
snmp-server location "Phone Room"
snmp-server contact "xxxxxx"
router ospf
router-id 192.168.252.254
exit

router rip
exit

classofservice dot1p-mapping 6 3
classofservice dot1p-mapping 7 3
no classofservice trust
classofservice ip-dscp-mapping 48 3
classofservice ip-dscp-mapping 49 3
classofservice ip-dscp-mapping 50 3
classofservice ip-dscp-mapping 51 3
classofservice ip-dscp-mapping 52 3
classofservice ip-dscp-mapping 53 3
classofservice ip-dscp-mapping 54 3
classofservice ip-dscp-mapping 55 3
classofservice ip-dscp-mapping 56 3
classofservice ip-dscp-mapping 57 3
classofservice ip-dscp-mapping 58 3
classofservice ip-dscp-mapping 59 3
classofservice ip-dscp-mapping 60 3
classofservice ip-dscp-mapping 61 3
classofservice ip-dscp-mapping 62 3
classofservice ip-dscp-mapping 63 3
classofservice ip-precedence-mapping 6 3
classofservice ip-precedence-mapping 7 3
ip name-server 192.10.10.5 192.10.10.110
interface 1/0/1
description 'xxxxxx'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
vlan tagging 10
vlan participation include 252
vlan tagging 252
vlan participation include 253
vlan tagging 253
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/2
description 'xxxxxx'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
vlan tagging 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/3
description 'xxxxxx'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/4
description 'xxxxxx'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
vlan tagging 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/5
description 'Network Closet Access Stack'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
vlan tagging 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/6
description 'xxxxxx'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/7
description 'xxxxxx'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
vlan tagging 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/8
description 'xxxxxx'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
vlan tagging 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/9
description 'xxxxxx'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
vlan tagging 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/10
description 'xxxxxx'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/11
description 'xxxxxx'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
vlan tagging 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/12
description 'xxxxxx'
vlan pvid 253
vlan participation exclude 1
vlan participation include 253
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/13
description 'xxxxxx'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
vlan tagging 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/14
description 'xxxxxx'
vlan pvid 253
vlan participation exclude 1
vlan participation include 253
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/15
description 'xxxxxx'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
vlan tagging 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/16
description 'xxxxxx'
vlan pvid 253
vlan participation exclude 1
vlan participation include 253
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/17
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/18
description 'xxxxxx'
vlan pvid 253
vlan participation exclude 1
vlan participation include 253
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/19
description 'LAG1'
vlan pvid 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/20
description 'LAG2'
vlan pvid 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/21
description 'Nortel elan vlan252'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
vlan tagging 10
vlan participation include 252
vlan tagging 252
vlan participation include 253
vlan tagging 253
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/22
description 'Phone Room 48port switch'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
vlan tagging 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/23
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/24
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/25
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/26
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
no lldp transmit
no lldp receive
no lldp med

exit

interface 1/0/27
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
no lldp transmit
no lldp receive
no lldp med
exit

interface 1/0/28
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
no lldp transmit
no lldp receive

no lldp med
exit

interface lag 1
description 'NC Distribution 2Gb to Core SFP'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
vlan tagging 10
exit

interface vlan 252
routing
ip address 192.168.252.254 255.255.255.0
ip ospf
ip rip
exit

interface vlan 10
routing
ip address 192.10.20.20 255.255.0.0
exit

interface vlan 253
routing
ip address 192.168.253.254 255.255.255.0
ip ospf
ip rip
exit

exit
Message 5 of 6
apack
Aspirant

Re: GSM7328FS 7.3.1.7 losing L3 vlan interfaces?

Since yesterday I have installed our backup GSM7328FS with FW 8.0.3.25 and connected it to the existing (FW 7.3.1.7) GSM7328FS on port 24 on both switches.
The new switch was factory defaulted, brought up and configured from console. I changed the l3 vlan 10 IP address on the old switch, and set the new switch to that same gateway IP. It is doing better, but still has issues.
All this switch is doing is providing the l3 gateway address for vlan 10, which about 400 machines use. I am showing about 3mb/s down and 1mb/s up on the internet router upstream from this switch. My pings (from a machine plugged in port 23 of the new GSM7328FS) to the l3 interface are inconsistent, ranging from 1ms to 100's and dropouts. The ping from the same machine through to www.yahoo.com range from 8ms to 30's and 40's but do not drop out.
show process CPU has indicated an average CPU utilization of 14% over 5 minutes on the switch.
This switch is factory default plus vlan 10 l2 and l3 setup with two ports (1/0/23, 1/0/24) setup for untagged vlan 10 pvid 10 and one port (1/0/21) setup for port mirroring 1/0/24 (uplink to old switch).
If someone has some ideas or questions about the config, please let me know.
The old core switch has hardly stable on l3, but had been relatively trouble free for almost two months. Wednesday night we started changing downstream switches from untagged vlan 10 uplinks to the core to tagged, and that is when this all started. I could go back and untag all those downstream switches, but we really need this config to work to be able to properly trunk wireless to our APs.
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 10579 views
  • 0 kudos
  • 3 in conversation
Announcements