Antworten
Highlighted
Aspirant

Gs108Ev3 macht kein IGMP Snooping

Hallo,

ich habe eigentlich eine sehr übersichtliche Konfiguration:

Telekom Speedport -> Gs108Ev3 und von dort einmal zum PC und einmal zu einem MediaReceiver 401.

Im Gs108Ev3 ist IGMP Snooping aktiviert, das war es bereits in der Standardeinstellung, ich habe also nicht geändert.

Wenn ich jetzt im Mediareceiver einen Stream laufen lasse, kommen alle Daten mit der vollen Datenrate auch am PC an.

Ich hab mir das mit Wireshark mal angesehen: der Mediareceiver sendet wie zu erwarten ein "include", und der PC sendet ein "exclude".

Nur scheint das den Gs108Ev3 nicht weiter zu interessieren. Wieso funktioniert IGMP Snooping beim Gs108Ev3 nicht ?

Im Anhang das Protokoll:

192.168.0.20 ist der Speedport mit der IGMP Anfrage

192.168.0.104 ist der Mediareceiver

und

192.168.0.16 ist mein PC, der ein "exclude" sendet aber trotzdem den vollen Stream geliefert bekommt.

 

viele Grüße
Harry

 

 

Model: GS108Ev3|ProSafe 8 ports Gigabit Plus switch
Nachricht 1 von 5
Highlighted
NETGEAR Moderator

Re: Gs108Ev3 macht kein IGMP Snooping

Hallo @harry4516,

 

willkommen in der NETGEAR Community!

 

Könntest Du mir zuerst mitteilen, was passiert, wenn Du die Option "IGMP Snooping-Status" deaktivierst? 

Schicke mir bitte einen Screenshot von der Seite System --> Multicast --> IGMP Snooping.

 

Wird der Streaming bei Dir irgendwie abgebrochen? 

Welche Dienste (beispielsweise) benutzt Du über den MediaReceiver? 

 

Freundliche Grüße
DamianM
NETGEAR Team 

Nachricht 2 von 5
Highlighted
Aspirant

Re: Gs108Ev3 macht kein IGMP Snooping

Hallo, vielen Dank für die schnelle Antwort.

Im Angang der gewünschte Screenshot.

Dienste: Magenta TV der Telekom

IPTV Streaming: läuft flüssig und einwandfrei

IGMP Snooping: das ist das Problem, alle Ports werden geflutet.

 

Was ich bisher versucht habe um IGMP Snooping zum laufen zu kriegen:

1) Werkseinstellung (IGMP Snooping aktiv, keine vlans)

2) IGMP Snooping deaktiviert: gleiche Funktion wie aktiviert, kein Unterschied

3) nach Infos aus diesem Forum VLAN eingestellt, in verschiedenen Konfigurationen.

Wobei diese Forum-Infos veraltet sind, hier wird von vlan 7 und 8 gesprochen, was die Telekom so aber nicht mehr macht. Aber generell sollte vlan nicht benötigt werden, es sein denn, der Netgear braucht das aus irgendeinem Grund.

Ich kann machen was ich will, sobald ich einen IPTV Stream starte, werden sämtliche Ports geflutet.

Heute habe ich einen weiteren Test gemacht und mit einen D-Link GS108E besorgt, der fast genauso aussieht wie der Netgear GS108Ev3. Und siehe da, einfach angeschlossen, ohne jede Konfiguration, und IGMP Snooping lief sofort. Nur die am IPTV beteiligen Ports hatten die IPTV Daten.

Leider ist der D-Link keine Lösung für mich, da ich unser ganzes Haus mit vielen Netgear GS108Ev3, und gleichartigen 5 und 16 port Netgears ausgestattet habe. Daher bin ich darauf angewiesen dass der GS108Ev3 das tut was versprochen ist, und zwar IGMP Snooping zu machen.

Ich bin für jede Hilfe dankbar.

Harry

 

 

Nachricht 3 von 5
Highlighted
NETGEAR Moderator

Re: Gs108Ev3 macht kein IGMP Snooping

Hallo @harry4516,

 

die IP-Adresse 224.0.0.22 (Whireshark) ist eine Multicasting-Adresse, also eine Adresse von dem Dienst IGMPv3. Das bedeutet, dass das IGMP aktiv ist und funktioniert.

Wenn Du das IGMPv3 auf dem Switch deaktivierst, soll die Adresse 224.0.0.22 aus dem Whireshark verschwinden. 

 

Wie hast Du festgestellt, dass auch die "neutralen" Clients die Pakete erhalten? 

 

Freundliche Grüße
DamianM
NETGEAR Team 

Nachricht 4 von 5
Highlighted
Aspirant

Re: Gs108Ev3 macht kein IGMP Snooping

Dass die neutralen Clients die Daten bekommen sehe ich einmal an den Router LEDs, die super schnell blinken wenn ein IPTV Stream drüber lauft. Und zusätzlich kann ich das an der Netzwerklast im PC sehen, die auf knapp 10Mbit/s hochgeht wenn ich fernsehe, und schließlich natürlich mit Wireshark.

Hab noch einen Test gemacht:

erstmal den D-Link Switch angeschlossen. Mediareceiver läuft. Mediareceiver bekommt den Stream, der PC nicht. Starte ich am PC mit VLC den Stream ebenfalls, so bucht sich der PC im Switch ein und bekommt den Stream auch. Schließe ich VLC so stoppt der Stream zum PC wieder. So wie es zu erwarten ist.

Genau das gleiche mit dem Netgear: der PC bekommt den Stream immer, ob er ihn braucht oder nicht. Das ganze ist so offensichtlich und einfach, da braucht sich bei euch nur mal ein Techniker das anschließen und nachgucken. Kann natürlich sein dass das Problem nur mit Magenta TV auftritt und mit anderen Streams nicht, weiß ich nicht. Aber bei den vielen Millionen Magenta TV Anwendern sollte das für Netgear durchaus von Interesse sein das zum laufen zu kriegen, oder?

viele Grüße
Harry

 

Nachricht 5 von 5
Autoren, für die die meisten Kudos vergeben wurden
Diskussionsstatistiken
  • 4 Antworten
  • 191 Aufrufe
  • 0 Kudos
  • 2 in Unterhaltung