Reply

Re: M4300 trying to reset ip http port number to default port 80

CrustySparks
Tutor

M4300 trying to rest ip http port number to default port 80

 

Trying to reset the http port back to default 80 from 6535:

my startup-config ... partial ...

exit
ip http port 6535 <---
ip http secure-server
ip http secure-protocol TLS1
ip ssh server enable

 

CLI manual says:

no ip http port

 

Switch says:

(M4300-12X12F) (Config)#no ip http ?

                                                         accounting Configure an Accounting List.
                                                         authentication Configure an Authentication List.

 

(M4300-12X12F) #show version

Switch: 1

System Description............................. M4300-12X12F ProSAFE 12-port 10GBASE-T and 12-port 10G SFP+, 12.0.2.20, 1.0.0.9
Machine Model.................................. M4300-12X12F
Serial Number.................................. 4G43697E80107
Burned In MAC Address.......................... 10:DA:43:F9:47:91
Software Version............................... 12.0.2.20
CPLD version................................... 0x5
Bootcode Version............................... 1.0.0.9
Current Time................................... Jan 16 09:53:40 2018 (UTC-8:00)
Current SNTP Sync Status....................... Success

 

(M4300-12X12F) (Config)#show ip http

HTTP Mode (Unsecure)........................... Enabled
HTTP Port...................................... 6535
Maximum Allowable HTTP Sessions................ 16
HTTP Session Hard Timeout...................... 24 hours
HTTP Session Soft Timeout...................... 15 minutes

HTTP Mode (Secure)............................. Enabled
Secure Port.................................... 443
Secure Protocol Level(s)....................... TLS1 -----
Maximum Allowable HTTPS Sessions............... 16
HTTPS session hard timeout..................... 24 hours
HTTPS session soft timeout..................... 15 minutes
Certificate Present............................ True
Certificate Generation In Progress............. False

(M4300-12X12F) (Config)#

 

(M4300-12X12F) (Config)#show captive-portal

Administrative Mode............................ Disable
Operational Status............................. Disabled
Disable Reason................................. Administrator Disabled
CP IP Address.................................. 0.0.0.0

(M4300-12X12F) (Config)#

Message 1 of 9

Accepted Solutions
Hopchen
Prodigy

Re: M4300 trying to reset ip http port number to default port 80

Hi @CrustySparks,

 

The issue is that you are doing this from the global config mode. You need to do it from EXEC mode, not config mode 🙂

 

As this:

(M4300) >enable
(M4300) #ip http server
(M4300) #ip http port 80

 

 

Cheers

Former NETGEAR Employee.
Views and opinions are my own.

View solution in original post

Message 6 of 9

All Replies
schumaku
Guru

Re: M4300 trying to rest ip http port number to default port 80

Dunno why the documented "no ip http port" does not work, no switch at hand, try this:

 

no ip http server

ip http server

ip http port 80

 

Message 2 of 9
CrustySparks
Tutor

Re: M4300 trying to rest ip http port number to default port 80

(M4300-12X12F) (Config)#no ip http server
                                   ^
% Invalid input detected at '^' marker.

(M4300-12X12F) (Config)#

Message 3 of 9
schumaku
Guru

Re: M4300 trying to rest ip http port number to default port 80

...continue with the other commands, regardless...

Message 4 of 9
CrustySparks
Tutor

Re: M4300 trying to reset ip http port number to default port 80

&

(M4300-12X12F) #config

(M4300-12X12F) (Config)#no ip http server
                                   ^
% Invalid input detected at '^' marker.

(M4300-12X12F) (Config)#ip http server
                                ^
% Invalid input detected at '^' marker.

(M4300-12X12F) (Config)#ip http port 80
                                ^
% Invalid input detected at '^' marker.

(M4300-12X12F) (Config)#show ip http

HTTP Mode (Unsecure)........................... Enabled
HTTP Port...................................... 6535
Maximum Allowable HTTP Sessions................ 16
HTTP Session Hard Timeout...................... 24 hours
HTTP Session Soft Timeout...................... 15 minutes

HTTP Mode (Secure)............................. Enabled
Secure Port.................................... 443
Secure Protocol Level(s)....................... TLS1 -----
Maximum Allowable HTTPS Sessions............... 16
HTTPS session hard timeout..................... 24 hours
HTTPS session soft timeout..................... 15 minutes
Certificate Present............................ True
Certificate Generation In Progress............. False

(M4300-12X12F) (Config)#

 

I'm guessing that I'll have to modify the startup config and edit out the offending line and restart the switch because it seems to be innacessible from the command line.  If you look at the top part of the startup you see that it comes before the configure command:

 

serviceport protocol none
serviceport ip 10.10.10.1 255.255.255.0 0.0.0.0
no serviceport ipv6 enable
vlan database
vlan 2-6
vlan name 2 "admin"
vlan name 3 "WiFi"
vlan name 4 "stdnt"
vlan name 5 "mgnt"
vlan name 6 "voip"
no vlan routing 1
vlan routing 4 1
vlan routing 3 2
vlan routing 5 3
vlan routing 2 4
vlan routing 6 5
exit
ip http port 6535
ip http secure-server
ip http secure-protocol TLS1
ip ssh server enable
configure
sntp server "172.16.0.2"
clock timezone -8 minutes 0
stack
member 1 5
exit

& etc ....

 

That option used to be available on the System Management Tab in the config pages.

Message 5 of 9
Hopchen
Prodigy

Re: M4300 trying to reset ip http port number to default port 80

Hi @CrustySparks,

 

The issue is that you are doing this from the global config mode. You need to do it from EXEC mode, not config mode 🙂

 

As this:

(M4300) >enable
(M4300) #ip http server
(M4300) #ip http port 80

 

 

Cheers

Former NETGEAR Employee.
Views and opinions are my own.
Message 6 of 9
CrustySparks
Tutor

Re: M4300 trying to reset ip http port number to default port 80

Ahem ... Smiley Embarassed ... thank you.  That was it ... I think too much of a Cisco hangover ... Smiley Surprised

Message 7 of 9
schumaku
Guru

Re: M4300 trying to reset ip http port number to default port 80

Based on the # prompt I've assumed you are in config mode. Silly me 8-)
Message 8 of 9
CrustySparks
Tutor

Re: M4300 trying to reset ip http port number to default port 80

Been there ... done that ... Smiley Frustrated

Message 9 of 9
Top Contributors
Discussion stats
  • 8 replies
  • 2593 views
  • 2 kudos
  • 3 in conversation
Announcements