Reply

Re: Problems with LAG von M4300-8x8F switches

ptoschi
Luminary

Problems with LAG von M4300-8x8F switches

Hello,

we have 4 M4300-8x8 Switches in two server rooms. In both rooms there are 2 Switches stacked together. These two stacks are connected by LAG (one cable per switch). Originally the LAG consisted of two SFP+ and it worked fine. Now we had to plug out the fibre cables so I included two copper ports in the LAG (again one per switch), plugged in two copper cables and removed the fibre cables. When I added the fibre cables again, I got all sorts of connection problems. Some servers could not reach other servers, but others worked. After a while I decided to plug out the fibre cables again, but the problems persisted, until I plugged out one of the copper cables. At the moment it works, but only with one active link in the lag. Since the servers are all productive I cannot just shut everything down. Are there some settings I should set in the LAG? I have left everything on default, admin mode enabled, and Link, STP, static disabled. I also had an expert test the fibre cables - the cables themselves should be ok.

My goal would be to have a working lag with two fibre cables. The copper cables are only for emergencies.

Thank You,

Peter

Message 1 of 9

Accepted Solutions
ptoschi
Luminary

Re: Problems with LAG von M4300-8x8F switches

Hello,

thank you for the reply. I only tried Hash mode 7 after I encountered the problems. But I will of course set it back to 3.

I will try to reboot the switches on the weekend. Then I will be able to use the new firmware and the lag will probably work anyway.

Thank you for your help!

View solution in original post

Message 9 of 9

All Replies
Retired_Member
Not applicable

Re: Problems with LAG von M4300-8x8F switches

Hi @ptoschi,

 

Welcome to the community!

First, you need add all ports as LAG members on Switch, include fiber port and copper port. And the up ports member will change to active port, and will forwarding traffic.  And other config for LAG just keep default.

So please run CLI commad as below to check LAG members:

'show port-channel 1'



Hope it helps!

Regards,

EricZ
NETGEAR employee

Message 2 of 9
ptoschi
Luminary

Re: Problems with LAG von M4300-8x8F switches

Hello,

the 4 ports in question are all members of the lag group:

1/0/1, 1/0/9, 2/0/1, 2/0/91/0/9

The problem is, if i connect more than one port on the fly, I get connection errors. It worked fine in the beginning so I suspect it would work again if i gut shut down the switches, connect the lag ports and then start up the switches again. Unfortunately that is not possible at the moment and I would expect the lag group to accept changes on the fly.

 

By the way, the CLI command did not work (it would not accept the "1" after the command, but I can see everything in the web interface.

 

Thank You,

Peter

Message 3 of 9
Retired_Member
Not applicable

Re: Problems with LAG von M4300-8x8F switches

Hi @ptoschi,

 

For further analysis, Could you please provide the tech-support file of the Switch? Include two stacking switches.
How do I send tech-support files from my Managed Switch to NETGEAR community moderators?
http://kb.netgear.com/app/answers/detail/a_id/31439

Message 4 of 9
ptoschi
Luminary

Re: Problems with LAG von M4300-8x8F switches

Thank You very much for your help. I've sent the files to switch_support@netgear.com

Message 5 of 9
Retired_Member
Not applicable

Re: Problems with LAG von M4300-8x8F switches

Hi @ptoschi,

 

Thanks for immediately response!

Yes, it's enough. 

And I notice some ports are blocking by STP protocol. So please run below CLI command to check STP status(plug-in all LAG member ports, include copper and fiber port):

1. show spanning-tree summary

2. show spanning-tree mst port summary 0 active

3. show port-channel 1 (you mean this command cannot be executed on console port?)

 

Besides: The firmware is too old on your 4 switches, could you please upgrade to latest image and try again?

The latest firmware link is image

 

Message 6 of 9
ptoschi
Luminary

Re: Problems with LAG von M4300-8x8F switches

Thank You for your answer. I've uploaded the new firmware. Unfortunately I am not able to reboot the Switches at the moment since they are productive. For the same reason I cannot plug in all of the lag port cables - I will try to do so tomorrow noon. I disabled stp because with my old netgear switches the net went down for a minute when I rebooted one switch of the stack. I hope this doesn't have with stp disabled, but I am not willing to find out at the moment.

 

Here is the output of the commands you told me:

 

(Server Switch OG 1) >show spanning-tree summary

Spanning Tree Admin Mode.......... Disabled
Spanning Tree Version............. IEEE 802.1w
BPDU Guard Mode................... Disabled
BPDU Filter Mode.................. Disabled
Configuration Name................ ****
Configuration Revision Level...... ****
Configuration Digest Key.......... ****
Configuration Format Selector..... 0
No MST instances to display.

(Server Switch OG 1) >show spanning-tree mst port summary 0 active

            STP                  STP            Port
Interface   Mode   Type         State           Role       Desc
--------- -------- ------- ----------------- ---------- ----------
1/0/1     Enabled  PC Mbr  Discarding        Disabled
1/0/3     Enabled          Manual forwarding Disabled
1/0/5     Enabled          Manual forwarding Disabled
1/0/8     Enabled          Manual forwarding Disabled
1/0/9     Enabled  PC Mbr  Discarding        Disabled
1/0/11    Enabled          Manual forwarding Disabled
1/0/15    Enabled          Manual forwarding Disabled
1/0/16    Enabled          Manual forwarding Disabled
2/0/1     Enabled  PC Mbr  Discarding        Disabled
2/0/3     Enabled          Manual forwarding Disabled
2/0/6     Enabled          Manual forwarding Disabled
2/0/8     Enabled          Manual forwarding Disabled
2/0/9     Enabled  PC Mbr  Discarding        Disabled
2/0/13    Enabled          Manual forwarding Disabled
2/0/14    Enabled          Manual forwarding Disabled
2/0/16    Enabled          Manual forwarding Disabled
lag 1     Disabled         Manual forwarding Disabled

(Server Switch OG 1) >show port-channel 1
                                        ^
% Invalid input detected at '^' marker.

(Server Switch OG 1) >

Message 7 of 9
Retired_Member
Not applicable

Re: Problems with LAG von M4300-8x8F switches

Hi @ptoschi,

 

I notice the LAG1 Hash Mode is 7 on your Switch. Unfortunately the switch M4300-8X8F not support this Mode right now, it's a known problem, limited by Hardware. So suggest change to other Hash Mode(1-6, default is 3) and try again.

 

Hope it helps!

 

 

Message 8 of 9
ptoschi
Luminary

Re: Problems with LAG von M4300-8x8F switches

Hello,

thank you for the reply. I only tried Hash mode 7 after I encountered the problems. But I will of course set it back to 3.

I will try to reboot the switches on the weekend. Then I will be able to use the new firmware and the lag will probably work anyway.

Thank you for your help!

Message 9 of 9
Top Contributors
Discussion stats
  • 8 replies
  • 2253 views
  • 0 kudos
  • 2 in conversation
Announcements