Reply

Trunk two M4300-12x12F Switches without stacking

CrustySparks
Tutor

Trunk two M4300-12x12F Switches without stacking

I have two M430012x12F switches that I want to connect together, but I don't want to stack them.

The one (Master) is in the server room and is stacked with an M430016X, the other will reside at the end of fiber run (10G) in remote room.

When I first set up the M430016X in the server room I tried trunking it with the M430012x12F without success. It wasn't until I stacked them that they started trading traffic.

Now, when I go to connect the second M430012x12F in an MDF room, I want it to trunk to the stack but not be a member of the stack.  How would I go about this configuration?

 

The firmware version all switches are running is 12.0.13.8.

 

Current stack configuration:

!Current Configuration:
!
!System Description "M4300-12X12F ProSAFE 12-port 10GBASE-T and 12-port 10G SFP+, 12.0.11.16, B1.0.0.9"
!System Software Version "12.0.11.16"
!System Up Time "332 days 3 hrs 44 mins 55 secs"
!Additional Packages QOS,Multicast,IPv6,IPv6 Management,Stacking,Routing
!Current SNTP Synchronized Time: Nov 3 02:40:37 2021 UTC
!
serviceport protocol none
serviceport ip 10.10.10.1 255.255.255.0 0.0.0.0
no serviceport ipv6 enable
vlan database
vlan 2-9
vlan name 2 "admin"
vlan name 3 "WiFi"
vlan name 4 "stdnt"
vlan name 5 "mgnt"
vlan name 6 "voice"
vlan name 7 "cloud"
vlan name 8 "bbbnet"
vlan name 9 "mycc"
no vlan routing 1
vlan routing 4 1
vlan routing 3 2
vlan routing 5 3
vlan routing 2 4
vlan routing 7 5
vlan routing 9 6
exit
no ip http server
ip http secure-server
ip ssh server enable
configure
sntp server "172.16.0.2"
clock timezone -8 minutes 0
stack
member 1 5
member 2 11
no nsf
exit
dos-control firstfrag
dos-control icmpv4
dos-control icmpv6
dos-control icmpfrag
dos-control tcpport
dos-control udpport
dos-control sipdip
dos-control smacdmac
dos-control tcpfinurgpsh
dos-control tcpflagseq
dos-control tcpsyn
dos-control tcpsynfin
dos-control tcpfrag
dos-control tcpoffset
no ip routing
ip redirects
ip helper enable
username "admin" password 2 level 15 encrypted
no username guest
aaa authentication login "defaultList" local enable line
aaa authentication login "networkList" local enable line
aaa authentication login "eugene" local line enable
aaa authentication enable "enableList" enable line
aaa authentication enable "enableNetList" enable line
aaa authentication dot1x default local
line console
serial timeout 160
exit
line telnet
exit
line ssh
enable authentication enableNetList
exit
interface 1/0/11
addport lag 1
exit
interface 1/0/12
addport lag 1
exit
interface 1/0/10
auto-negotiate
speed auto 1000 full-duplex
addport lag 2
exit
interface 1/0/8
auto-negotiate
speed auto 1000 full-duplex
addport lag 2
exit
interface 1/0/5
addport lag 3
exit
interface 1/0/6
addport lag 3
exit
interface 1/0/1
addport lag 4
exit
interface 1/0/2
addport lag 4
exit
snmp-server sysname "Switch-Server-Room"
snmp-server location "Server Room"
snmp-server contact "helpdesk@coquitlamcollege.com"
!
snmp-server community "coqcollege"
snmp-server community ipaddr 192.168.0.23 coqcollege
snmp-server community ipmask 255.255.255.0 coqcollege
dhcp l2relay vlan 2
interface 1/0/1
bandwidth 100000
description 'sfp-BkRm-fp#'
switchport mode trunk
switchport trunk allowed vlan 1-5
vlan ingressfilter
vlan participation include 2-8
vlan tagging 1-8
ip mtu 1500
exit
interface 1/0/2
description 'sfp-BkRm-fp#'
switchport mode trunk
switchport trunk allowed vlan 1-5
vlan ingressfilter
vlan tagging 1
exit
interface 1/0/3
switchport mode trunk
switchport trunk allowed vlan 1-6
vlan ingressfilter
vlan participation include 2-3,5
vlan tagging 1-3,5
exit
interface 1/0/4
auto-negotiate
speed auto 1000 full-duplex
bandwidth 1000000
description 'sfp-Admin-fp1'
switchport mode trunk
switchport trunk allowed vlan 1-5
vlan ingressfilter
vlan participation include 2-3,5
vlan tagging 1-3,5
ip mtu 1500
exit
interface 1/0/5
bandwidth 10000000
description 'sfpAdmin-fp#'
switchport mode trunk
switchport trunk allowed vlan 1-5
ip mtu 1500
exit
interface 1/0/6
description 'sfpAdmin-fp2'
switchport mode trunk
switchport trunk allowed vlan 1-5
exit
interface 1/0/7
auto-negotiate
speed auto 1000 full-duplex
bandwidth 1000000
description 'sfp-Library-fp1'
switchport mode trunk
switchport trunk allowed vlan 1-5
vlan ingressfilter
vlan participation include 2-5
vlan tagging 1-5
ip mtu 1500
exit
interface 1/0/8
bandwidth 1000000
description 'sfp-Vault-fp2'
switchport mode trunk
switchport trunk allowed vlan 1-5
vlan ingressfilter
vlan participation include 2-5
vlan tagging 1-5
ip mtu 1500
exit
interface 1/0/9
switchport mode trunk
switchport trunk allowed vlan 1-5
vlan acceptframe vlanonly
vlan ingressfilter
vlan participation include 3-5
exit
interface 1/0/10
bandwidth 1000000
description 'sfp-Vault-fp3'
switchport mode trunk
switchport trunk allowed vlan 1-5
vlan ingressfilter
vlan participation include 2-5
vlan tagging 1-5
ip mtu 1500
exit
interface 1/0/11
bandwidth 1000000
description 'sfp-CpSci-akaRm1-fp1'
switchport mode trunk
switchport trunk allowed vlan 1-5
ip mtu 1500
exit
interface 1/0/12
bandwidth 1000000
description 'sfp-CpSci-akaRm1-fp2'
switchport mode trunk
switchport trunk allowed vlan 1-5
ip mtu 1500
exit
interface 1/0/13
bandwidth 1000000
description 'Cloudy-p1'
switchport mode trunk
switchport trunk allowed vlan 1-5
vlan acceptframe vlanonly
vlan ingressfilter
vlan participation include 2-5
ip mtu 1500
exit
interface 1/0/14
bandwidth 1000000
description 'worm-p3'
switchport mode access
switchport access vlan 2
switchport trunk native vlan 2
switchport trunk allowed vlan 2
vlan pvid 2
vlan acceptframe admituntaggedonly
vlan ingressfilter
vlan participation include 2,4
vlan tagging 2
ip mtu 1500
exit
interface 1/0/15
bandwidth 10000000
description 'Cloud5-p2'
switchport mode access
switchport access vlan 4
switchport trunk native vlan 4
switchport trunk allowed vlan 4
vlan pvid 4
vlan ingressfilter
vlan participation include 4-5
ip mtu 1500
exit
interface 1/0/16
bandwidth 10000000
description 'Cloud5-p4'
no spanning-tree auto-edge
spanning-tree mst 0 cost 20000
switchport mode access
switchport access vlan 2
switchport trunk native vlan 2
switchport trunk allowed vlan 2
vlan pvid 2
vlan ingressfilter
vlan participation include 2,4-5
vlan tagging 2
ip mtu 1500
exit
interface 1/0/17
bandwidth 1000000
description 'smrtg-p1'
switchport mode access
switchport access vlan 4
switchport trunk native vlan 4
switchport trunk allowed vlan 4
vlan pvid 4
vlan participation auto 1
vlan participation include 4
vlan tagging 1,4
ip mtu 1500
exit
interface 1/0/18
bandwidth 1000000
description 'worm-p1'
switchport mode trunk
switchport trunk allowed vlan 1-6,8
vlan acceptframe vlanonly
vlan ingressfilter
vlan participation include 3-5
vlan tagging 1,3,5
ip mtu 1500
exit
interface 1/0/19
bandwidth 1000000
description 'ptc1-p1'
switchport mode trunk
switchport trunk allowed vlan 1-5
vlan acceptframe admituntaggedonly
vlan ingressfilter
vlan participation include 2-5
vlan tagging 1-5
ip mtu 1500
exit
interface 1/0/20
bandwidth 10000000
description 'rainy-p2'
switchport mode trunk
switchport trunk allowed vlan 1-9
ip mtu 1500
exit
interface 1/0/21
bandwidth 10000000
description 'Cloud7-p3'
switchport mode access
switchport access vlan 7
switchport trunk native vlan 7
switchport trunk allowed vlan 7
vlan pvid 7
vlan acceptframe vlanonly
vlan ingressfilter
vlan participation include 4-5,7
vlan tagging 4,7
ip mtu 1500
exit
interface 1/0/22
bandwidth 100000
description 'M4300-U2-p1'
switchport mode trunk
switchport trunk allowed vlan 1-5
vlan ingressfilter
vlan participation include 2-8
vlan tagging 1-8
ip mtu 1500
exit
interface 1/0/23
bandwidth 1000000
description 'POEI-FrontLobby-WAP'
switchport mode access
switchport access vlan 3
switchport trunk native vlan 3
switchport trunk allowed vlan 3
vlan pvid 3
vlan acceptframe vlanonly
vlan ingressfilter
vlan participation auto 1
vlan participation include 3
vlan tagging 3
ip mtu 1500
exit
interface 1/0/24
bandwidth 1000000
description 'Clouds-p24-Trunk'
switchport mode trunk
switchport trunk allowed vlan 1-7,9
vlan acceptframe vlanonly
vlan ingressfilter
vlan participation include 2-5
ip mtu 1500
exit
interface 2/0/1
bandwidth 100000
description 'M4300-U1-p22'
ip mtu 1500
exit
interface 2/0/2
bandwidth 1000000
description 'Cloud7-p2'
switchport mode access
switchport access vlan 2
switchport trunk native vlan 2
switchport trunk allowed vlan 2
ip mtu 1500
exit
interface 2/0/3
bandwidth 1000000
description 'Cloud8-p1'
switchport mode access
switchport access vlan 7
switchport trunk native vlan 7
switchport trunk allowed vlan 7
ip mtu 1500
exit
interface 2/0/4
bandwidth 1000000
description 'Cloud7-p1'
switchport mode access
switchport access vlan 7
switchport trunk native vlan 7
switchport trunk allowed vlan 7
ip mtu 1500
exit
interface 2/0/5
bandwidth 100000
description 'Cloud5-p1'
switchport mode access
switchport access vlan 7
switchport trunk native vlan 7
switchport trunk allowed vlan 7
ip mtu 1500
exit
interface 2/0/6
bandwidth 100000
description 'NA-purple'
switchport mode access
switchport access vlan 7
switchport trunk native vlan 7
switchport trunk allowed vlan 7
ip mtu 1500
exit
interface 2/0/7
bandwidth 10000000
description 'Cloud2-p5'
switchport mode trunk
switchport trunk allowed vlan 1-9
ip mtu 1500
exit
interface 2/0/8
bandwidth 10000000
description 'Cloud2-p6'
switchport mode access
switchport access vlan 5
switchport trunk native vlan 5
switchport trunk allowed vlan 5
ip mtu 1500
exit
interface 2/0/9
bandwidth 100000
description 'NA-shrtcable'
switchport mode access
switchport access vlan 9
switchport trunk native vlan 9
switchport trunk allowed vlan 9
ip mtu 1500
exit
interface 2/0/10
bandwidth 10000000
description 'Cloud8-p3'
switchport mode access
switchport access vlan 9
switchport trunk native vlan 9
switchport trunk allowed vlan 9
ip mtu 1500
exit
interface 2/0/11
bandwidth 100000
description 'NA-shrtcable'
switchport mode access
switchport access vlan 9
switchport trunk native vlan 9
switchport trunk allowed vlan 9
ip mtu 1500
exit
interface 2/0/12
bandwidth 10000000
description 'Cloud7-p4'
switchport mode access
switchport access vlan 9
switchport trunk native vlan 9
switchport trunk allowed vlan 9
ip mtu 1500
exit
interface 2/0/13
switchport mode access
switchport access vlan 9
switchport trunk native vlan 9
switchport trunk allowed vlan 9
exit
interface 2/0/14
switchport mode access
switchport access vlan 9
switchport trunk native vlan 9
switchport trunk allowed vlan 9
exit
interface 2/0/15
switchport mode access
switchport access vlan 5
switchport trunk native vlan 5
switchport trunk allowed vlan 5
exit
interface 2/0/16
bandwidth 10000000
description 'Cloud8-p4'
switchport mode access
switchport access vlan 5
switchport trunk native vlan 5
switchport trunk allowed vlan 5
ip mtu 1500
exit
interface lag 1
description 'Room1'
port-channel static
switchport mode trunk
switchport access vlan 5
switchport trunk allowed vlan 1-5
vlan ingressfilter
vlan participation include 2-5
vlan tagging 1-5
exit
interface lag 2
description 'Vault-EastElect'
port-channel static
switchport mode trunk
switchport access vlan 5
switchport trunk allowed vlan 1-5,8
vlan ingressfilter
vlan participation include 2-5
vlan tagging 1
exit
interface lag 3
description 'AdminOffice'
switchport mode trunk
switchport access vlan 5
switchport trunk allowed vlan 1-5
vlan acceptframe vlanonly
vlan ingressfilter
vlan participation include 3-5
exit
interface lag 4
description 'BookRoom-Library'
switchport mode trunk
switchport access vlan 5
switchport trunk allowed vlan 1-5
exit
interface vlan 4
routing
ip address 192.168.0.239 255.255.255.0
exit
interface vlan 3
routing
ip address 10.1.0.2 255.255.0.0
exit
interface vlan 5
routing
ip address 172.16.0.10 255.255.255.0
exit
interface vlan 2
routing
ip address 192.168.1.11 255.255.255.0
exit
interface vlan 7
routing
ip address 192.168.4.253 255.255.255.0
exit
interface vlan 9
routing
ip address 192.168.5.12 255.255.255.0
exit
ip management vlan 5 172.16.0.10 255.255.255.0
ip management source-interface vlan 5
router rip
no enable
exit
router ospf
no enable
exit
ipv6 router ospf
no enable
exit
exit

Model: XSM4324S|M4300-12X12F - Stackable Managed Switch with 24x10G including 12x10GBASE-T and 12xSFP+ Layer 3
Message 1 of 4
DaneA
NETGEAR Moderator

Re: Trunk two M4300-12x12F Switches without stacking

@CrustySparks,

 

Now, when I go to connect the second M430012x12F in an MDF room, I want it to trunk to the stack but not be a member of the stack.  How would I go about this configuration?

You can connect the second M430012x12F via LAG to the existing stack. Let me share these articles below as reference guide:

 

How do I create two Link Aggregation Groups (LAGs) using the web interface on my managed switch?

How do I create two Link Aggregation Groups (LAGs) using CLI commands on my managed switch?

 

 

Regards,

 

DaneA

NETGEAR Community Team

Message 2 of 4
CrustySparks
Tutor

Re: Trunk two M4300-12x12F Switches without stacking

The LAG seems to meet with the same problem as trunking.

Unless there is a command to force the LAG up, it is down on one side:

172.16.0.11.png

 

172.16.0.12.png

Current configs on both sides:

 

172.16.0.12:

!System Software Version "12.0.13.8"
!System Up Time "0 days 14 hrs 30 mins 17 secs"
!Additional Packages QOS,Multicast,IPv6,IPv6 Management,Stacking,Routing
!Current SNTP Synchronized Time: SNTP Last Attempt Status Is Not Successful
vlan database
vlan 2-7,9
vlan name 2 "admin"
vlan name 3 "wifi"
vlan name 4 "stdnt"
vlan name 5 "mgmt"
vlan name 6 "voice"
vlan name 7 "cloud"
vlan name 9 "mycc"
no vlan routing 1
vlan routing 2 1
vlan routing 3 2
vlan routing 4 3
vlan routing 5 4
vlan routing 6 5
vlan routing 7 6
vlan routing 9 7
exit

configure
stack
member 1 5
exit
no ip routing
username "admin" password
username snmpv3 authentication "admin" md5
line console
exit

line telnet
exit

line ssh
exit

interface 1/0/13
addport lag 1
exit
interface 1/0/14
addport lag 1
exit
interface 1/0/1
auto-negotiate
speed auto 1000 full-duplex
switchport mode trunk
switchport trunk allowed vlan 1-7,9
vlan ingressfilter
vlan participation include 2-7,9
vlan tagging 1-7,9
exit

interface lag 1
port-channel static
port-channel load-balance 3
switchport mode trunk

switchport trunk allowed vlan 1-7,9
exit

interface vlan 2
routing
exit

interface vlan 3
routing
exit

interface vlan 4
routing
ip address 192.168.0.12 255.255.255.0
exit

interface vlan 5
routing
ip address 172.16.0.12 255.255.255.0
exit

interface vlan 6
routing
exit

interface vlan 7
routing
exit

interface vlan 9
routing
exit

ip management vlan 5 172.16.0.12 255.255.255.0
ip management source-interface vlan 5
router rip
no enable
exit
router ospf
no enable
exit
ipv6 router ospf
no enable
exit

exit

 

172.16.0.11:

!System Software Version "12.0.13.8"
!System Up Time "0 days 14 hrs 30 mins 17 secs"
!Additional Packages QOS,Multicast,IPv6,IPv6 Management,Stacking,Routing
!Current SNTP Synchronized Time: SNTP Last Attempt Status Is Not Successful
vlan database
vlan 2-7,9
vlan name 2 "admin"
vlan name 3 "wifi"
vlan name 4 "stdnt"
vlan name 5 "mgmt"
vlan name 6 "voice"
vlan name 7 "cloud"
vlan name 9 "mycc"
no vlan routing 1
vlan routing 2 1
vlan routing 3 2
vlan routing 4 3
vlan routing 5 4
vlan routing 6 5
vlan routing 7 6
vlan routing 9 7
exit

configure
stack
member 1 5
exit
no ip routing
username "admin" password
username snmpv3 authentication "admin" md5
line console
exit

line telnet
exit

line ssh
exit

interface 1/0/13
addport lag 1
exit
interface 1/0/14
addport lag 1
exit
interface 1/0/1
auto-negotiate
speed auto 1000 full-duplex
switchport mode trunk
switchport trunk allowed vlan 1-7,9
vlan ingressfilter
vlan participation include 2-7,9
vlan tagging 1-7,9
exit

interface 1/0/24
switchport mode access
switchport access vlan 4
switchport trunk native vlan 4
exit

interface lag 1
port-channel static
port-channel load-balance 3
switchport mode trunk

switchport trunk allowed vlan 1-7,9
exit

interface vlan 2
routing
exit

interface vlan 3
routing
exit

interface vlan 4
routing
ip address 192.168.0.12 255.255.255.0
exit

interface vlan 5
routing
ip address 172.16.0.11 255.255.255.0
exit

interface vlan 6
routing
exit

interface vlan 7
routing
exit

interface vlan 9
routing
exit

ip management vlan 5 172.16.0.11 255.255.255.0
ip management source-interface vlan 5
router rip
no enable
exit
router ospf
no enable
exit
ipv6 router ospf
no enable
exit

exit

 

 

Model: XSM4324S|M4300-12X12F - Stackable Managed Switch with 24x10G including 12x10GBASE-T and 12xSFP+ Layer 3
Message 3 of 4
DaneA
NETGEAR Moderator

Re: Trunk two M4300-12x12F Switches without stacking

@CrustySparks,

 

I apologize for the late response. :catsad: 

It seems that the configuration is correct.  Kindly double check the physical connections.  

 

If still the same problem, I suggest you to open a support ticket with NETGEAR Support here at anytime for further investigation.   

 

 

Regards,

 

DaneA
NETGEAR Community Team

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 289 views
  • 0 kudos
  • 2 in conversation
Announcements