Discussion stats
  • 1 reply
  • 79 views
  • 0 kudos
  • 2 in conversation
Announcements

Top Contributors
Reply
Highlighted
Follower

Can't seem to get AirCard 340U Beam to work on Raspberry pi

I have been trying for the past 5 summers to get some kind of a cellular internet connection working on a raspberry pi. I've tried over 7 different hardware solutions with the latest effort involving an old 340U Beam and an AT&T hotspot plan. I updated the firmware so it doesn't only work on windows 8 and confirmed it works just fine on my laptop with Linux Ubuntu. But doing the exact same set-up in Raspbian doesn't work.
Last summer when I tried it, I couldn't even get an IP address or get the modem to say it was connected. This year I get an IP and it says it's connected but if I try anything like a ping using the wwan0 interface, nothing happens. (it works just fine on the linux box)

I am using nmcli to set up the broadband connection and apn. I've tried bringing the interface up and down, verified the qmi_wwan and qcserial are loading. Verified the route is getting set up. Everything appears to start up identically on both devices, but only the ubuntu version can actually get anything back over the interface. There are no firewall rules in place on either machine while doing these tests.

Does anyone have any suggestions as to what ubuntu may be doing that rasbpian is not?

Model: AirCard 340U (AT&T)|AT&T Beam
Message 1 of 2
Highlighted

Re: Can't seem to get AirCard 340U Beam to work on Raspberry pi

You might get better and quicker replies, and find other answers, over in the appropriate section for your device. That's probably here:

Mobile Routers, Hotspots & Modems

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 2 of 2