Reply
rramstad
Guide

Re: LB2120: no automatic re-connect

I've been trying to get the new firmware for about two months and it still hasn't been pushed to my device though I've interacted both with the community manager and have a formal support case open.

 

I am not aware of a single person who has actually gotten the new firmware -- I've asked on this forum for people to confirm if they have gotten it, and no one responded.

 

I suspect if you are sincere -- that you need your device to work within seven days or you'll be returning it -- that you'll be returning it.  There are other suggested devices on this thread, from other companies, perhaps one of those will work.

 

My device hasn't worked propery for a year and a half.  I've held off on replacing it because it always feels like new firmware is just around the corner -- this can't be a difficult problem to fix, TBH -- but I will have to give up if my broadband gets flakey again like it often does in the winter.

 

 

Message 126 of 158
Bigrck
Aspirant

Re: LB2120: no automatic re-connect

Hello all,

 

I have the exact same problem since 2 years...

Bridge mode, and reconnect doesn't work every ~24h.

 

@Blanca_O Could you send me the procedure to test new firmware ? thanks

Model: LB2120|4G LTE Modem
Message 127 of 158
steeley
Aspirant

Re: LB2120: no automatic re-connect

I gave up.  I haven't heard from anybody that has actually received the firmware.  I sent my router back to Amazon and got a full refund.  After this experience I certainly wont be buying netgear kit again.  This support section seems to be wasting everyone's time with promises of a firmware upgrade that simply isn't coming

Message 128 of 158
Wilde1
Aspirant

Re: LB2120: no automatic re-connect

Hi. I just found this thread this morning (2019-09-30).

 

I downloaded and installed new firmware on my LB2120 a few days ago. I use my LB2120 as my home internet source (bridge mode, connected to an Netgear Orbi AC3000 router, using AT&T cellular), not as a backup for hardwired internet.

 

The firmware upgrade had three immediate effects:

1) I had to do a hardware reset (hole on the bottom label) before I could login to the LB2120 at 192.168.5.1.

2) My normal download and upload speeds almost doubled.

3) My LB2120 completely loses the internet once or twice a day (and I have to manually turn off then on again).

 

Before the firmware upgrade, I had a slow but solid ISP source (usually ~ 10 Mb/s, losing internet once every 7-14 days). Now it is fast and unreliable (usually 20-30 Mb/s, losing internet typically twice a day).

 

Has anyone else been able to download the latest firmware?

Model: LB1120|4G LTE Modem
Message 129 of 158
Blanca_O
NETGEAR Moderator

Re: LB2120: no automatic re-connect

Hi @Wilde1

 

May we please know the current firmware version and device model number / SKU? 

 

Regards, 
Blanca 
Community Team

Message 130 of 158
mfoster11
Aspirant

Re: LB2120: no automatic re-connect

Wow someone from netgear is here at last ...quick everyone get in before they vanish for another few months!!!

Is this fixed yet!!
Message 131 of 158
Blanca_O
NETGEAR Moderator

Re: LB2120: no automatic re-connect

Hi @mfoster11

 

We received an update from engineering team that a new firmware was released. Please check for an available update on your device and let us know of the result and/or observation. 

 

Regards, 
Blanca 
Community Team

Message 132 of 158

Re: LB2120: no automatic re-connect

@Blanca_O what's the version number of this recently released firmware? Might be a good idea for us all to check if this matches our current instaled firmware?

 

Cheers, Will

Message 133 of 158
Wilde1
Aspirant

Re: LB2120: no automatic re-connect

Hi Blanca,

 

My device model number is: LB2120

The SKU  is: LB2120-100NAS

I have no idea what the firmware version is. It is not available anywhere on the LB2120 Manager (at 192.168.5.1) or on Netgears support pages. I just had the LB2120 Manager check for new firmware a few days ago, then installed the update.

 

Note: My download and upload speeds continue to be 2-3 times faster than normal, but I've already lost internet twice today (required manually turning the LB2120 Off - On twice).  Very frustrating...

 

Thanks in advance for any help you can offer.

Model: LB2120|4G LTE Modem
Message 134 of 158
Bigrck
Aspirant

Re: LB2120: no automatic re-connect

@Wilde1 You can find the firmware version on the webinterface of the LB2120: once logged, click on the "About" in the top-right menu (just beside "logoff").

Message 135 of 158
rramstad
Guide

Re: LB2120: no automatic re-connect

I had a previous post removed, and have no idea why, but I have a hunch that it was due to posting firmware revision numbers, and so I won't post my current revision here.

 

That said, my interaction with support this morning was confusing and troubling.

 

They sent an update to my support case saying an update was available for my LB2120.  I logged into the device and confirmed that I had the same firmware version as before.  (In the past they've claimed they can push new firmware to the device, but that has never happened.)  There was also details displayed that an update was available.

 

In an attempt to be systematic, I navigated to the manual "check for updates" button and pressed it -- in the past it had said no updates available, this time it prompted me to do a download.  I did that download, then told the system to update to the new firmware.

 

The system rebooted.  As per the instructions from support, I did a factory reset.

 

It took me some time to realize that the password was now the default (printed on the bottom of the device).  I also did not have my APN working properly, as it lost those settings as well as all the others...  so I spent a little time tweaking settings.  To get it to work with my APN I had to power cycle the modem, nothing else would work.

 

Anyhow, once I had everything all set, I went into about and shockingly the firmware revision is exactly what it was before.  Truly weird.  Same exact thing -- I saved the string off in the support case earlier, and used Ctl-F in my browser to "find" the identical string.

 

Weirdly the manual update button doesn't show any updates available now.

 

So, to be charitable, they may have released a new firmware revision without incrementing the identifier.  I have no idea why they'd do that, as it would just lead to massive confusion, as no one could compare revisions.

 

The other possibility is that they just forced my device to reload the same firmware again, in the hope that doing a factory reset on a fresh firmware load would magically fix the problem.

 

I can't actually replicate the problems that I have had in the past -- if the device fails, it'll start thrashing in the middle of the night -- so I have no idea if anything is fixed or not, but other than the typical issues when factory resetting a device and having to redo all the configurations, the firmware upgrade went fine...  it just didn't increment or change the firmware revision, which is weird.

Message 136 of 158
Wilde1
Aspirant

Re: LB2120: no automatic re-connect

My post listing the firmware version number also disappeared. I wish the new firmware would disappear from my LB2120 and the old firmware would replace it....

Model: LB2120|4G LTE Modem
Message 137 of 158
Blanca_O
NETGEAR Moderator

Re: LB2120: no automatic re-connect

Hi, All, 

 

Please check for an available firmware update and let us know of the result. 

 

The new firmware version: 

 

For LB2120-100AUS, LB2120-100EUS and LB2120-100PES, firmware version is NTG9X07C_13.05.04.00

And for LB2120-100NAS, firmware version is NTG9X07C_12.09.05.29

 

LB2120 (all SKUs) release notes: 
New Features and Enhancements:

Added Keepalive settings to prevent the device from losing data connection due to idle timeout
Updated AutoAPN database to version 01.20
Bug Fixes:

Fixed security issue

 

Regards, 
Blanca 
Community Team

Message 138 of 158
Blanca_O
NETGEAR Moderator

Re: LB2120: no automatic re-connect

Hi @rramstad

 

I have sent you a message. Please check your inbox.

 

Regards, 
Blanca 
Community Team

Message 139 of 158
rramstad
Guide

Re: LB2120: no automatic re-connect

Hi, yes, my experience has been odd for sure.

 

My firmware revision is the same that it was before.  I won't post it here because every time I've done that, someone has deleted my post.

 

That said, I do have a Keepalive option in the web interface, which I didn't have before.

 

Checking for updates says there are no updates available.

 

It seems very much like the new firmware doesn't change the displayed firmware revision.  Weird, but absolutely true.

 

I mentioned all of this in the support case and included screenshots.

Message 140 of 158
Wilde1
Aspirant

Re: LB2120: no automatic re-connect

After sending Blanca at support all of my equipment information back on October 6th, I haven't heard a thing.  My LB2120 still disconnects from the internet twice a day. I have to manually turn it off and back on to restart the connection.

 

Wired internet is not available where I live and I'm dependent on an AT&T cellular hotspot plan. Unfortunately, that means I'm dependent on Netgear for a cellular modem setup. 

 

Is the Nighthawk a reliable substitute for an LB 2120/2110? Can you leave it plugged in to AC like an LB2120, or does it cause issues with the battery? Has anyone used both the LB gear and a Nighthawk?

Model: LB2120|4G LTE Modem
Message 141 of 158
PaulandLance
Aspirant

Re: LB2120: no automatic re-connect

My LB2120 is set in bridge mode runningthe latest firmware version. It can connect to LTE and successfully work as a backup for my house's wired connection, but it stops serving ANY internet via the normally wired connection (Nor does it switch to cellular and use it) every 24 hours or so. Please advise? Firmware version  current as of 10/22/19.

Model: LB2120|4G LTE Modem
Message 142 of 158
Eguun
Aspirant

Re: LB2120: no automatic re-connect

Hi,

 

I was facing this red light issue.

Google search brought me to this thread with several users facing similar issue, largely described in previous posts (my LB2120 was in router mode though)

 

This thread made me aware of a firmware update. I updated my router.

No red light issue any longer.

 

Before this update, I had the LB2120 plugged on a power switch with a timer. And I scheduled the timer to reset the power daily at 3am.

That wasn't sufficient: even in spite in this daily reboot, I still caught the router with the red light activated.

This router is used as backup switch, when fiber is down. Fiber is pretty stable, but in the few cases it failed, the 4G router wasn't up to the task due to this red light.

 

It's been a few consecutive days without reboot and no red light.

Seems for me this update fixed this painful issue.

Model: LB2120|4G LTE Modem
Message 143 of 158

Re: LB2120: no automatic re-connect

I've got the stupid amber light again!

Restarted the device; nothing

Reseated the SIM card; nothing

Tried checking all the settings; nothing

Can't see any options for manual reconnecting or beong able to view the log

Model: LB2120|4G LTE Modem
Message 144 of 158
mfoster11
Aspirant

Re: LB2120: no automatic re-connect

hows the replacement 4g modem going 

Message 145 of 158
mfoster11
Aspirant

Re: LB2120: no automatic re-connect

Hows the replacement 4g modems going anyone using Teltonika 4G-RUT240 Compact Industrial 4G LTE Router

Message 146 of 158
bex000
Initiate

Re: LB2120: no automatic re-connect

I stopped buying netgear 6 years ago (I bought a fritzbox router) and decided I needed a netgear LTE modem and bought a netgear this year (2020).

 

Having set this up, I am experiencing the same thing the OP and countless others on this thread are facing since 2018. Looks like 2020 and it is still not resolved. I have that latest firmware, the download firmware button on modem allows as of Last checked at: 3/8/20 10:51 PM. Still get disconnections every few hours.

 

Hate to apply the same logic to all of netgear but after reading the 2 year old thread and the problem is not resolved, I might get rid of this LB2120 and never come back to Netgear... Good bye.

Model: LB2120|4G LTE Modem
Message 147 of 158

Re: LB2120: no automatic re-connect

Mine is still plugged in but it's not doing anything. The LTE connection has totally stopped working. I plan on unplugging it when I have some time as I'll have to reconfigure my Router to talk directly to my Modem again. I'll probably look for another solution.
Message 148 of 158

Re: LB2120: no automatic re-connect

Mine is still plugged in but it's not doing anything. The LTE connection has totally stopped working. I plan on unplugging it when I have some time as I'll have to reconfigure my Router to talk directly to my Modem again. I'll probably look for another solution.

Model: LB2120|4G LTE Modem
Message 149 of 158
mfoster11
Aspirant

Re: LB2120: no automatic re-connect

Got rid of it ages ago, better solutions out there that actually work and are reliable
Message 150 of 158
Discussion stats
Announcements