Reply
Guide

Re: LB2120: no automatic re-connect

Thanks - that makes sense SOGAPEX

Message 26 of 158
Guide

Re: LB2120: no automatic re-connect

I had to write a bash/python script that pings from one of my linux server. If the modem is disconnected I power off and on a smart plug. One minute outage but at least it doesn't stay amber. There is another better way to do this, use the netgear API, unfortunately it's not published so you have to sort of stab in the dark.

 

This is, by the way, ridiculous.

Message 27 of 158
Guide

Re: LB2120: no automatic re-connect

Hi tleej, thanks for the note, could I ask what you're pinging to know if the LTE is disconnected?  Is this an internal ping (to the box) or a ping from the internet to see if you can reach an internal server (via the LTE connection), I'm assuming the latter?  If you have any details on the API at all I'm all ears and tempted to write a smartthings device handler!

Message 28 of 158
Guide

Re: LB2120: no automatic re-connect

I'm doing the same with my router and power plug
Message 29 of 158
Guide

Re: LB2120: no automatic re-connect

Hi,

 

I am pinging from a linux server on my network.

 

The script is as follows (in bash). All you need to get is the wemo python script (you can find it here: https://gist.github.com/pruppert/af7d38cb7b7ca75584ef). Copy and paste the script 2 times, and uncomment what you need (I use on/off).

 

#!/bin/bash
SERVERIP=8.8.8.8 ping -c 3 $SERVERIP > /dev/null 2>&1 if [ $? -ne 0 ] then echo `date` >> /home/logwemo.log echo `/home/wemo-off.py` >> /home/logwemo.log echo "WEMO OFF" >> /home/logwemo.log sleep 2 echo `date` >> /home/logwemo.log echo `/home/wemo-on.py` >> /home/logwemo.log echo "WEMO ON" >> /home/logwemo.log else echo "CONNECTED ON" >> /home/logwemo.log echo `date` >> /home/logwemo.log fi

then in your crontab:

*/2 * * * * /home/checkinternet.sh

 

Message 30 of 158
Guide

Re: LB2120: no automatic re-connect

My problem has been ongoing with bridge mode failing to reconnect, but out of interest what settings are people with the issue using for auto reconnect, the 'except when roaming' or 'always'?

 

Only reason I ask is I changed from the former to the latter and I've gone a couple of days without failure to reconnect. Probably wishful thinking and just coincidence, but it did make me wonder.

Message 31 of 158
Guide

Re: LB2120: no automatic re-connect

Funnily I was having similar thoughts yesterday when I was considering the settings. I also realised I don’t actually know for certain what those connection settings are actually doing, I’m assuming overseas roaming but then thought it may actually be network roaming and for some reason I jump off the home network, pick up another and hey presto no reconnections. 

 

I haven’t changed any settings just now and the connection is still up after 24h so am monitoring it on ‘except when roaming’ using an EE sim.  I’m going to test this theory on roaming over the coming days when I inevitably disconnect. 

Message 32 of 158
Guide

Re: LB2120: no automatic re-connect

Thanks tleej, I see you’re pinging 8.8.8.8 so checking an external ip so I assume that address is accessible via your LTE connection all the time.  I’m using the box as a failover for a primary wired connection, so pinging 8.8.8.8 would reply via the wired connection even if the LTE is disconnected.  I have found some API info on github and going to see if I can adapt it to allow more direct automated control of the box. 

Message 33 of 158
Guide

Rif.: LB2120: no automatic re-connect

Hi Guys, I'm form Italy and I have the same problem, both in the router or bridge mode.

I bought this modem to have a fail-safe network but every couple of days it goes down and I cant'reach it from the web.

 

If I log-in in the web-based interface and i click on "reconnect" it restart working.

 

Why isn't this automatic?

 

(I use only 4G connection and it is always connected).

 

Is there a solution or did I have to send it back to the vendor?

 

(Sorry for my bad english)

Message 34 of 158
Guide

Rif.: LB2120: no automatic re-connect

Hi Jetro, welcome to the debate!  Your're English is definately better than my Italian!  Seems this problem is very common and so far I've not seen a solution - the best I've read is package it back up and send it back.  I've had lots of probems in the past with Netgear routers and extenders and this is proving to be no exception I'm afraid. 

Message 35 of 158
Guide

Rif.: LB2120: no automatic re-connect

Just a further update on what I've been trying.

 

1. In bridge mode I've tried the "Auto Connect Always" setting, this hasn't made the LTE re-connection automatic.

2. I've actually added an external aerial ... no joy there.

3. I've now reconfigured the box back to "router" mode (it still sits between my wifi access points and ISP router).  

 

I'll update with any progress, you never know Netgear may actually fix it at some point.

Message 36 of 158
Guide

Rif.: LB2120: no automatic re-connect

I had my case escalated to L2, but before I could find a day when I would be available for a call they closed the case!

 

They wouldn't use email so this seems convenient.

Message 37 of 158

Rif.: LB2120: no automatic re-connect

Having a script continually ping a host and using smart plugs may work but it is a hack, what we need is new firmware. Everyone here should be opening tickets with Netgear https://www.netgear.com/support/ you need to login and open a ticket. Only with people complaining directly to Netgear are we likely to get a fix.

 

I have a ticket open, it is poor support via a online portal, there is suppose to be live chat but I can not find any link to it. So far I have had 2 replies the standard please try a power cycle and a reset, next was check you are on latest firmware. I doubt I will get anywhere with them, but if enough of us complain they may notice. I also asked to RMA the device and pointed them to this forum.

Message 38 of 158
Aspirant

Re: LB2120: no automatic re-connect

I have the same issue. I keep losing internet connection and cannot get back on. So frustrating, I restarted the modem 10 ties the other day until it comp,etely failed. Please help, I need this for work!

Model: MR1100|Nighthawk LTE Mobile Hotspot Router (AU)
Message 39 of 158
Aspirant

Re: LB2120: no automatic re-connect

Hi, Can someone from Netgear please email me too? I need help with this modem. It keeps losing connection and doesn't reconnect automatically. It also takes me a very very long time to reconnect it manually.

Please help.

Model: MR1100|Nighthawk LTE Mobile Hotspot Router (AU)
Message 40 of 158
Guide

Re: LB2120: no automatic re-connect

Mine now is disconnecting more than one time every 24h. As I want to use it for remote-control now it's totally useless.

 

I'll open a ticket ASAP

Message 41 of 158
Guide

Re: LB2120: no automatic re-connect

Hi all, apart from a script and use a smart power plug I think we all are out of luck. And as Netgear support seems to just ignore us, I'm not sure if you will be able to get anything from them, but please do post any solution here if you do.

 

Before having to use bash/python and a wemo plug I have tried both to use the device as a router and bridged, to no avail, disconnected each time and no auto-reconnection.

 

Good luck and f**k you vey much NG

Message 42 of 158
Guide

Re: LB2120: no automatic re-connect

Well I've pretty much tried everything I can (bar the hard restart) - it's clearly a firmware problem and the absence of any feedback from NG looks to me like it's unlikely to be fixed and essentially means the box is really no better than creating a personal hotspot when I need one.  I'm going to raise a ticket as per the above suggestion and see if NG acknowlege the problem, unfortunately I can only see this box being returned as not fit for purpose.

 

I did try to post an Amazon review but it was rejected - warning others away from this kit.

Message 43 of 158
Guide

Re: LB2120: no automatic re-connect

I've posted a review on Italian Amazon about this and I'm going to send back the 4G modem.

Message 44 of 158
Guide

Re: LB2120: no automatic re-connect

Hi thought it worth a disappointing update.

 

I raised a ticket with Netgear and managed to get a chat with Netgear support, after a very fast conversation I was told that the team I was speaking to didn't support the LTE devices and this had to be dealt with by the AirCard team based in the US, they gave me a US number to call.  When I said I was in the UK I was given a UK number.

 

I did this and was immediately told that they couldn't deal with it and I was transferred to another team, it became apparent quickly that I was dealing with the US team now.

 

I explained the problem and pointed them to these discussions, we went through the basic troubleshooting and was asked if it was OK to call me back later, which was fine and in fairness they did.

 

The outcome was basically 3 options from Netgear, all involved them sending me a replacement to try a new "known" box, without doing this L2 support wouldn't acknowledge a problem and L1 couldn't escalate to them.  Given that I have until 31st Jan to return to Amazon I'm not comfortable taking this option away from myself, so unfortunately I've had to leave the call in the following state.

 

1. Netgear won't send a new box unless I return the one I got from Amazon.

2. They believe that it's a hardware fault - I stressed that this seems to be a common problem on more than the LB2120, so more likely firmware.

3. Unless I test the new box - L1 support can't escalate to L2.

4. I stressed that there are people on this group that would be willing to provide diagnostics if they were prepared to release a firmware capable of doing this (see point 3) to us.

5. I stressed that the people on this thread WANT and NEED this to be acknowledged as a problem and fixed.

6. My only available option was to accept a replacement from Netgear thereby invalidating my ability to send back to Amazon for a refund and risk an expensive doorstop.

 

So unfortunately my only option from here is to return to Amazon as not fit for purpose, the case I raised was #40785937 if anyone would like to quote this case.

 

IF there's any change in the situation I'll post an update. 

Message 45 of 158

Re: LB2120: no automatic re-connect

Thanks @robfrg I too would of returned it to Amazon if I had not missed the window

 

My ongoing case number #40758994, which like you is being dealt with in the US. I think they will just fob me off. They asked about my network topology. I pointed out the the device fails even with no clients attached in the LAN, just powered on with a SIM card after a number of hours it loses connection. Utterly useless!

Message 46 of 158

Re: LB2120: no automatic re-connect

Sorry another update. As I had missed the return window I contacted Amazon: My Orders > Order # > get product support > Chat Now. Explained the issue and quoted my Statutory Rights where goods are not as described, not fit for purpose or not of satisfactory quality. They instantly issues a return label and refund.

 

If they fix the firmware I will repurchase this item.

Message 47 of 158
Guide

Re: LB2120: no automatic re-connect

Me too!

 

Now i've purchased a Huawei B525s-65a which looks better, i hope Netgear will fix the problem, also because the LB2120 is a product for business solutions, not only for home use.

Message 48 of 158
Aspirant

Re: LB2120: no automatic re-connect

i am having the same issue here. connection dropping out on a daily basis.

 

is there a solution for this yet?

Message 49 of 158
Guide

Re: LB2120: no automatic re-connect

Hi @JoeC79 not as far as any of us has been able to come up with and Netgear don't seem to think it's an issue I'm afraid.

Message 50 of 158
Top Contributors
Discussion stats
Announcements