Re: Nighthawk M1 - selection of LTE Frequency/Band


Re: Nighthawk M1 - selection of LTE Frequency/Band

Ok Smiley Happy

This is great then, will look futher but what I did notice too but need confirming for next couple of days.

When I manually change BAND in setting, I have set B7 / B3 and B28 for selection, most of the time, it didn't reconnect to LTE provider, it was needed to create a manual APN to switch on it and/or back to APN auto to have the connection UP again.

It seems that with this firmware, it wasn't needed anymore. At least on different BAND change it was happening Smiley Happy


Not related to this firmware update (I think it was the case before but like I didn't fully tested it) :

Connecting an USB key to USB port and router without his battery, the power supply adapter is not enough, when I'm starting download, the router reboot ifself.

If I use a power adapter supercharge (for my phone) 40W, it's ok no more reboot.

In fact, the router was connected to 40W charger for last days.

And today, I have put the NETGEAR one and noticed it, so i don't know if it's firmware related or not.


I'm remembering that USB-C and ethernet in the same time, last week, the router reboot too on download (maybe after that i have used the 40W power supply).



For information : External antenna is always used for lower BAND than 2300. So B7 (2600) is using internal antenna.

Model: MR1100|Nighthawk M1 Mobile Router
Message 76 of 78

Re: Nighthawk M1 - selection of LTE Frequency/Band

MR1100EUS Firmware Version is available for Europe version.

Message 77 of 78

Re: Nighthawk M1 - selection of LTE Frequency/Band

Sometime in late 2019, an outfit on E-Bay started selling refurbished AT&T (USA) MR1100-2A1NAS Band 14 hotspots – and people bought hundreds of them. I finally bought one. I had hesitated to buy an MR1100 before because of problems other people had when trying to select frequency bands or trying to use the Ethernet connection. I tried it out and it just simply worked – very well. Within hours after I set it up, it notified me that a firmware update was pending. I postponed it but it didn’t do any good – it installed itself anyway the next time I rebooted it. The firmware version now is NTG9X50C_12.05.05.12 (dated 2019/11/26), and it is working fine. The previous firmware on it was dated in the summer of 2018 I believe. I am able to Telnet into it via USB on port 5510 and it allows me to add frequency bands without asking for a password at all (this was after the firmware update – I didn’t try Telnet before the firmware update). Thanks to Olkitu for the Telnet information!  I did mess it up the first time I tried it by overwriting the existing setting for “LTE ALL,” but hitting the factory reset button (near the battery) removed that mistake and I was able to try again.


Using the AT!GSTATUS? command on Telnet, it tells me that the MR1100 is doing CA, using Band 30 as primary, and Bands 12 and 2 as secondary bands. With this combination, it is giving me speeds of 50 – 150 Mbit/sec download, and usually 4 - 10 Mbit/sec upload. Typical download speed in the evenings is about 70. If I need to upload Gigabytes of information, I can force it to select Band 14 only. That improves the upload speed to about 20 or so, but the download speed is “only” about 30. Most of the time I just leave it set to LTE ALL so it can do carrier aggregation. For some reason it won’t include Band 14 in the CA though. I’m guessing it’s because that band is shared with first responders, so including it in CA wouldn’t be appropriate. Still, by itself Band 14 does pretty well. I would expect Band 4 or Band 66 to be involved in the mix, but my tower doesn’t support either of those bands (yet).


I connected the Ethernet port to the WAN port of my home router and it just simply worked without hassle. The only change I made was to disable ETHERNET STANDBY (so that it was always working). Other than that, I didn’t need to enable IP PASSTHROUGH or disable the MR1100 as DHCP server. I did try to disable its DHCP server function once to try something different, but that was a bad idea. After that I couldn’t get into its menu to correct that mistake, even if I connected up via USB. A factory reset and restoring my backup configuration file took care of it. I had to Telnet in again to recreate all the frequency band menu selections because a factory reset wipes those out.

Message 78 of 78
Discussion stats