Reply

Re: Armor on R8000 does not run Vulnerability Scans

sph70
Aspirant

Armor on R8000 does not run Vulnerability Scans

9 days ago I activated the 30 day Armor trial on my R8000 router (Firmware V1.0.4.46_10.1.63) with the primary aim of leveraging the Vulnerability Scan capability for the many devices  I have on my network - 25 according to armor - all of which are Linux, MacOS or iOS based.

 

But to date no scan appears to have been run - cetainly the Bitdefender dashboard that I can access states "Not scanned yet" for all devices.

 

The router has been on permanently during the trial, as have many of the devices attached.

 

According to the 'blurb' available from Netgear (quoted below) such as scan is supposed to run "anytime a new device connects to your network". Is this lack of scanning the reason I see the following in the Nighthawk app for every device: "This %@ is connected via %@" ??

 

How do I get this key functionality of the Armor offering to work? Does it work?

 

----

 

"With NETGEAR Armor, anytime a new device connects to your network a Vulnerability Assessment is run to identify the device, as well as any possible misconfiguration or flaws. Additional checks look at open services (SSH, Telnet), default credentials, and weak passwords. Armor’s Vulnerability Assessment doesn’t end at identifying flaws. It also includes Bitdefender research into all issues affecting IoT devices discovered through manual inspection of the firmware, cloud-based components, and web apps, ultimately giving you a 360° view of the device’s security state, and flags specific vulnerabilities."

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 1 of 14
Orbi-Roc
Luminary

Re: Armor on R8000 does not run Vulnerability Scans

Hi @sph70 . The vulnerability scans will run. The article you quoted means that a vulnerability scan is done the first time you connect a new device to the network; and weekly thereafter. But that weekly schedule is tricky; unless your devices are on line when the scan is scheduled, the scan will be delayed till the following week. Unfortunately, there is no option for user-triggered scan at this time.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 2 of 14
sph70
Aspirant

Re: Armor on R8000 does not run Vulnerability Scans

Thank you for the response - but if I interpret it correctly: Armor will scan at some point, but we have no way to know or even predict when and no way to trigger?

 

I think it a reasonable expectation that when Armor is first activated it must consider all attached devices as "new" and so scan? Even if not I also have devices that first connected to the network after Armor activation as well as multiple devices that are always on and connected since armor was activated. This includes multiple Netgear devices (switches & NAS) that are all hardwired to the R8000.

 

This only gives the impression that this feature simply does not work at all as at least one of my devices should have triggered based on your description

Message 3 of 14
Orbi-Roc
Luminary

Re: Armor on R8000 does not run Vulnerability Scans

@sph70 . I presume that you check the vulnerability scans at the Netgear Armor Portal, is that correct?

 

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 4 of 14
sph70
Aspirant

Re: Armor on R8000 does not run Vulnerability Scans

Yes - I attached a screenshot from the portal to my original post. The only other place I’m aware of that shows the status is the Nighthawk app which also shows no scans performed.

There is nowhere on the R8000 itself that reports anything regarding Armor other than it is enabled.
Message 5 of 14
DexterJB
NETGEAR Moderator

Re: Armor on R8000 does not run Vulnerability Scans

Hi @sph70, there are other users who have reported that a quick reboot of the router triggered the scan. Let us know how that goes.

 

Dexter

Message 6 of 14
cfansoon
Tutor

Re: Armor on R8000 does not run Vulnerability Scans

I guess you need to also install bitdefender onto your computer after your activated Armor.

On the Armor/bitdefender dashboard, click the device you connected to the Netgear router, than click the Install button to install bitdefender onto that device, (assume it is a laptop).

After finish install bitdefender onto that laptop, than click scan (on that laptop). After finish scan, only than the bitdefender on that laptop will report to the Armor/bitdefender dashboard than the scan has been done.

 

 

 

 

 

Message 7 of 14
sph70
Aspirant

Re: Armor on R8000 does not run Vulnerability Scans

@DexterJB: I did reboot the router shortly after activating Armor as a precaution - your post just reminded me of that. To be sure however I have rebooted again this morning. So far no scan has been reported.

 

I note in the Armor Dashboard that there is a "Summary" page for my R8000 router that I hadn't consulted before which specifically states "No Vulnerability Assessment scan performed yet." Each device on my network also states 'Not Scaned Yet' as before

Message 8 of 14
sph70
Aspirant

Re: Armor on R8000 does not run Vulnerability Scans

The client is installed on multiple devices - but this does not change the situation; even those devices remain unscanned as shown here

 

Plus this does not address the issue of non-Windows/MacOS clients not being scanned which is a claimed feature independent of those clients

Message 9 of 14
sph70
Aspirant

Re: Armor on R8000 does not run Vulnerability Scans

Investigating a little further, I am really struggling to see that Armor is doing anything at all beyond giving me a dashboard list of my devices that I already have via the standard R8000 configuration interface.

 

No threats have been reported - this despite the R8000 itself emailing reports of blocked sites. No Vulnerability scans are reported and now I notice the the Nighthawk app shows me an empty Protection Level History  with a "No Data Found" error when I try to view the log after 10 days of operation.

 

The claimed feature set is very attractive - but does it actually work? Does Armor do anything beyond provide yet another interface?

 

My experience so far is the R8000 without armor, together with my previous, much cheaper, anti-malware solution provides equally as much functionality - more even; I don't see the point at all of the iOS armor app at all which just replicates services already freely available to all.

 

Is it worth me investing more time this?

 

Message 10 of 14
cfansoon
Tutor

Re: Armor on R8000 does not run Vulnerability Scans

Sorry, me also a new user, (just started using Armor few days ago).

Before purchase Netgear router, I already have Norton on my Macbook. 

 

My Amor dashboard also showing ""No Vulnerability Assessment scan performed yet"

 

Message 11 of 14
Syphr53
Aspirant

Re: Armor on R8000 does not run Vulnerability Scans

It’s a total waste of time.
Message 12 of 14
DexterJB
NETGEAR Moderator

Re: Armor on R8000 does not run Vulnerability Scans

Hi @sph70, I have sent you a message. Please check your inbox.

 

Dexter

Message 13 of 14
cfansoon
Tutor

Re: Armor on R8000 does not run Vulnerability Scans

Today I tried this and everything looks ok:

 

Prior to this, I already installed Bitdefender onto my MacBook,
From my iPad/iPhone start the Nighthawk app, than click the [Amor security] icon.
It will display list of protected devices, those online devices will have a green dot next to it,
than I click the [MacBook] icon, and than click [Device Security],
Next screen it display a button [Run a scan].
I than click [Run a Scan] from my iPad/iPhone
And this trigger the Bitdefender on my MacBook to run scan,
After finish scan, the Amor app on my iPad/iPhone display "Device Scan, Scanned at 01:20PM"
(Scan done at 01:20PM)
and display Threats Blocked (number of threads blocked).

Message 14 of 14
Top Contributors
Discussion stats
  • 13 replies
  • 3053 views
  • 1 kudo
  • 5 in conversation
Announcements

Orbi WiFi 6E